Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

25 Posts

02-16-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

335 Page Views

  • Posts: 25
  • Registered: ‎02-16-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 335
  • Message 41 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-18, 10:51 AM

Ok so this problem still persists and it appears to be a windows 10 / drivers issue that still doesn't have a comprehensive solution.

running latencymon the culprits seem to be 'HDAudBus.sys', 'ndis.sys', 'tcpip.sys' primarily but other *.sys can show up too

 

latency dpc

 

Just do a search for "hdaudbus.sys (or any other ones i've mentioned )dpc latency" and there's a whole world reporting the same pop/crackling/stuttering issues that remain open topics with no known fixes.

 

Might be worth giving this a shot, it seems to be solving the issues for some (but not for me).

https://www.sysnative.com/forums/threads/system-interrupts-latency-hdaudbus-sys.22339/page-2

 

 

 

Reply
Options

20 Posts

03-04-2019

United States of America

30 Signins

131 Page Views

  • Posts: 20
  • Registered: ‎03-04-2019
  • Location: United States of America
  • Views: 131
  • Message 42 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-18, 17:51 PM

I think I found the SUS driver. When I installed the Lenovo Vantage Gaming Feature Driver (1.0.0.26), via the Lenovo Vantage update the stutters appeared.

 

!!!44!!4! @lenovo pls fix !!!44!!4!

Reply
Options

77 Posts

01-10-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

480 Page Views

  • Posts: 77
  • Registered: ‎01-10-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 480
  • Message 43 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-18, 22:24 PM

Hello all again,

 

It seems I missed a lot of posts, I received a notification for this today but nothing for other people's.

 

Congrats on the new machine, I think... but you must be more than frustrated to have the same issue? That is absurd!

 

That is an interesting potential solution you found in that link. I made the registry changes earlier and ran LatencyMon. Granted, I have not run it in a while, but here are the results:

 

 

I have to say, those are probably the best results I've had, especially the ISR execution time. Normally after 2-5mins everything is already in the red. Obviously, I am reluctant to say that has fixed it, too many times I thought I clear and the grinding/freeze return. It doesn't seem to have hurt, so thank you for sharing that. If I still get the usual freezes I will update. In fact, I may revert the changes and run LatencyMon to compare.

 

When you tried, how many registry keys did you change? I overlooked what one user wrote at first, and only changed the Realtek entry listed in Device Manager, however running the following command I got 2 results:

 

reg query HKLM\SYSTEM\CurrentControlSet\Enum\PCI\ /s /f hdaudbus

 

Both had MSIsupported, so I changed the values to 1. I'm not sure if that affects anything for you?

 

Also, I recently tried a different experiment and I was able to reproduce the freezing 3 or 4 times in a row relatively easily, that is how I got some results from the Windows Performance Analyser. I had the laptop plugged in using it normally, I then closed the lid to put it to sleep, once the lid was closed, I turned the power off at the mains. After 15-20mins, I opened the laptop from its sleep whilst running on battery power, I immediately started a video playing once on the desktop and with a few minutes I would get the 2-3sec freeze/grind. I had this happen every time. However, I tried again the other day hoping to record it and of course, it didn't happen. Sod's law!

 

Whether some system power state is yet another cause of these issues, I have no idea?

 

AL

 

Edit: misquoted so removed the reply. I was replying to @cccat. 

 

Edit #2: Ignore most of that. Just had 2 big freezes in 5mins!

Reply
Options

25 Posts

02-16-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

335 Page Views

  • Posts: 25
  • Registered: ‎02-16-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 335
  • Message 44 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-19, 7:17 AM

@AtLocke I added the 'MSISupported' flag to the wifi, sound and graphics card devices. But in my case it didn't improve the latencies.

 

I found this in the same forum. It's more of a hack than a fix though it seems to trade one problem for another in my case the stutter is still there but it is much shorter in duration, 1/4th seconds rather than 2-3 seconds. The random pop / crackling sounds are more frequent but it is less noticeable. If I wasn't such an audiophile I probably wouldn't notice it.

 

However by luck it seems to fix the guy's legion 5p in the last post of the thread in the link so maybe it will work for you guys.

 

https://www.sysnative.com/forums/threads/latency-issue-audio-cracks-pops-on-a-new-lenovo-legion-5-laptop.32554/

 

It involves tinkering with the c-states of the cpu which you can read about here for a general explanation

https://www.dell.com/support/kbdoc/en-uk/000060621/what-is-the-c-state

 

How it works on a ryzen cpu

https://forums.guru3d.com/threads/windows-power-plan-settings-explorer-utility.416058/page-5

 

How to disable c-states with Quick CPU utility.

 

Good luck and keep us posted.

Reply
Options

77 Posts

01-10-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

480 Page Views

  • Posts: 77
  • Registered: ‎01-10-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 480
  • Message 45 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-19, 9:36 AM

Good Morning, @cccat and everyone,

 

Thank you for the links, I shall have a read through them. What annoys me is that customers have to go to these lengths on essentially brand-new machines. A little acknowledgement from these huge manufacturers would go a long way here.

 

Just so I know I'm not going completely mad, I installed OBS today to capture a desktop sample, I had to listen to this on loop for an hour or so (good fun!) but got a clip. I have had it freeze/stutter much harder, but still.

 

Could yourself and any others involved in, or just following this thread confirm this is similar to what they are experiencing? I would much appreciate it.

 

For irony's sake, I had to use a Lenovo video haha. A bit of a volume warning by the way!

 

 

Thanks Lenovo!

 

AL

Reply
Options

2 Posts

06-07-2021

Singapore

8 Signins

60 Page Views

  • Posts: 2
  • Registered: ‎06-07-2021
  • Location: Singapore
  • Views: 60
  • Message 46 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-19, 9:44 AM

The exact same problem. Video and audio stutter with the mouse cursor lagging across.

 

The problem persisted even after I used DDU to do a clean reinstallation of the AMD and Nvidia drivers. Reinstalling Windows didn't work for me too.

 

Currently trying out @cccat's thread on the processor idle demote threshold change to 100%.

 

@AtLocke Thank you for the video reference!

 

Edit: Unfortunately, @cccat's post on the processor idle demote threshold change to 100% did not work for me. Stutter occurred twice when I was in-game.

 

Where are the admins and support when we need them?

Reply
Options

25 Posts

02-16-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

335 Page Views

  • Posts: 25
  • Registered: ‎02-16-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 335
  • Message 47 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-19, 9:57 AM
Pretty much this and the crackling / pop sound through the speakers / headphones when it happens.
Reply
Options

11 Posts

10-16-2020

United States Minor Outlying Islands

15 Signins

160 Page Views

  • Posts: 11
  • Registered: ‎10-16-2020
  • Location: United States Minor Outlying Islands
  • Views: 160
  • Message 48 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-19, 9:58 AM

I experienced the same issue (brief and random audio stutters when watching or listening to on/offline contents), and LatencyMon showed 3-50ms delays after testing it throughout a 2h 1080p movie - no matter what power state.

 

No matter what power state, I keep getting micro stutters on this €1800 laptop - even my slow €500 ThinkPad T480 doesn't have this issue.

 

I was able to reduce the micro stutters to 3ms by formatting everything, reinstalling vanilla June or newer Win10 Pro ISO, let Win install all updates, restart 5x then let Vantage install the rest.

You can still hear the stutters though sometimes.

 

ATTENTION: I have a German Legion 5 Pro (5800H, 32GB, 1TB, RTX 3070) which is missing H.264 and NVENC features because Lenovo BIOS updates silently remove these features.

20210710 Lenovo legion 5 Pro - 50ms audio stutter.PNG
Reply
Options

77 Posts

01-10-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

480 Page Views

  • Posts: 77
  • Registered: ‎01-10-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 480
  • Message 49 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-19, 10:22 AM

Thanks for the quick confirmation everyone.

 

I only asked because I got a little peeved reading an earlier admin post, where they were essentially saying it is likely a user error. I just want as many people to come forward and confirm they are having the same issue. This is not a user problem as far as I'm concerned and needs addressing. It makes using these machines a miserable experience as I'm sure you all know.

Reply
Options

25 Posts

02-16-2021

United Kingdom of Great Britain and Northern Ireland

50 Signins

335 Page Views

  • Posts: 25
  • Registered: ‎02-16-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 335
  • Message 50 of 393

Re:Legion 5P 15ARH05H micro stutters

2021-07-19, 13:16 PM

This thread is getting busy today.I just had another 2 stutter events but it didn't even trigger anything on latecymon the bars are all still in the green (running for 10 mins now). We are no where closer to a solution since my very first post.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms