Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

4 Posts

10-11-2020

Switzerland

4 Signins

40 Page Views

  • Posts: 4
  • Registered: ‎10-11-2020
  • Location: Switzerland
  • Views: 40
  • Message 1 of 13

Legion 7i Second NVMe M.2 SSD not detected

2020-10-11, 9:58 AM

Hello,

 

I have a problem with a newly installed second SSD (Corsair MP510) that is not detected on my Legion 7i.

 

Steps done so far 

1) Physically installed the second SSD drive (new) in the free NVMe M.2 slot ; then booted the device without problems

2) Check in Disk Management : the drive is not listed at all, so cannot partition / format

3) Check in device manager -> Disk drives, "scan for hardware changes" : the new SSD didn't show up 

4) Check in Bios. Yes, it shows 2 drives !

     Slot 1 : the original SSD coming with the laptop (Samsung)

     Slot 2 : the newly installed Force MP510

5) Downloaded Corsair SSD toolbox, but it did not see the SSD neither

6) Started in Advanced Bios. Again, the drive is there and can even see it's serial number etc. 

    - Don't see options that would allow to edit relevant configurations

    - Intel RST controller is active (not AHCI). Changing to AHCI gives a scary warning that it will wipe all data, so I keep it on RST.

7) After exiting advanced bios , the Windows immediately run into a BSOD loop with KERNEL SECURITY CHECK FAILURE. The only way to revolve this BSOD loop was to physically remove the SSD. 

8) Re-installed the SSD (of course not detected , again ...)

 

So, basically the Bios sees the Force MP510 SSD , meaning it's correctly installed on HW side and the SSD is not defect.

Still, Windows 10 does not find it, probably some driver issues but all sees updated (see below for details).

 

I'm kindly asking if you have an idea what else I could check, or if you resolved a similar situation already? Thank you!

 

Best regards

 

Machine : Legion 7i , 15IMHg05

SSD drive : Corsair MP510,  NVMe SSD M.2 2280 form factor

Windows 10, Version 2004 (OS Build 19041.508), check for Windows update is empty list

Storage Controller : Intel(R) Chipset SATA/PCIe RST Premium Controller (17.9.0.1007, driver date 23.Apr.2020 - up to date)

Lenovo update : everything updated

 

 

 

Reply
Options

4 Posts

10-11-2020

Switzerland

4 Signins

40 Page Views

  • Posts: 4
  • Registered: ‎10-11-2020
  • Location: Switzerland
  • Views: 40
  • Message 2 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2020-10-12, 19:28 PM

Update to post 1:

 

 1) I added a picture showing the 2 SSD's in BIOS to support my claim

 2) I run "Lenovo Diagnostics Windows", and passed Motherboard , PCIe test, Storage test. No issues found, only 1 SSD drive.

 

Lenovo Support team, please can you kindly provide answers to following questions:

 

  • Legion 7i supports up to 2 NVMe M.2 according https://psref.lenovo.com/Product/Legion/Lenovo_Legion_7_15IMHg05  . Is that correct?
  • Please confirm if Corsair MP 510 NVMe M.2 SSD's are supported or not. Mine is:

   https://www.corsair.com/eu/en/Categories/Products/Storage/M-2-SSDs/Force-Series-MP510/p/CSSD-F4000GBMP510#tab-tech-specs

  • Explain how to configure the SSD in BIOS so it shows up in Windows. 

 

Thank you!

 

Best regards

 

Reply
Options

4 Posts

10-11-2020

Switzerland

4 Signins

40 Page Views

  • Posts: 4
  • Registered: ‎10-11-2020
  • Location: Switzerland
  • Views: 40
  • Message 3 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2020-10-15, 20:10 PM

 

Hello,

 

It' s very unusual that an SSD drive is not recognized in Windows. 

 

Since it's a Lenovo motherboard, I would more think it's a limitation on Lenovo's Legion 7i bios to support a second SSD. 

 

Was someone trying to switch from RAID to AHCI, and did that help to make the SSD to show up?

 

Thank you!

 

 

Reply
Options

2 Posts

08-23-2020

United States of America

2 Signins

20 Page Views

  • Posts: 2
  • Registered: ‎08-23-2020
  • Location: United States of America
  • Views: 20
  • Message 4 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2020-11-28, 23:14 PM

I am having the same problem with a Samsung 970 evo plus being not recognized as a second drive. It's shows up in Bios, but not in windows or is not recognized by Samsung magician software.

Did you ever get your problem resolved?

 

Thanks.

Reply
Options

1 Posts

12-13-2020

United States of America

4 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎12-13-2020
  • Location: United States of America
  • Views: 0
  • Message 5 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2020-12-13, 8:38 AM

I have the same problem with the Samsung 070 plus.  Any updates?

Reply
Options

1 Posts

01-11-2021

United Kingdom of Great Britain and Northern Ireland

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎01-11-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 0
  • Message 6 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2021-01-11, 18:42 PM

Hi, I bought the same SSD Samsung 970 EVO Plus NVMe M2 (1Tb) today and, after installing it, I found myself with the same issue. I don't know if you got it sorted or not but even if it is a bit late for you it could still be helpful to someone else.

 

As said, my new SSD did not appear initially on Windows but it did show when booting on the BIOS which implied it was a software problem. Only two steps were needed to solve it:

1. Update the storage controller named Intel(R) Chipset SATA/PCIe RST Premium Controller (this can be found in "device manager") and you can get there easily by right clicking on "This PC" window and going into properties.

2. Even after updating the controller, it is very possible that the new SSD will not appear under "This PC" yet. That's because if it is a new component it needs to be partitioned. If  you are unsure about using windows tools you can download a disk management software to do so, I have used the free version of Partition Master for this type of stuff before but any would do. Once it has been partitioned then you are set.

Reply
Options

7 Posts

12-14-2020

Germany

11 Signins

80 Page Views

  • Posts: 7
  • Registered: ‎12-14-2020
  • Location: Germany
  • Views: 80
  • Message 7 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2021-01-12, 7:53 AM

I ran into the same issue with an 1TB WD Blue SSD. Not recognized in the BIOS and also in Windows.

My solution: Go into the advanced bios (normal bios won´t work), don´t change anything and "save WITH changes" although nothing was changed.

After reboot i was able to partition and format the ssd in Windows.

This worked for me. Good luck...

Reply
Options

5 Posts

11-14-2020

Switzerland

4 Signins

30 Page Views

  • Posts: 5
  • Registered: ‎11-14-2020
  • Location: Switzerland
  • Views: 30
  • Message 8 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2021-01-13, 15:17 PM

Having the exact same problem. My setup is the Legion 7 15 inch and a Corsair MP400, 4TB.

I get the same whole shennanigan with Bios loop, SSD detected in Bios but not Windows and all.

Tried everything mentioned so far. Updated Bios, updated device drivers. SSD in and out 10 times, Advanced Bios,.... but nothing, nada. An older 1TB SSD in the same slot works without problems.

Laptop is brand new. Really wonder if I shall return the SSD or the laptop. Not that happy with a few things. Regretting heavy to make the switch from ASUS to Lenovo so far. Tons of troubles and that **bleep**ty rainbow keyboard doesn't make my mood better.

Any real help here Lenovo?

Reply
Options

5 Posts

11-14-2020

Switzerland

4 Signins

30 Page Views

  • Posts: 5
  • Registered: ‎11-14-2020
  • Location: Switzerland
  • Views: 30
  • Message 9 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2021-02-17, 11:32 AM

So I gave the SSD back and bought another 4TB SSD, different model, also from Corsair. Same result. Did anyone find a solution for this? I need a 4TB SSD working, if there is no workaround I have to sell this laptop & get one not from Lenovo.

Reply
Options

5 Posts

11-14-2020

Switzerland

4 Signins

30 Page Views

  • Posts: 5
  • Registered: ‎11-14-2020
  • Location: Switzerland
  • Views: 30
  • Message 10 of 13

Re:Legion 7i Second NVMe M.2 SSD not detected

2021-02-17, 12:29 PM

Update. So, I talked with Lenovo Support - Seems like they never read the forums or give answers on questions here - and it seems like that the Legion 7 has as max SSD capacity 1TB. Any SSD over 1TB will most likely give you problems.

So there you go. No solution in sight. Going back to Asus now. Bye bye

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms