cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
P28111
Not applicable
Posts: 18
Registered: ‎07-06-2018
Location: NO
Views: 185
Message 1 of 3

Legion Y520-15IKBN Fail to update BIOS

Hi i have a Legion Y520-15IKBN laptop and I am unbale to update my bios. Things I have tried updating it with the lenovo vantage program but it gives me this message fail 1 update failed to download and install, I tried downloading the bios from the support website and it gave me this error message, mount the efi system partition. Im on the latest version of windows 10 my drivers are also all up to date. I have added a few screenshot to my post showing my issue. Also my bios is just called bios. I tried doing it via the support website under the automatic updates tab but that does also not work.29b056b2ca5a8b05edf5cc9e63e6f04e.png

 

d4402ec5d48a6682b93009982abf3d0c.png405c65629c4e4f5e4a48fe8c6bfd3f73.pngBIOSPIC.png

Highlighted
Jwes_Lenovo
Not applicable
Posts: 1,046
Registered: ‎08-02-2018
Location: US
Views: 57
Message 2 of 3

Re: Legion Y520-15IKBN Fail to update BIOS

Hi P28111! Here is a similar discussion here: https://forums.lenovo.com/t5/Lenovo-IdeaPad-1xx-3xx-5xx-7xx/quot-mount-the-Efi-system-partion-faild-....



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

masterpiece22
Not applicable
Posts: 5
Registered: ‎07-11-2019
Location: ID
Views: 24
Message 3 of 3

Re: Legion Y520-15IKBN Fail to update BIOS

any luck my friend? i want to update my bios too

Check out current deals!


Shop current deals

Top Kudoed Authors