cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
piyush29
What's DOS?
Posts: 1
Registered: ‎01-17-2018
Location: IN
Views: 1,337
Message 1 of 5

Legion Y520 - F4, F7,and F8 key does not work

When I initially booted my Lenovo Legion Y520 , pressing F1 F2 F3 work fine for volume controls with a UI prompt for the function.

Pressing F4 toggled the mic mute with a UI prompt.

F5 could be used to refresh a webpage.

F6 toggled the use of the touchpad, but did not show a UI prompt.

F7 toggled airplane mode with UI prompt.

F8 toggled camera function with UI prompt.

F9 locks fine.

F10 works fine too.

F11 F12 toggles brightness with UI prompt.

 

I don't know what happened along the way, but now F4 (mic), F7 (airplane mode), F8 (camera) stopped working. Nothing happens when I press the buttons. I'm running Windows 10 Home, version 1709, OS Build 16299.192.

 

Maybe someone can help me in restoring the functions of those buttons? And additionally, maybe add a UI prompt for F6 (touchpad)?

 

 

Moderator comment: Model added to subject for clarity.

Retired Moderator
Retired Moderator
Posts: 13,719
Registered: ‎12-07-2009
Location: CZ
Views: 1,304
Message 2 of 5

Re: F4, F7,and F8 key does not work

For the old system ( Idepad Y series) it was related to Power ( Energy ) Management drivers. You can try to re-install it


http://www.krasotaiskusstva.com
Robzta
Blue Screen Again
Posts: 4
Registered: ‎02-15-2018
Location: AU
Views: 1,118
Message 3 of 5

Re: F4, F7,and F8 key does not work

I had the same problem my F4, F7 and F8 buttons were not working all of the sudden, I think they stopped working when I updated the BIOS.  I searched for a solution but I nothing worked until I noticed that my Lenovo Utility app was gone or got unninstalled somehow, so I installed it back up again & it promted me to restart the pc, when I restarted my pc nothing hapenned, so I checked task manager under startup programs & Lenovo Utility was on disabled so I enabled it & restarted my pc once more & it worked because all the buttons are now working fine.

RahulM06
What's DOS?
Posts: 1
Registered: ‎09-08-2018
Location: IN
Views: 573
Message 4 of 5

Re: F4, F7,and F8 key does not work

Thanks for solution. I had same problem since last once month and i was unable to find soltion. And your solution worked for me perfectly.
WitheredAngel
What's DOS?
Posts: 1
Registered: ‎09-16-2018
Location: US
Views: 496
Message 5 of 5

Re: F4, F7,and F8 key does not work

Thank you for your comment. I disabled my Lenovo Utility App Smiley Sad. But now I fixed it. Thank you

Check out current deals!


Shop current deals

Top Kudoed Authors