cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mansour-farokhi
Ctrl-Alt-Del
Posts: 18
Registered: ‎12-03-2017
Location: AE
Views: 214
Message 1 of 13

Legion Y530-1060 - PCI express system status test failed - system runs smoothly

Hi everyone 

yesterday i was playign some btf 3 and after i finished the game i recived a notification to run system diognostic through Lenovo Vantage.
After 30 min of waiting everything is good except PCI Express system.
The laptop is new, barely used and is runing flawlessly. Then i installed lenevo Diognostic Tool and it says that the issue is with my ethernet controller , i checked and ethernet port is working without a hiccup. kindly check the details and see if u can help me my best guess is that its software issue.

As mentioned everything is working properly , device is not overhitting and comes up fast after every restart , I also have updated all fo the outdated drives.

PS : This issue happend after windows update today.

EDIT : After a restart it passes the test but after a long session of gaming ( around 1 hour) if i test it it fails again.

UDI:PCI Express System
PCI0:0:2.0
PCI1:6:0.0
PCI2:7:0.0
PCI3:8:0.0
Resources: 
Resource type:Device
Index:0
Bus:0x0
Device:0x2
Function:0x0
Device Connected:NO
Vendor Id:0x8086
Vendor Name:Intel Corporation
Class:0x3
Class Name:Display controller
Subclass:0x0
Subclass name:VGA compatible controller
  
Resource type:Device
Index:1
Bus:0x6
Device:0x0
Function:0x0
Device Connected:YES
Vendor Id:0x144d
Vendor Name:Samsung Electronics Co Ltd
Class:0x1
Class Name:Mass storage controller
Subclass:0x8
Subclass name:Non-Volatile memory controller
  
Resource type:Device
Index:2
Bus:0x7
Device:0x0
Function:0x0
Device Connected:YES
Vendor Id:0x10ec
Vendor Name:Realtek Semiconductor Co., Ltd.
Class:0x2
Class Name:Network controller
Subclass:0x80
Subclass name:Network controller
  
Resource type:Device
Index:3
Bus:0x8
Device:0x0
Function:0x0
Device Connected:YES
Vendor Id:0x10ec
Vendor Name:Realtek Semiconductor Co., Ltd.
Class:0x2
Class Name:Network controller
Subclass:0x0
Subclass name:Ethernet controller
  
11-Jan-19 05:16:03 - Status TestFailed (0s)
11-Jan-19 05:16:03 - Warning Fatal Error Detected in PCI device present on Bus: 0x8 Device: 0x0 Function: 0x0.
Dan_Petrescu
SCSI Port
Posts: 76
Registered: ‎09-02-2018
Location: RO
Views: 210
Message 2 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly


@Mansour-farokhi wrote:

Hi everyone 

yesterday i was playign some btf 3 and after i finished the game i recived a notification to run system diognostic through Lenovo Vantage.
After 30 min of waiting everything is good except PCI Express system.
The laptop is new, barely used and is runing flawlessly. Then i installed lenevo Diognostic Tool and it says that the issue is with my ethernet controller , i checked and ethernet port is working without a hiccup. kindly check the details and see if u can help me my best guess is that its software issue.

As mentioned everything is working properly , device is not overhitting and comes up fast after every restart , I also have updated all fo the outdated drives.

PS : This issue happend after windows update today.

UDI:PCI Express System
PCI0:0:2.0
PCI1:6:0.0
PCI2:7:0.0
PCI3:8:0.0
Resources: 
Resource type:Device
Index:0
Bus:0x0
Device:0x2
Function:0x0
Device Connected:NO
Vendor Id:0x8086
Vendor Name:Intel Corporation
Class:0x3
Class Name:Display controller
Subclass:0x0
Subclass name:VGA compatible controller
  
Resource type:Device
Index:1
Bus:0x6
Device:0x0
Function:0x0
Device Connected:YES
Vendor Id:0x144d
Vendor Name:Samsung Electronics Co Ltd
Class:0x1
Class Name:Mass storage controller
Subclass:0x8
Subclass name:Non-Volatile memory controller
  
Resource type:Device
Index:2
Bus:0x7
Device:0x0
Function:0x0
Device Connected:YES
Vendor Id:0x10ec
Vendor Name:Realtek Semiconductor Co., Ltd.
Class:0x2
Class Name:Network controller
Subclass:0x80
Subclass name:Network controller
  
Resource type:Device
Index:3
Bus:0x8
Device:0x0
Function:0x0
Device Connected:YES
Vendor Id:0x10ec
Vendor Name:Realtek Semiconductor Co., Ltd.
Class:0x2
Class Name:Network controller
Subclass:0x0
Subclass name:Ethernet controller
  
11-Jan-19 05:16:03 - Status TestFailed (0s)
11-Jan-19 05:16:03 - Warning Fatal Error Detected in PCI device present on Bus: 0x8 Device: 0x0 Function: 0x0.

Hello,

Go to Device manager->Storage controllers and update the drivers manually, both of them. Then go to System Devices and update them one by one, I know, they are too many, but just do it. Hope this will help you.

Mansour-farokhi
Ctrl-Alt-Del
Posts: 18
Registered: ‎12-03-2017
Location: AE
Views: 198
Message 3 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly

There is only two in that section which has been upded yesterday , yesterday i updated all of the drivers which had a newer version and rolled back those i though could be casuing it nothing at all.

The two drivers are : 

Microsoft Storage Space controller 

Standard NVM Express controller 

Highlighted
Dan_Petrescu
SCSI Port
Posts: 76
Registered: ‎09-02-2018
Location: RO
Views: 194
Message 4 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly


@Mansour-farokhi wrote:

There is only two in that section which has been upded yesterday , yesterday i updated all of the drivers which had a newer version and rolled back those i though could be casuing it nothing at all.

The two drivers are : 

Microsoft Storage Space controller 

Standard NVM Express controller 


What about those under "System devices" section ? Did you update them aswell ?

Mansour-farokhi
Ctrl-Alt-Del
Posts: 18
Registered: ‎12-03-2017
Location: AE
Views: 189
Message 5 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly

Yeah i missed 2 and i updated them now , the test passed just now but this happend before after the restart  the test passes but after half an hour again it might fail.

Yesterday this happend i updated SATA controlloer and restarted it passed then i watched some yotube checked again and it failed , again there is no issue whatsoever and i really dont want to take it to the shop since the repaier center in here is terrible ,takes for ever and device comes back with more issue.

Again thank you , ill check if it fixed it ill choose this an answer.

I updated power button and virtual power button controller 

Mansour-farokhi
Ctrl-Alt-Del
Posts: 18
Registered: ‎12-03-2017
Location: AE
Views: 187
Message 6 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly

Yup as suspected after playing for a while it failed again with the same error list provide here 

Dan_Petrescu
SCSI Port
Posts: 76
Registered: ‎09-02-2018
Location: RO
Views: 184
Message 7 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly


@Mansour-farokhi wrote:

Yup as suspected after playing for a while it failed again with the same error list provide here 


What BIOS version do you have installed ? Is it the latest ? If not, try to update to the latest BIOS version.

*EDIT*

Now I see, you have this problem after windows update. Try to open command prompt as Administrator and run this: Dism /Online /Cleanup-Image /RestoreHealth

Maybe during the windows update some files got corrupted or something..

Mansour-farokhi
Ctrl-Alt-Del
Posts: 18
Registered: ‎12-03-2017
Location: AE
Views: 169
Message 8 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly

Thank you for the tip ,Again it passed the test , but i left the device on for maybe half an hour and it was ideling. could it be when i try to play games this happens ? device doesnt heatup and thermal controller works perfectly.

ill check again and make you anwser as the solution after a match of CS GO.

Mansour-farokhi
Ctrl-Alt-Del
Posts: 18
Registered: ‎12-03-2017
Location: AE
Views: 160
Message 9 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly

Played the game came out again passed i think we are good.

thank you for the solution mate it was making me go crazy i spend a month salary on this.

Dan_Petrescu
SCSI Port
Posts: 76
Registered: ‎09-02-2018
Location: RO
Views: 157
Message 10 of 13

Re: Legion Y530-1060 - PCI express system status test failed - system runs smoothly


@Mansour-farokhi wrote:

Played the game came out again passed i think we are good.

thank you for the solution mate it was making me go crazy i spend a month salary on this.


You are welcome Smiley Happy

Check out current deals!


Shop current deals

Top Kudoed Authors