English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

8 Posts

03-02-2019

US

17 Signins

160 Page Views

  • Posts: 8
  • Registered: ‎03-02-2019
  • Location: US
  • Views: 160
  • Message 1 of 9

Legion Y530 sound issues fix

2019-03-07, 23:19 PM

How to fix realtek hd audio losing first second of playback of notifications, crack and pops (cause: device being switched to low power mode all the time by driver):
use regedit  to edit
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\xxxx\PowerSettings
where xxxx - number from 0000 and up, look for DriverDesc value of "Realtek High Definition Audio"
Change ConservationIdleTime to ff ff ff 00
Change PerformanceIdleTime to ff ff ff 00
where ff ff ff 00 - time in seconds. Driver default values 03 00 00 00 - 3 seconds, which is causing all the problems. Value of 00 00 00 00 (no sleep timer) is not supported by realtek driver!
reboot to apply.

 

more details about audio device class inactivity timer: https://docs.microsoft.com/en-us/windows-hardware/drivers/audio/audio-device-class-inactivity-timer-implementation

 


If you are missing separate playback and recording devies in realtek hd audio (like I do, using headset for skype and listening to music from speakers are convinient):
Search and download AudioDevice_sky.rar  - realtek driver configuration editing tool.
There is no RTKHDAUDIO.DAT file present, it's ok. Go to driver policy tab, press "get policy driver" button, press "save".

Open "JackCfg" subsection, and enable "10-PBIndependentSupport", "14-RecIndependentSupport".
Press "save" again, reboot to reload driver.
You can now see separate headphones and speakers (playback) and microphone array and headset microphone in recording in windows "sound" control panel.

Reply
Options

8262 Posts

01-13-2008

US

77228 Signins

2188549 Page Views

  • Posts: 8262
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2188549
  • Message 2 of 9

Re: Legion Y530 sound issues fix

2019-04-13, 20:41 PM

The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

3 Posts

09-28-2019

RO

2 Signins

24 Page Views

  • Posts: 3
  • Registered: ‎09-28-2019
  • Location: RO
  • Views: 24
  • Message 3 of 9

Re: Legion Y530 sound issues fix

2019-09-28, 23:13 PM

Hi, can you give me a download link for  audioDevice_sky.rar?
Thank you !

Reply
Options

3 Posts

09-28-2019

RO

2 Signins

24 Page Views

  • Posts: 3
  • Registered: ‎09-28-2019
  • Location: RO
  • Views: 24
  • Message 4 of 9

Re: Legion Y530 sound issues fix

2019-09-28, 23:15 PM
i've tried to modify the registers, i've modified from 03 00 00 00 to 00 00 00 00 but the poping sound is still there
Reply
Options

8 Posts

03-02-2019

US

17 Signins

160 Page Views

  • Posts: 8
  • Registered: ‎03-02-2019
  • Location: US
  • Views: 160
  • Message 5 of 9

Re: Legion Y530 sound issues fix

2019-09-30, 6:28 AM

No, I can't provide a link, but I can google it for you:

https://www.google.com/search?q=%22audioDevice_sky.rar%22&oq=%22audioDevice_sky.rar%22

Reply
Options

8 Posts

03-02-2019

US

17 Signins

160 Page Views

  • Posts: 8
  • Registered: ‎03-02-2019
  • Location: US
  • Views: 160
  • Message 6 of 9

Re: Legion Y530 sound issues fix

2019-09-30, 6:29 AM

Hey, why do you do this to yourself? 00 00 00 00 is not supported by the driver. Please set to FF FF FF 00 and reboot.

Reply
Options

3 Posts

09-28-2019

RO

2 Signins

24 Page Views

  • Posts: 3
  • Registered: ‎09-28-2019
  • Location: RO
  • Views: 24
  • Message 7 of 9

Re: Legion Y530 sound issues fix

2019-09-30, 20:58 PM

i've changed to ff ff ff 00 and it still pops ; i've also tried the AudioDevice_sky.rar and it still pops. i would apriciate if we could use team viewer or something to help me overcome the problem :)

Reply
Options

12 Posts

08-12-2016

IL

44 Signins

236 Page Views

  • Posts: 12
  • Registered: ‎08-12-2016
  • Location: IL
  • Views: 236
  • Message 8 of 9

Re: Legion Y530 sound issues fix

2019-12-03, 11:13 AM
Thanks for taking the time and posting this. It seemed really promising, but unfortunately it didn't work for me. It's really so annoying. I'm on a new S340-14IIL and am really considering returning it. Using a usb audio card solves it, but I'm not going to travel around with it on a new laptop. I've tried EVERYTHING.
Reply
Options

6 Posts

03-27-2019

MY

6 Signins

326 Page Views

  • Posts: 6
  • Registered: ‎03-27-2019
  • Location: MY
  • Views: 326
  • Message 9 of 9

Re: Legion Y530 sound issues fix

2019-12-12, 9:44 AM

this fix was working fine for me for a very long time until my y530 auto updated itself to win10 1909 build today...

 

normally after a big win10 update, the regedit changes defaults itself back to 03 00 00 00.. but its fine because normally i can change it back to ff ff ff 00 in the regedit and the audio lag will go away..

 

however after the 1909 update the audio lag came back.. and when i tried to do the regedit changes like before, it doesnt work anymore this time.. so even with the regedits and after restarting, the audio lag is still there but in regedit the values are indeed changed..\

 

 

Hoping anyone else can help on this!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete