Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

1 Posts

05-04-2021

Philippines

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎05-04-2021
  • Location: Philippines
  • Views: 5
  • Message 1 of 2

Legion Y540 got stuck on logo at boot up

2021-05-04, 12:48 PM

My legion y540 (still under warranty) is stuck up at logo during boot up. Downloaded a system recovery from Lenovo support. Its been 2.5 hrs already and it is still not done. Is it normal? How long should I wait before i give up? Thanks.

Reply
Options

2656 Posts

04-23-2019

United States of America

551 Signins

21774 Page Views

  • Posts: 2656
  • Registered: ‎04-23-2019
  • Location: United States of America
  • Views: 21774
  • Message 2 of 2

Re:Legion Y540 got stuck on logo at boot up

2021-05-04, 13:49 PM

Hello @ThisIsMich,

 

Welcome to the Community Forums.

 

I once tried recovery and it took a few hours.

You might want to try and leave it overnight just to make sure that the recovery process isn't ended prematurely.

Hope this helps.
Regards,
Jack_Lenovo1



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms