Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

13 Posts

02-10-2021

Viet Nam

14 Signins

150 Page Views

  • Posts: 13
  • Registered: ‎02-10-2021
  • Location: Viet Nam
  • Views: 150
  • Message 21 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-02-22, 3:30 AM

Thank you for replying,

 

Could you link me to the reddit thread? I made some searchs, given several threads but seem not the one you mention.

In one thread I saw a user with the same XMC chip, bricked then he flashed the backup from another machine. But he's absent for 2 months...

Maybe I'm looking for luck in the thread you mentioned.

 

Thank you in advance.

Reply
Options

13 Posts

02-10-2021

Viet Nam

14 Signins

150 Page Views

  • Posts: 13
  • Registered: ‎02-10-2021
  • Location: Viet Nam
  • Views: 150
  • Message 22 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-02-22, 15:35 PM

Finally, I got my machine with XMC bios chip revive by using Neo Programmer 2.1.0.19.

 

Let me cite a full instruction of what should be done to flash the BIOS back with CH341a Programmer:

 

If your BIOS chip is the Winbond 25q125jvsq, this is the process from @Nitin29 (I see the same two names, please let me know if you are not the Nitin29 at forums.mydigitallife.net)

Link: https://forums.mydigitallife.net/threads/solved-lenovo-legion-y740-15irh-bios-recovery.83063/page-2#post-1645169)

 

Complete process to flash main bios chip/ic using CH341a SPI Programmer (confirmed on Lenovo Legion Y740 15IRHg):
(DISCLAIMER: I will not be responsible for any kind of damage you might do following the these steps.)

1. Grab programmer CH341a drivers and AsProgrammer from the first. From internet download HxD hex viewer/editor too.
Go to : https://github.com/boseji/CH341-Store

2. Read this page to get idea how to use the programmer in real case :
https://jensd.be/980/linux/bios-or-spi-programming-on-windows-or-linux-using-a-ch341a

3. Grab bios file of the version from lenovo website that you want to flash to your device, url for bios exe and readme txt from v1.06 to v1.11.
Don't forget to download the readme file. Read and confirm if the BIOS is for your laptop model number.

V1.06
https://download.lenovo.com/consumer/mobiles/bvcn10ww.exe
https://download.lenovo.com/consumer/mobiles/bvcn10ww.txt

V1.07
https://download.lenovo.com/consumer/mobiles/bvcn11ww.exe
https://download.lenovo.com/consumer/mobiles/bvcn11ww.txt

V1.08
https://download.lenovo.com/consumer/mobiles/bvcn12ww.exe
https://download.lenovo.com/consumer/mobiles/bvcn12ww.txt

V1. 10/
https://download.lenovo.com/consumer/mobiles/bvcn14ww.exe
https://download.lenovo.com/consumer/mobiles/bvcn14ww.txt

V1.11
https://download.lenovo.com/consumer/mobiles/bvcn15ww.exe
https://download.lenovo.com/consumer/mobiles/bvcn15ww.txt

4. Grab innoextract binaries from https://constexpr.org/innoextract/ or get from Github from https://github.com/dscharrer/InnoExtract.
Follow the steps from the instructions given on their page. Your file that you need to extract is from step 3. It usually involve extracting lenovo bios file using innoextract using cmd.
the extracted folder contains bios exe which need to be extracted using 7zip which will extract few files in them exist a .bin file with a size approx 17 MB.

5. Then open extracted bios bin file from step 4 in HxD hex editor. Go to edit menu and choose "select block". Put "de9d0" in start-offset and "10de9cf" in end-offset in hex mode in 4 option.
Now hit enter. It will select the bios region. Now go to "save selection" in File menu. Give it a name that you like, give it a extension .bin.
This is the file that we will use in later step to flash to the bios ic. It's size must be 16 MB.

6. Open the laptop cover, remove battery connector and remove CMOS battery connector (2 pin connector above battery) circled in red in the attached pic : https://ibb.co/8cXBnDX , then press main power button on laptop for 30 seconds. Now you are ready to flash the bios ic. So no need to dismantle laptop motherboard, just open the laptop cover, remove two battery connector.
Bios ic is located near main battery in this laptop, its number is 25q128jvsq. It has to be 25q128.. At end "128" denotes its size is 128Mbit = 16 MByte.
That's the size of our extracted bios bin file from previous step.

7. Now with the knowledge you gained how to read and write using SPI programmer from the blog post from above, use it in following steps.
Be careful not to touch any ic with fingers etc, also check the polarity of ic and programmer power supply and connections.
They must be correctly connected or you can destroy the ic.

8. You can use clip that come with spi programmer if you ordered it or you can desolder the ic and flash it in the special ic socket for soic 8 type ic that you can order with spi programmer. Pic : https://ibb.co/r27rtFp

9. Then you need to open bios bin file from step 5 in AsProgrammer, select the IC (select 25q128BV or 25q128FV) and flash it to the bios chip.
Use the Drop down menu near menu option "Program IC" and select "unprotect->erase ->program->verify".

10. After programming, you need to connect cmos battery, then main battery and that's it.

11. If everything went well, the laptop must boot and say that it need to run Automatic repair for Windows. If it will boot repairing automatically, the secure boot will be disabled.
If windows can repair than your laptop will boot to windows login screen else it will display that it could not successfully run automatic repairs.
It may even show Blue screen of death (BSOD), you will have to reinstall windows again.
If you reinstall windows, before that go to bios menu by pressing F2, go to secure boot. Select to setup keys and hit enter and leave it in setup mode.
As Windows will install again, it will also enable secure boot again.

Good luck!
At first I thought It wont work, but the XM25QH128B did the job of XM25QH128AHIG
Interesting that CH341 Programmer 1.38 also showed the same chip name (XM25QH128B) but always game mismatch error.

Thankfully it's just program version issue (not the voltage additional supply cable required, or damaged component). I also faced the broken windows (like yours), but it's the later/easy problem rather than the broken BIOS with no POST. Now it's time to get my information and G-sync back (the machine I purchased lack of these information/feature, seem due to motherboard replacement. I have made Mr. Lost_N_BIOS have a look on it, but I had suffered in Covid treatment. when I was back he had been offline since Jan.20 :( )

Thanks you again for your help and patience. Please also help mention the Neo Programmer 2.1.0.19 with others in case they have problems with XM25QH128AHIG programmer (or some other XMC chip, I saw a list of XM25QH32B, XM25QH64B,XM25QU64B,XM25QU128B). I'll also mention this in Lenovo forum at the thread I made.
Have a nice day.

 

If your BIOS chip is the XMC XM25QH128AHIG,

- At Step 9, please use the NeoProgrammer 2.1.0.19 (Link: https://drive.google.com/file/d/18fQGCFqEs_qjoqs3LAReG0pxMcfZVdyL/view ; Credit: https://www.youtube.com/watch?v=MeBupU_4qXo)

- Press Detect. In case the programmer does not detect the Chip, press Search then enter and choose XM25QH128B.

- You can also try the CH341 Programmer V1.38. it also detects the chip but in my case it could not write properly. I have no idea if that's just my case or also the programmer compatibility.

- Remember to verify the written data and the written bios .bin file before disconnecting the clippers. If they don't match, you have not been successful. Leave the cable there and try the steps again, slowly; or try another programmer (of course I don't want you to face that. Seeking for working programmer software took me nearly a sleepless week)

 

When power on after all steps, you might face the rainbow with no display for some turns of on-off. Just be patient and wait. If that spins for too long without self-restart give it a long press on the power button. When you see the POST screen (Legion), that does the job.

 

Good luck.

Reply
Options

10 Posts

07-14-2019

United States of America

4 Signins

107 Page Views

  • Posts: 10
  • Registered: ‎07-14-2019
  • Location: United States of America
  • Views: 107
  • Message 23 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-02-27, 19:13 PM

Theres alot of people with 1.11 issue thats lenovo fault, of course im not going to buy lenovo again in my Life, but atleast give us a fix to the users

Reply
Options

4 Posts

02-26-2021

Ukraine

9 Signins

50 Page Views

  • Posts: 4
  • Registered: ‎02-26-2021
  • Location: Ukraine
  • Views: 50
  • Message 24 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-02-28, 3:25 AM
Dear Sir, good day, sorry for my English. I need you help. I have the same problem. Lenovo legion y740 15irhg. Bios was stuck after downgrade from bcvn15ww to bcvn10ww. I am many time try to blind flash bios throw fn+R but nothing help. What you think just throw programmer can install bios?
Reply
Options

13 Posts

02-10-2021

Viet Nam

14 Signins

150 Page Views

  • Posts: 13
  • Registered: ‎02-10-2021
  • Location: Viet Nam
  • Views: 150
  • Message 25 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-02-28, 3:41 AM

If you are under warranty just give them a throw. Surely they replace the whole MB (with the risk of not writing back the information ) 

 

If you want to try yourself just buy the ch341A programmer them with clippers. Surely you dont want to desolder the Bios chip out of MB to attach directly to the programmer. It's confirmed to work for many user then. 

Remember to detach the main battery and cmos battery before processing. At least the winbond and xmc bios dont need the additional supply. I saw reports that the programmer burned the electric IC when trying that (for safety, as attaching before flashing is normal on other chip but just dont do it for safety) 

One more other notice, the clipps will wear out after times of using. Therefore making all thing ready bwfore attach the clippers to the bios chip

 

It could behave strangely after being flashed but you could turn it on and reinstall windows and run the official bios upgrade/downgrade. 

Reply
Options

3 Posts

03-06-2021

Pakistan

3 Signins

45 Page Views

  • Posts: 3
  • Registered: ‎03-06-2021
  • Location: Pakistan
  • Views: 45
  • Message 26 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-03-06, 14:41 PM

@ Jack_Lenovo1 wrote:

Hello @DucTri,

 

Welcome to the Community Forums.

 

You could try performing a power drain by holding down the power button for 30 seconds while unplugged or letting the battery drain completely then trying to boot up again.

 

If this does not work since you are unable to boot into Windows or the BIOS I would suggest contacting support for repairs since a motherboard with damaged or bad firmware may have to be replaced.

Since the MTM was not included in the post you can also view this link: https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/legion-series/legion-y740-15ichg/81he/parts/display/compatible to find the part number for the systemboard for self replacement 

 

You can use this link to find a local service center: https://support.lenovo.com/us/en/partnerlocator or use this link to contact support for your region: https://support.lenovo.com/us/en/supportphonelist

 

Hope this helps.
Regards,
Jack_Lenovo1

Hi Jack, I was also facing the same issue with my Legion Y740. Thank you for your guide and links you shared really help in solving my problem.

Reply
Options

1 Posts

07-03-2021

Japan

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎07-03-2021
  • Location: Japan
  • Views: 5
  • Message 27 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-07-03, 5:37 AM

Can you use MacBook instead in flashing with the ch341a

Reply
Options

2 Posts

07-26-2021

Brazil

1 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎07-26-2021
  • Location: Brazil
  • Views: 25
  • Message 28 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-07-26, 23:24 PM

Hey, I flashed the Bios with a spi programmer and a few days later my right fan stopped working correctly. Now it starts spinning, makes a couple rotations then stops abruptly, turns back slightly and then spins again (The left one works perfectly). At first I thought there was something in the fans, so I cleaned them but the problem continued, that's when I remembered the whole bios thing. Can the Bios cause this?

Reply
Options

1 Posts

08-10-2021

Canada

6 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎08-10-2021
  • Location: Canada
  • Views: 10
  • Message 29 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-09-05, 2:13 AM

Hi I have a Y540-15IRH that need to reflash bios with 3414 programmer.. I follow all the steps but I couldn't find a modded bios that is 16mb to flask back.. any ideas? I did tried that method using hex editor to Put "de9d0" in start-offset and "10de9cf" in end-offset to reduce the file size but heard it only works on XMC chip and mine is a winbond chip..

 

 

Can someone help me please

Reply
Options

13 Posts

02-10-2021

Viet Nam

14 Signins

150 Page Views

  • Posts: 13
  • Registered: ‎02-10-2021
  • Location: Viet Nam
  • Views: 150
  • Message 30 of 30

Re:Legion Y740 - no boot, no bios, no logo after bios backflash to 1.08

2021-09-23, 9:18 AM

Hello, it's meagain.

 

Sorry for the delay in replying. I'm just out of covid treatment.

 

For Y540, please refer to this Reddit thread, from

Embarrassed-Dig-2963. Seems the blocks are different therefore you could not trim the file using their limits.

 

https://www.reddit.com/r/Lenovo/comments/lypbjk/y540_black_screen_after_downgrading_42ww_bios_to/gvqvioa/

 

Sorry again for the late response. Hope this works for you.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms