cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Eliteforce
Paper Tape
Posts: 2
Registered: ‎01-07-2017
Location: AE
Views: 767
Message 1 of 5

Lenovo Ideapad Y900-17ISK Killer Wireless Lan Poor performance

I bought this laptop few weeks ago & facing terrible issues while using internet. I updated Killer Wirless Lan AC-1535, updated windows to the latest version. have done everything. even I have replaced this laptop with new one but still facing the same issue. I am using other Laptops & mobile devices those are working without any issue. I am really fedup. I need help to solve this issue. Internet is very slow on this laptop.

Lenovo Technology Partner
Posts: 570
Registered: ‎07-07-2014
Location: PH
Views: 696
Message 2 of 5

Re: Lenovo Ideapad Y900-17ISK Killer Wireless Lan Poor performance

Hi EliteForce,

I just want to verify a few things:

1. When you said you're facing terrible issues, does you game lag while browsing/streaming online (e.g., Youtube)?

If yes, how's the difference when it comes to latency (ping replies) when the game is running discretely and while multi-tasking.


2. When you said Internet is very slow on this laptop, how's your internet speed via www.speedtest.net?

3, Is the AC 1535 driver version updated to http://support.lenovo.com/us/en/downloads/ds118527


As for troubleshooting, try these steps:

1. open the nerve center & check on Network Priority and ensure it's enabled to the best settings

2. Connect to a 5Ghz AP & observe functionality

3. From this review, http://www.notebookcheck.net/Lenovo-IdeaPad- Y900-17ISK-Notebook-Review.174445.0.html, the AC 1535 has been tested to get amx throughput of 618.333MBit/s using a Linksys
EA8500 (settings may depend on your router).

Cheers,

Did someone help you today? Press the star on the left to thank them with a Kudos!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"
Eliteforce
Paper Tape
Posts: 2
Registered: ‎01-07-2017
Location: AE
Views: 691
Message 3 of 5

Re: Lenovo Ideapad Y900-17ISK Killer Wireless Lan Poor performance

Thank you so much for replying. I have 50MB Broadband connection all my other devices are working fine. I recently installed Linksys EA6100 Router. when I run speed test on Y900 it shows only 3MB download & 10MB upload. I am connected on 5GHZ. I have tried a lot but not able to solve this issue. This is my 2nd Laptop. Same issue I was facing with Lenovo Y900 I return it to service center & they replaced it with new box pack. I have spoke to Linksys Customer Service they checked router settings & said it's ok. The previous Laptop is with Lenovo & they are doing research on that Laptop. Inernet is working only for 10 to 15 minutes after that I can't open any website. last night I was downloading ESET Smart Security & Office 365 it took serveral hours to complete it. I don't know how to solve this issue or where to take this laptop.

Lenovo Technology Partner
Posts: 570
Registered: ‎07-07-2014
Location: PH
Views: 674
Message 4 of 5

Re: Lenovo Ideapad Y900-17ISK Killer Wireless Lan Poor performance

The speed test results are peculiar, download speeds should always be higher than upload speeds. It seems like there is something limiting the bandwidth of the download.
 
Have you already tried disabling Media Prioritization on your router and wifi card? 

Did someone help you today? Press the star on the left to thank them with a Kudos!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"
RivetNetworks
What's DOS?
Posts: 1
Registered: ‎01-12-2017
Location: US
Views: 660
Message 5 of 5

Re: Lenovo Ideapad Y900-17ISK Killer Wireless Lan Poor performance

Hello, I am a support representative from Rivet Networks.  There are a fews steps can try here to see if the driver or Killer Software itself may be limiting your connection.  If the Killer Network Manager is installed, can you please try going to the Settings page, check your limits and if they are not correct please run a speedtest within the application to see if it updates to the correct connection settings and test further.

 

If that does not work, please try disabling Advanced Stream Detect and testing your connection to see if the speed is the expected values.  If these basic steps do not work, please submit a ticket through our website and we can try to do some more advanced troubleshooting steps.  You can use the link below to submit a support ticket with us.

 

http://www.killernetworking.com/about/contact

 

Please reference your Lenovo forum post, so we're able to easily link the ticket to this post.

 

Thanks,

Josh

Rivet Support

Check out current deals!


Shop current deals

Top Kudoed Authors