cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
crsvld
Paper Tape
Posts: 3
Registered: ‎08-16-2017
Location: RO
Views: 938
Message 1 of 1

Lenovo Legion Y520 - 15IKBM - Qualcomm Atheros QCA61x4A 5Ghz problems

I just purchased the system in the title and after installing the drivers from Lenovo support page I noticed everytime I wanted to connect to my 5Ghz WiFi the adapter was disabled.

 

I have an Archer C2 750Mbps router with two antennas 2.4 Ghz and 5Ghz. 

 

I tried installing newer drivers with 3rd party software, reseting the connection, nothing worked.

The 5Ghz worked on my iPhone 6 but not on the laptop.

 

A friend came at my place with a different Lenovo system and he tried connecting to the 5Ghz band and he had the same problem. So I figured that it's something with the router.

 

I quickly searched for an updated firmware for the router and that solved the problem.

 

I just put this here in case some of you guys have the same combo - Archer C2 + Lenovo with Qualcomm Atheros QCA61x4A WiFi card.

 

Check out current deals!


Shop current deals

Top Kudoed Authors