cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
faqih1
Paper Tape
Posts: 3
Registered: ‎06-10-2019
Location: ID
Views: 318
Message 1 of 5

Lenovo Legion Y520 HDD missing when 100% performance

greetings,

i have lenovo legion y520 with 250GB SSD and 1TB HDD installed. I placed my os in SSD. When the HDD performance is 100% at task manager like i copy big files, scanning with antivirus, defragmenting, or something that make it work hard, it suddenly disconnected/missing. I have to restart or hibernate and turn it on again to reconnect the HDD. I read somewhere that it is bios compatibility problem and need upgrade. I upgraded my bios to the newest version but the problem still exist. I checked the HDD health still fine no bad sector or anything.

Any clues on whats wrong, and the solution? 

thank you very much

Social Support Agent
Social Support Agent
Posts: 175
Registered: ‎09-06-2018
Location: PH
Views: 264
Message 2 of 5

Re: Lenovo Legion Y520 HDD missing when 100% performance

Hello faqih1!

 

Welcome to the Lenovo Community Forums. Share the SMART result if you have ran diagnostic tests on the drive. You can post a picture of task manager here showing the 100% disk usage, a program or a system file/service might also be causing it. But before you do all this, kindly use a different SATA cable or swap the cables and see how your HDD performs.

 

Let us know how it goes. Hassen_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

faqih1
Paper Tape
Posts: 3
Registered: ‎06-10-2019
Location: ID
Views: 260
Message 3 of 5

Re: Lenovo Legion Y520 HDD missing when 100% performance

thank you for the reply,

i checked again using a software and the result is shown below. might that be the cause?

 

smart.png

Social Support Agent
Social Support Agent
Posts: 175
Registered: ‎09-06-2018
Location: PH
Views: 252
Message 4 of 5

Re: Lenovo Legion Y520 HDD missing when 100% performance

Hello again!

 

Thank you for posting the results. This is a warning, larger number of these errors and/or a large increase in these errors in a short period of time could cause the hard drive to fail. This can be the reason why you are getting 100% disk usage all the time. If you have important data on the computer we suggest that you create a backup.  If you want to continue using a drive with these errors you need to closely monitor the drive’s health, but a replacement HDD is your best option. Hopefully this helps. 

 

Hassen_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

faqih1
Paper Tape
Posts: 3
Registered: ‎06-10-2019
Location: ID
Views: 232
Message 5 of 5

Re: Lenovo Legion Y520 HDD missing when 100% performance

thank you,

but actually my harddisk isnt 100% all the time, its working normally but when i use until the active time reaching 100% for some time its disconnect. guess its time to replace it.

 

thanks alot for the reply

 

Check out current deals!


Shop current deals

Top Kudoed Authors