Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

4 Posts

08-26-2019

Singapore

9 Signins

109 Page Views

  • Posts: 4
  • Registered: ‎08-26-2019
  • Location: Singapore
  • Views: 109
  • Message 1 of 258

Lenovo Y540 Audio desync (Audio ahead of Video)

2019-08-27, 1:21 AM

Hi all,

 

I just received by brand new Lenovo Y540 (i7-9750H, GTX1660Ti), everything is great except the audio.

 

I tested both online (YouTube) and local video using MP Classic and audio is slowly ahead of the video after a while (5ish mins), the longer the video the more out of sync it will be if kept running. Refreshing solves the issue but just pausing and playing it again does not solve the issue.

 

I have tried all sorts of things such as updating all the drivers, updating Windows, and tried all sort of fixes on the other thread but no luck. Note that i noticed that there is a faint clicks or pops from the speaker from time to time like in the other thread but i did not experience crackle like described there so this might be a different issue. (https://forums.lenovo.com/t5/Gaming-Laptops/Lenovo-Y540-crackling-sound/td-p/4448320).

 

 

If anyone experience the same and/or have a solution, please help! Thank you.

Reply
Answer
Options

47 Posts

10-10-2019

Bosnia and Herzegovina

109 Signins

961 Page Views

  • Posts: 47
  • Registered: ‎10-10-2019
  • Location: Bosnia and Herzegovina
  • Views: 961

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-18, 20:59 PM

Guys, I think I found the solution to desync, audio cracking, popping and latency issues!!!!!!!

 

This evening I started to notice desync in Edge too. It was really going on to my nerves, so I have decided to try some more driver updates. I updated diferent drivers manualy in Device Manager (right click and then "Update driver"). However, that didn't solve the issue.

 

Then, I opened the "Storage controllers" section in Device Manager and there where two devices: "Standard NVM express controller" and "Microsoft storage spaces controller". I then right clicked on "Standard NVM express controller" and then "Update driver" , "Browse my computer for driver software" and "Let mi pick from list...". I then browsed into folder of the Intel IRST driver (c:\Drivers\Intel IRST Driver\Source\), and selected the first file. That was the Intel IRST driver downloaded from Lenovo support page for our laptop. After selecting that file there was "Intel Chipset SATA/PCIe RST Premium Controller" to select and install instead of "Standard NVM express controller". There will be message that it might not be compatible or something similiar, but just go with it. I then restarted laptop, and everything was working! No latency in LatencyMon, no delay in Chrome or Edge, even Latency Checker shows no more red bars!

 

I tested it only for 30 minutes, but I'm sure it solved all the issues. Maybe some other driver updates did the trick, but I think the one explained above did the trick. Just in case, I'm gonna post all my drivers in HTML again. Also, fast startup is off, but I don't think that matters too.

 

Please try and report back!

 

Link to HTML file with all my drivers: https://www120.zippyshare.com/v/drit3Ovr/file.html

Reply

Replies(257)
Options

61 Posts

08-27-2019

Egypt

80 Signins

871 Page Views

  • Posts: 61
  • Registered: ‎08-27-2019
  • Location: Egypt
  • Views: 871
  • Message 2 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-08-28, 14:19 PM

Can coonfirm both issues happening with my unit, although the crackling is'nt as noticable as the desync.

I have the i7 9750h +1660ti that came with free dos (So I installed a clean version of windows).

Reply
Options

2 Posts

08-29-2019

United States of America

4 Signins

26 Page Views

  • Posts: 2
  • Registered: ‎08-29-2019
  • Location: United States of America
  • Views: 26
  • Message 3 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-08-29, 13:10 PM

Same issue here. Haven't found any solid advice but I'm about to install the latest Realtek driver on the Lenovo support page. Will report back on the delay. Side note, I uninstalled the Dolby Atmos stuff. I don't know why these laptops have so much most processing software.  

 

Did not seem to fix the issue though.

Reply
Options

4 Posts

08-19-2019

Thailand

10 Signins

123 Page Views

  • Posts: 4
  • Registered: ‎08-19-2019
  • Location: Thailand
  • Views: 123
  • Message 4 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-08-29, 16:19 PM

I ask Lenovo Service Center in my country. They say that they will release the driver to fix this problem soon. 

Reply
Options

2 Posts

08-29-2019

United States of America

4 Signins

26 Page Views

  • Posts: 2
  • Registered: ‎08-29-2019
  • Location: United States of America
  • Views: 26
  • Message 5 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-08-29, 17:05 PM

 wrote:

I ask Lenovo Service Center in my country. They say that they will release the driver to fix this problem soon. 


Good to hear, I'll keep an eye out for it.

 

Until then, forcing Windows to use the Windows Audio Driver fixed the delay for me. 

 

I used the first method here: 

https://troubleshooter.xyz/wiki/stop-windows-10-from-automatically-installing-realtek-audio-drivers/

 

Let me know if this works for any of you.

Reply
Options

2 Posts

08-30-2019

Netherlands

10 Signins

52 Page Views

  • Posts: 2
  • Registered: ‎08-30-2019
  • Location: Netherlands
  • Views: 52
  • Message 6 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-08-30, 9:24 AM

heya tim0,

 

I have the exact same hardware and the exact same issues.

 

Tested both on Youtube and the Netflix app and Netflix website: the longer the video plays, the more out of sync it gets.

Indeed pausing the video seems to get it back in sync.

 

Regarding the popping, I also experienced it. It was during the first few hours when I used the laptop to play music via Youtube.

Currently this issue appears to be resolved as I do not hear any crackling / popping anymore.

I lowered the Hz from 48000 to 44100 (Studio Quality) in the Sound Control Pannel (Sound Control Pannel --> Playback --> Rightclick " Speakers" to go to properties --> Advanced --> Default Format).

What I am unsure of if this is indeed the solution, or if it magically got better. I turned the quality down to CD Quality and still experienced crackling / popping. But with the 44100 Hz (Studio Quality) it appears fine.

Reply
Options

61 Posts

08-27-2019

Egypt

80 Signins

871 Page Views

  • Posts: 61
  • Registered: ‎08-27-2019
  • Location: Egypt
  • Views: 871
  • Message 7 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-08-30, 13:07 PM

Tried the above fix (lowering the transmission power) and it at least lowered the poping to an unnoticeable degree, still haven't tried the fix for the delay, will try it and report back here.

Edit: tried the first fix (using microsofts drivers), but the delay is still there sadly..

Reply
Options

9 Posts

09-01-2019

United States of America

18 Signins

120 Page Views

  • Posts: 9
  • Registered: ‎09-01-2019
  • Location: United States of America
  • Views: 120
  • Message 8 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-09-01, 5:45 AM

Just wanted to say I'm having the same problem as well. I think it's a DPC Latency issue, but I'm not too well versed on any of this stuff to be certain. Could you download this program and post a screenshot of the main screen (with the green/red bars)? https://www.resplendence.com/latencymon It would at least help me pinpoint what the issue is for us.

Reply
Options

4 Posts

08-26-2019

Singapore

9 Signins

109 Page Views

  • Posts: 4
  • Registered: ‎08-26-2019
  • Location: Singapore
  • Views: 109
  • Message 9 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-09-01, 8:30 AM

Hey all, thanks for all the replies. glad to hear that it's driver issue and there might be a fix soon. Unfortunately my unit is in the service centre for inspection so i can't post the latencymon results, but i did the test beforehand and it came up with all RED and the text saying that it's HDaudiosys issue and network & power management related latency, but i can't post the exact screenshot until i get the laptop back, will report back again here once there is an update.

Reply
Options

31 Posts

08-31-2019

Bulgaria

151 Signins

639 Page Views

  • Posts: 31
  • Registered: ‎08-31-2019
  • Location: Bulgaria
  • Views: 639
  • Message 10 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-09-07, 19:38 PM

Awesome! Please keep us posted :)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms