Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

47 Posts

10-10-2019

Bosnia and Herzegovina

109 Signins

961 Page Views

  • Posts: 47
  • Registered: ‎10-10-2019
  • Location: Bosnia and Herzegovina
  • Views: 961
  • Message 141 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-13, 17:04 PM

Jonathan, your help is appreciated, you shouldn't be upset because some people think negatively. 

I used your previous posts to figure out solution for my laptop. Basically, you're right. It's the driver problem.

 

Thank you for trying to give the solution for everyone here. I will try your guide with clean install without internet connection, to try to fix desync that I still have in Chrome. 

Reply
Options

6 Posts

11-13-2019

Turkey

43 Signins

201 Page Views

  • Posts: 6
  • Registered: ‎11-13-2019
  • Location: Turkey
  • Views: 201
  • Message 142 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-13, 22:33 PM

İ have this issue and solved with high performance mode but i definitely say that this problem start at the end of september or beginning of november.İn these days which update has come,it caused the desync issue.

İ want to try jonathan's solution and i want to  clarify the steps.

Clean installation means that i should do with bootable windows 10 usb?

Or is windows 10 recovery  enough for clean installation.

After i did the installation drivers from my hdd,whaty should i do ?

Which lenovo drivers can i install ?

Sorry for my bad english.

Reply
Options

40 Posts

09-24-2019

United States of America

70 Signins

621 Page Views

  • Posts: 40
  • Registered: ‎09-24-2019
  • Location: United States of America
  • Views: 621
  • Message 143 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-14, 0:52 AM

+This will be my last post so hope administrator do not delete my post. I dont want to be annoying for anyone but wanted to share something useful that i already tested and worked in my case.

+Just let me explain what i did because is not a repetitive message like some people said.

If it doesnt work for some, at least leave other try what i did, because this is not a suggestion, is a solution between a hundred solutions. +Let others read my solution because i saw some are interested in mine and they cant read it because administrator deleted my message.

Remember be patient. If you can´t tolerate read message saying, "this work, not work, change this..." just use your 1 year warranty, sell the laptop, buy a new one, theres a lot of solutions..

+Obviosly this solution is related to a topic that previosly we identify, the realtek audio driver fail, but theres different ways to think and implement a solution to this problem and i need to explain with full details because theres people who hasnt enough experience with PC

+I admit i have send other "solutions" but just because i was one like you, a guy trying to fix a laptop. But this solution worked for me since 1 month ago and everything work perfect. So i begin.

 

PREPARATION:

1)Create a windows 10 iso USB. Just search in google this: Create Windows 10 Installation media, download the app and follow the steps.

2)With Lenovo Vantage see your serial code and put it here https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t420i/downloads/automatic-driver-update

3)Donwload every driver you see from your laptop, just omit the Audio Driver. Put this on a Usb

4)Identify a folder named "Drivers" who is in the second hard drive. This contains apparently the drivers who are installed in the brand new laptop. Copy this folder in a Usb.

 

START

1)Turn off your laptop. Use a pen to put into a little hole who is in the right side of your pc.

2)Select Boot Menu and find the usb you have already use to install windows 10

3Be sure any ethernet cable is unplugged to your laptop,not any internet connection please

4)When you install windows 10 , be sure to delete all the partition of the Harddrive you will use to install win 10. Be sure to delete it and to create a new one because we want a very clean installation.

6)Don´t connect to wifi too.

 

WHEN WIN 10 IS INSTALLED 

1)Keep no internet connection

2)Begin installing the Drivers who you find in the folder named "Drivers". Avoid install the audio driver. Remember install as an adminsitrator to reduce problems. Be patient and wait until you see driver installation finished. If a restart is request, do it and keep installing the drivers.

3)Begin installing the driver who you find in the lenovos webpages. Avoid install again the audio driver. If it say a better drivers is already installed, just keep with the others.

 

WHEN DRIVERS ARE INSTALLED

1)Connect to internet. Avoid a Device manager update.

2)Install the latest windows update. Obviusly win 10 is known to have a lot problems but i thing with every update the try to fix problems and that means better option to solve the audio desync.

3)Install the basic programs like Nvidia ones. Im sure you will find a Nvidias driver ready to be installed

4)Let windows connected to insternet for a while because after a clean windows installation the download a lot of stuff.

 

FINISH

1)If you did all just why i said, the problem must be gone. 

2)I highly recommend to not use Latency mon  program to check if the pc has desyn because just like in other post people have said, do a simple things like increase the bright of the screen show a rise of latency in that program, but we only wanted to be focus on the audio desync. No matters if the program show us a latency if it isnt affecting us. Even you can try that program with other laptop who you think work well and you will find the also has latency and if its not, just use the pc and you will see latency.

3)The best way to test the laptop is with media content, i mean, audio and video,. Is better some youtube videos with people talking, just try to read their lips and see if their lips and audio is sync. Try also to stop the video for a seconds in see if audio is late or is sync.

4)Disable and enable ones the hybrid mode who you wil find in the Lenovo Vantage App. Must be enabled

 

And no more, hope this work for a lot people. I leave a picture with my driver version. Sorry if this post is long but i prefer to be clear. If you have read this, im sure you will noticed that is not a repetitive message like other said...

Buy, i really hop you can fix your laptop with my solution or with any other.

 

Reply
Options

6 Posts

11-13-2019

Turkey

43 Signins

201 Page Views

  • Posts: 6
  • Registered: ‎11-13-2019
  • Location: Turkey
  • Views: 201
  • Message 144 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-14, 7:11 AM

Thank you man great work!

After the everthing has done,what should i avoid to not happen again?

i mean, should i avoid updates of lenevo vantage or something else?

Reply
Options

3 Posts

11-14-2019

Turkey

3 Signins

48 Page Views

  • Posts: 3
  • Registered: ‎11-14-2019
  • Location: Turkey
  • Views: 48
  • Message 145 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-14, 19:01 PM

Hi Jonathan. I followed the exact instructions and I still got the delay. Can you share the driver info screenshot of Realtek device under "Sound, video and game controllers" in Device Manager?

Reply
Options

10 Posts

11-03-2019

Germany

25 Signins

198 Page Views

  • Posts: 10
  • Registered: ‎11-03-2019
  • Location: Germany
  • Views: 198
  • Message 146 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-14, 19:08 PM

Hi Guys,

 

I bought my Legion Y540 laptop in October 2019 with the following configuration:

 

  • Intel Core i5-9300H with 16GB RAM and GTX 1660TI 6GB RAM
  • HDD SKHynix 256GB, no second HDD
  • No OP System so I installed everything by my own incl. Kaspersky Internet Security and Google Chrome, Office etc.
  • I have an external monitor with lid closed so the video runs always using the Nvidia card (hard wired to external monitors via HDMI and Mini Display port)

After testing I saw the same problem with desync and tried everything described. At the end contacted Lenovo Support and send the laptop to the repair center (they advised to do so). After two weeks I got my laptop back. They did a fresh Windows home 64bit installation with basic drivers and did not find any problem with video streams.

 

I checked this using the Edge browser (which is a part of Windows 10) and the videos are without desync issue at all (Amazon prime, YouTube etc.). After this I installed Lenovo Vantage Software and all drivers shown by Vantage. Windows downloaded all default updates etc. I left the test version of McAfee installed with the image. I tried the Windows sound driver and also the Realtek – no desync problems as well. I installed also Latency Mon and this shows high latency about 6000 for sound driver, but this did not affect the streams if using Edge only.

 

Now I installed Google Chrome 64bit english and the story begins:

  • If Chrome is open I got desync in Chrome (and Edge as well), even if no streams in Chrome are started after about 5-10 minutes
  • If the Chrome is closed I can stream using Edge whatever I will without sync issues, I tested it the whole evening and the streams were just perfect.
  • With connected external USB Sound Card I can stream on both Chrome and Edge without any issue

 

I am still not sure what is the root cause of this issue, but it seems some resource sharing problem or some settings in Chrome (hardware acceleration maybe)?

 

If you have any further ideas please let me know, at the moment I can live with streaming using Edge (and have Chrome closed). For any other activity is Chrome ok (incl. simple music straming without video). For a longer term this is not a solution - on my older laptop (over 8years old with i3 3210 processor) everything worked fine, it was only a slower then the current Y540.

 

 

 

 

Reply
Options

47 Posts

10-10-2019

Bosnia and Herzegovina

109 Signins

961 Page Views

  • Posts: 47
  • Registered: ‎10-10-2019
  • Location: Bosnia and Herzegovina
  • Views: 961
  • Message 147 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-14, 19:26 PM

As I already posted in previous posts, I have the exactly same expirience. I strictly installed drivers from Lenovo support page (I had to manually select the right versions in Device manager) for our laptop and have expirienced desync only in Chrome. Microso Edge (and Edge chromium beta) have no desync! 

 

With drivers that Windows installed during install, even after installing Lenovo drivers (some of them still don't get applied, because Windows installs newer versions), I got desync in Edge and Chrome. 

Reply
Options

28 Posts

10-04-2019

Poland

52 Signins

319 Page Views

  • Posts: 28
  • Registered: ‎10-04-2019
  • Location: Poland
  • Views: 319
  • Message 148 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-14, 19:37 PM

@Jonathan1539
Installed everything according to instructions. No results, I've got desyncs and crackling.

The only thing that completely get rid of these issues is to install W10 on another disc (2,5 HDD instead od m.2 Hynix SSD in my case). 0 desync, 0 crackling sound without messing with Windows settings, updates, drivers. Just installed and downloaded everything

Reply
Options

40 Posts

09-24-2019

United States of America

70 Signins

621 Page Views

  • Posts: 40
  • Registered: ‎09-24-2019
  • Location: United States of America
  • Views: 621
  • Message 149 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-14, 20:31 PM

Hi, i leave down bellow what you have request, but i noticed that my laptop is usign 2 drivers, 1  in the device manager sector Audio inputs and outputs and this is the exactly information:  Manufacturer Microsoft, date 18/03/2019, version 10.0.18362.1.

 

The other one is in the Sound, video and game controllers sector and is for this device( 3 - Realtek(R) Audio)  and you can find it down bellow on the screenshot

 

 

Reply
Options

40 Posts

09-24-2019

United States of America

70 Signins

621 Page Views

  • Posts: 40
  • Registered: ‎09-24-2019
  • Location: United States of America
  • Views: 621
  • Message 150 of 258

Re: Lenovo Y540 Audio desync (Audio ahead of Video)

2019-11-14, 20:41 PM
So, following what other people have said, it is possible that the Hynix m2 already come with some defect. The only thing i can recommend is to perform the same installation but in the other Hard drive. The speed shouldnt be any problem because the laptop in fact is pretty quick. If the problem is solve, you can think to buy a samsung m2 in order to replace the one that your lapto has, and use the "defective" one as a external HD.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms