English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

5 Posts

03-26-2016

PL

14 Signins

54 Page Views

  • Posts: 5
  • Registered: ‎03-26-2016
  • Location: PL
  • Views: 54
  • Message 1 of 7

Lenovo y700-15isk - terrible wifi

2016-03-26, 20:44 PM

Hello everyone. 

So, i've recently bought a new laptop - y700-15isk, i was pretty happy with it, until i wanted to use laptop with wifi only. It was absolutely terrible. I am on windows 7, almost clear installation, only drivers, nothing else. I didnt changed a single thing in ethernet lan/wifi drivers. My router is TP Link TL-WR740, my smartphone and other laptop are connected also using wifi and there is not a single problem with it. But y700 is absolutely losing it's mind. Using ping cmd i got like 4 responses from the server, with 2800ms and rest of responses are timed out. I tried various channels - 802.11b, g etc and none was working properly. Any advices?

Reply
Options

3830 Posts

12-11-2015

US

4365 Signins

49222 Page Views

  • Posts: 3830
  • Registered: ‎12-11-2015
  • Location: US
  • Views: 49222
  • Message 2 of 7

Re: Lenovo y700-15isk - terrible wifi

2016-03-26, 21:13 PM

This seems to be a known issue, so I would try the suggestions on this link, but if that fails, I would call Lenovo Support and if they cannot fix it under warranty, return the laptop under the 30 day replacement window and try a differenty model.   

 

Wireless signal drops frequently

https://support.lenovo.com/us/en/documents/ht070623

 

  1. Bring the laptop closer to the router.
  2. Restart computer.
  3. Run antivirus.
  4. From Device Manager, click Network Adapter. Right click on the driver and click update driver.
  5. Change the wireless channel for the router.
  6. Go to command prompt. Type the following command:
    • Ipconfig/flushdns and press enter
  7. Go to command prompt, type ipconfig/all. Press enter
    • Is the IP address for the Local Area Connection correct?
    • If not, type ipconfig/release and press Enter
    • Type ipconfig/renew and press Enter
    • Type ipconfig/all and see if the IP address is correct
Reply
Options

5 Posts

03-26-2016

PL

14 Signins

54 Page Views

  • Posts: 5
  • Registered: ‎03-26-2016
  • Location: PL
  • Views: 54
  • Message 3 of 7

Re: Lenovo y700-15isk - terrible wifi

2016-03-26, 21:27 PM
It's not working, **bleep**. Seems like i'll have to return it, too bad because i like this laptop. Thanks for response tho.
Reply
Options

5402 Posts

05-09-2013

US

6273 Signins

19373 Page Views

  • Posts: 5402
  • Registered: ‎05-09-2013
  • Location: US
  • Views: 19373
  • Message 4 of 7

Re: Lenovo y700-15isk - terrible wifi

2016-03-26, 21:31 PM

wrote:

Hello everyone. 

So, i've recently bought a new laptop - y700-15isk, i was pretty happy with it, until i wanted to use laptop with wifi only. It was absolutely terrible. I am on windows 7, almost clear installation, only drivers, nothing else. I didnt changed a single thing in ethernet lan/wifi drivers. My router is TP Link TL-WR740, my smartphone and other laptop are connected also using wifi and there is not a single problem with it. But y700 is absolutely losing it's mind. Using ping cmd i got like 4 responses from the server, with 2800ms and rest of responses are timed out. I tried various channels - 802.11b, g etc and none was working properly. Any advices?


Since the unit is new there might be a need to restart your modem and router. See to it that it is set to transmit/receive a mixed set (n, g, b, etc.). Try connecting your unit using the 2.4 GHz band since I believe the router is capable only in the 2.4 Ghz. If you still have the problem you might need to do some fine tuning of the configuration for your wifi card. Refer to the wifi manufacturer's site on how to go about it.

Reply
Options

5 Posts

03-26-2016

PL

14 Signins

54 Page Views

  • Posts: 5
  • Registered: ‎03-26-2016
  • Location: PL
  • Views: 54
  • Message 5 of 7

Re: Lenovo y700-15isk - terrible wifi

2016-03-26, 21:39 PM
Switched to 2.4gHz, and it barely could get any response from server. Thanks for response.
Reply
Options

5402 Posts

05-09-2013

US

6273 Signins

19373 Page Views

  • Posts: 5402
  • Registered: ‎05-09-2013
  • Location: US
  • Views: 19373
  • Message 6 of 7

Re: Lenovo y700-15isk - terrible wifi

2016-03-27, 0:29 AM
wrote:
Switched to 2.4gHz, and it barely could get any response from server. Thanks for response.

Are you sure that your router is the TP Link TL-WR740? This is the spec of that router.

Don't tell me that you are using the 5 Ghz band. You might be connecting to another router.

Reply
Options

5 Posts

03-26-2016

PL

14 Signins

54 Page Views

  • Posts: 5
  • Registered: ‎03-26-2016
  • Location: PL
  • Views: 54
  • Message 7 of 7

Re: Lenovo y700-15isk - terrible wifi

2016-03-27, 1:18 AM
Hmm, i just got email about your response and when i was comparing Intel's documents with TP Link entirely, i noticed that the wifi is working very well. BUT there is another thing. On my local network, every device that is connected seems to be getting ip like xxx.xxx.x.100 then xxx.xxx.x.101 etc. Wi-fi connection had always like 103 ending or even 104. Now, in the middle of the night the wired connection has ending 100, and the wifi has 101, and they are working great. Thanks again Len, i'd probably just returned the laptop, now i know that's it network problem. Maybe you got any advice how to solve it? I mean the ip thing.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete