English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

1 Posts

03-14-2019

PT

2 Signins

22 Page Views

  • Posts: 1
  • Registered: ‎03-14-2019
  • Location: PT
  • Views: 22
  • Message 1 of 15

Lenovo y720/y520 | Buggy BIOS = missing GPU?

2019-03-14, 12:24 PM

Greetings.
I'm (sadly) the computer engineer responsible for my company's workforce computing hardware, I think now I can see I made a terrible choice by buying Lenovo "Gaming Hardware" as everything stands.

After days of troubleshooting my y520 laptop which was passed down to someone else because the GPU seemed to be completely absent from the system, I then purchased a y720 which had the exact same problem. Rinse and repeat, now troubleshooting the y720.

Both of the different models Nvidia GPUs are not being powered on correctly either due to faulty hardware (which was my first assumption) or by faulty bios, i can say that with certainty because neither windows device manager nor linux's lspci detect the cards.

After a year of owning the y520 mentioned above I was checking lenovo support for drivers for my y720 and decided to try and also update the y520 to the latest bios and that fixed the missing GPU problem on the y520 model, sadly, I can't say the same for my y720 on which I tried all available bios versions and the GPU only appears to be correctly powered on at boot by random chance, or after a certain amount of cold boots. Again, y720's GPU is not powered on and not detected as an available hardware part in linux nor windows.

This is not a driver issue, I am certain this is most certainly a BIOS problem.
2 out of 4 laptops so far had this issue, strangely enough only one of the y520 suffered from this issue.

I didn't actually need the Nvidia card up until now, thus, it took me a while to notice its absence. But now we had ordered in some external monitors to use with the laptops, lo and behold two of them don't' have HDMI output because of the problem I've just described.

After many hours spent googling I've noticed a lot of people complaining about GPU issues for both these laptops, many on the software side of things, but now I am sure there is also problems on the firmware side of things.

I advertised the products I sugested to my bosses as reliaible and very well built, as was the lenovo standard a couple of years ago, but this does not seem the case anymore.

Is Lenovo aware this is an issue?
Is there any ETA on the resolution of this problem? I can imagine the amount of laptops with these models still in the wild that people will buy and have loads of problems with if this isn't resolved, mind you both of these models are almost two years old and there is still no reliable way of fixing the problem.

TLDR: y720 and y520 have the same problem, even though they differ in BIOS, they both fail to power on the dedicated NVIDIA GPU at BOOT. This is not a driver issue. As for the y520 the latest available BIOS update to this date seemed to fix the problem. The y720 doesn't seem to have a solution, having tried to check if the graphics card was available in multiple operating systems and using all of the available BIOS versions.

Thank you for your time.

Reply
Options

2 Posts

10-04-2017

US

2 Signins

29 Page Views

  • Posts: 2
  • Registered: ‎10-04-2017
  • Location: US
  • Views: 29
  • Message 2 of 15

Re: Lenovo y720/y520 | Buggy BIOS = missing GPU?

2019-03-15, 22:05 PM
I have this problem too, and just the other day I got a blue screen for faulty hardware
Reply
Options

3 Posts

01-08-2019

MX

20 Signins

112 Page Views

  • Posts: 3
  • Registered: ‎01-08-2019
  • Location: MX
  • Views: 112
  • Message 3 of 15

Re: Lenovo y720/y520 | Buggy BIOS = missing GPU?

2019-09-04, 7:03 AM
I have the same problem, so far I have no solution, unfortunately I have no guarantee.
Reply
Options

4 Posts

11-08-2019

US

5 Signins

62 Page Views

  • Posts: 4
  • Registered: ‎11-08-2019
  • Location: US
  • Views: 62
  • Message 4 of 15

Re: Lenovo y720/y520 | Buggy BIOS = missing GPU?

2019-11-13, 18:38 PM

hi everyone/support,

 

having the same issue and spent days trying to find a solution but with no avail, you may be right as it seems a firmware issue as the GPU is not detected else I would have been able to install it. The bios option is very limited for the Lenovo legion Y720 and the option to swith graphic not available, see screenshot attached whereby it is available on the Lenovo Legion Y740.

 

Should it be great if a bios update in that sense be available from Lenovo team.

 

Looking forward to hear from you.

 

Reply
Options

4094 Posts

01-22-2010

US

38391 Signins

573986 Page Views

  • Posts: 4094
  • Registered: ‎01-22-2010
  • Location: US
  • Views: 573986
  • Message 5 of 15

Re: Lenovo y720/y520 | Buggy BIOS = missing GPU?

2019-11-13, 18:40 PM

Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so. Using Browser Search To Find Answers in the Lenovo and Moto Communities
Reply
Options

4 Posts

12-30-2019

MX

3 Signins

38 Page Views

  • Posts: 4
  • Registered: ‎12-30-2019
  • Location: MX
  • Views: 38
  • Message 6 of 15

Re: Lenovo y720/y520 | Buggy BIOS = missing GPU?

2019-12-30, 5:01 AM

I also have a lenovo y720, I had worked perfectly with it until a few days ago, but since a couple of weeks ago the device manager doesn't detect the Nvidia graphic card, and the Bios doesn't detect it either. Does Lenovo have any suggestions that might help us?

Reply
Options

3 Posts

01-08-2019

MX

20 Signins

112 Page Views

  • Posts: 3
  • Registered: ‎01-08-2019
  • Location: MX
  • Views: 112
  • Message 7 of 15

Re: Lenovo y720/y520 | Buggy BIOS = missing GPU?

2020-01-27, 0:48 AM
i have the same problem.
Reply
Options

2 Posts

04-26-2020

US

4 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎04-26-2020
  • Location: US
  • Views: 25
  • Message 8 of 15

Re:Lenovo y720/y520 | Buggy BIOS = missing GPU?

2020-04-26, 2:49 AM

Hello,

 

Were any of you able to resolve this issue? 

 

My Lenovo Y720 just started having the same problems: GPU not detected in BIOS, yellow exclamation on graphics driver in device manager, no external monitor detection. I downloaded Lenovo Diagnostics Tool and ran video card with 'Not Applicable' result (I am assuming it did not detect). I have pretty much done everything I can find on the internet: reset my pc and updated everything, deleted graphics driver using DDU with no automatic update or internet and flashed old and new BIOS. I even replaced the thermal paste.

 

Please let me know either or if there is a FIX or how to use the Y720 as BRICK.

Reply
Options

4 Posts

12-30-2019

MX

3 Signins

38 Page Views

  • Posts: 4
  • Registered: ‎12-30-2019
  • Location: MX
  • Views: 38
  • Message 9 of 15

Re:Lenovo y720/y520 | Buggy BIOS = missing GPU?

2020-04-26, 9:21 AM

I think it could be a reballing problem. Have any of you tried reballing to the GPU?

Reply
Options

2 Posts

04-26-2020

US

4 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎04-26-2020
  • Location: US
  • Views: 25
  • Message 10 of 15

Re:Lenovo y720/y520 | Buggy BIOS = missing GPU?

2020-04-27, 8:21 AM
I really appreciate the quick response. I did a quick search on what 'reballing' is and unfortunately, it is way out of my capabilities; the most I can do is replace the thermal paste. I was hoping it is more in line of what the initial poster made about the BIOS or even a software/driver problem that I can do myself.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete