cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Danielm3
Blue Screen Again
Posts: 3
Registered: ‎09-28-2017
Location: CZ
Views: 7,708
Message 1 of 4

Touchpad stopped working

My touchpad on ideapad Y700 15-ISK just stopped working. I did a little research in drivers and i found, that there is no driver for touchpad installed. I tried to download new drivers from lenovo site and I used an older driver from C:\Drivers\Touchpad, there is InstNT.exe, which made a driver shows up in device manager, but prompt me to restart the laptop. When I did, the driver got lost again and I had to make the InstNT.exe "instalation" again. Then I tried to update it with a setup.exe in the same synaptics folder and after it, the driver got itself a name for synaptics. So I said to myself, ok after restart now, it will be fine. But it wasn't. Again, the driver is gone.

I'm attaching a screenshot for you to see driver being installed, but after restart, it vanished and isn't even showing in unrecognized drivers.

In addition, my windows defender warned me about some threats, but I guess it got rid of them, because there were none to be found by me. Just wanted to say it, maybe it could affect my problem.

Retired Support Specialist
Posts: 182
Registered: ‎07-19-2017
Location: IN
Views: 7,689
Message 2 of 4

Re: Touchpad stopped working

Hi Danielm3

 

Welcome to the Lenovo Community !

 

 Check if you would have enabled the “Hot keys enabled “ in BIOS to check please go to the BIOS by tapping F2 key on the keyboard before it boots to the desktop once you are in the BIOS  press FN + hot key (F6 on mine) and see if the Hot key is enabled or disabled.

 

Hope the above information helps and please let us know how you go about.

 

Please feel free to post in Lenovo Community Forums if you have any further queries!

 

Regards,

Rameez

 

Tap that kudos button if I helped.
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Danielm3
Blue Screen Again
Posts: 3
Registered: ‎09-28-2017
Location: CZ
Views: 7,674
Message 3 of 4

Re: Touchpad stopped working

Thank you for your fast answer.

Unfortunately, this is not my problem, I have never been in bios settings on this laptop, but when I already now was, the hotkeys are enabled. I can't use mouse in bios (not efi bios), so I can't say if the touchpad is dead (no matter what reason) or is it a software problem. This answer didn't helped me at all. 

I read another topic from today where the man is complaining about touchpad too, could it be a windows problem? But why is the driver after restart always uninstalled?

I have the laptop on warranty. But I don't want it to be in servis for a month because of this. Please, help me.

Danielm3
Blue Screen Again
Posts: 3
Registered: ‎09-28-2017
Location: CZ
Views: 7,638
Message 4 of 4

Re: Touchpad stopped working

Okay, so, I went for some research on the internet, that it can be a coincidence with build 1703 on windows 10 and found this solution:

1. Click Win + I to open Settings.

2. Click Update & Security > Recovery > Advanced startup > Restart now > Troubleshoot.

3. Select the Go back to the previous build option.

 

I restarted via point 2, but I had no option to go to previous build, so I clicked on system restore. It got me right into settings for system restore, but OS told me, that I have no restore point to go, so I dissapointly continued with restart. But even in this point and after the restart, touchpad started to work and the driver got itself in... weird, but I'm ok with this, I'm still on 1703 build with working touchpad.

 

But maybe, it's because before restart, I went to Settings -> mouse (I didn't have touchpad settings visible) -> additional mouse settings and in this point, I got warning message that synpatics couldn't be found and was prompting me to click YES for uninstalling the driver, which I did.

Check out current deals!


Shop current deals

Top Kudoed Authors