Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 2
Registered: ‎05-10-2019
Location: FR
Views: 2,052
Message 1 of 3

Trouble overclocking Legion Y530


I'm the owner of a Legion Y530-15ICH with i5-8300H and GTX 1050 4GB which has been running just fine.
I wanted to know how it would fare when overclocked, so I first tried going to the Bios for the auto-overclock like I did the last and first time I tried overclocking a computer. I didn't see any such options so I'm guessing my processor is locked. So I went on to trying to overclock with ThrottleStop(TS) for CPU and MSI Afterburner(AB) for GPU.

When I launch AB, I see it picks up values on my GPU but right after, all drops to 0 and I just read "Connection to GPU1 lost". Going back and forth from my Intel GPU does the same thing, AB picks up values for a second then loses connection. Anyone knows what's the cause of this and/or how to get around that?
( Also, if you have any advice on overclocking either CPU or GPU, I'll gladly take some since this is the first time I'm trying it with programs )

Support Specialist
Posts: 807
Registered: ‎04-23-2019
Location: US
Views: 1,984
Message 2 of 3


Hi Frost41,


Thanks for reaching out. Have you tried doing a clean install of the graphics card driver? This is a very nice place to start to make sure that the problem is not driver related. You can use third-party programs like Display Driver Uninstaller (DDU) to make sure that all drivers are 100% uninstalled or you can go the more traditional route of going for the device manager


Here's how:


After performing these steps try downloading the most updated driver for the card through the support website here:

As for overclocking guide, check this thread (the guide is for a Y720 but same aspects applies):


Let us know if this helps you out. Thanks.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Paper Tape
Posts: 2
Registered: ‎05-10-2019
Location: FR
Views: 1,955
Message 3 of 3

Re: Re:

I did try uninstalling my drivers and installing them again with no results but I did so manually then reinstalled them along GeForce Game Ready Driver and it seems that was the one causing the issue.
I tried installing the most updated driver as you said and Afterburner is working fine. I thought it was alright but I guess I should stop updating with Geforce Experience?

Anyway, kudos for the help, I'm heading over to the overclocking guide and I will post back here if I have another issue.

Thanks again.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!

Shop current deals

Top Kudoed Authors