Showing results for 
Search instead for 
Did you mean: 
Fanfold Paper
Posts: 2
Registered: ‎11-20-2018
Location: CA
Views: 556
Message 1 of 2

Using Lenovo Digital Download Recovery (DDRS) Fails

Note: Model info below signature.


Hi everyone.  I was hoping to be able to post an introduction before my first issue, but alas that wasn't in the cards....


I admit to having bunked my own Windows installation - the how isn't important Smiley Very Happy but suffice it to say that I did.  Now, I'm looking to recover using Lenovo's factory image, downloaded via DDRS and written to a 16GB USB drive.


The drive was created successfully, and booting from it works without issue.  The Lenovo recovery tool comes up, I accept, and it completes to the point where it asks me to remove the [removable media], which I do.  I hit OK - and it reboots.


So far, this all seems to work as advertised... then, it reboots.


A few DOS (cmd.exe) windows open up. 


Two are minimized, one is visible and has this in the titlebar: Administrator: X:\windows\system32\cmd.exe - startnet.cmd


This has a bunch of commands and messages, but it stops at a "Press any key to continue . . .", which is never good in an automated process.


The few lines prior to it stopping are as follows:


C:\SWWORK\VolumeD\HddInfo>goto error

C:\SWWORK\VolumeD\HddInfo>echo There is some error when read HDD info

There is some error when read HDD info

C:\SWWORK\VolumeD\HddInfo>echo HDDSUM=2


C:\SWWORK\VolumeD\HddInfo>echo Disk0.TotalSize=0

echo Disk0.TotalSize=0

C:\SWWORK\VolumeD\HddInfo>echo Disk1.TotalSize=0

echo Disk1.TotalSize=0


Press any key to continue . . .



The other two (minimized) DOS windows both show this:


Microsoft Windows [Version 10.0.1734.1]

Not enough memory resources are available to process this command.



Does anyone have any thoughts as to what I could do to fix this?  I've re-executed the recovery boot from USB twice with the same result.


Thanks in advance for any insight you may be able to offer!



Lenovo Legion Y530-15ICH - Core i7 - 16GB - 256GB NVME (Upgrade from 128 NVME) + 1TB 7200 RPM SATA


Legion Y530 - i7-8750H - 16GB - 128GB NVME/1TB HDD - nVidia 1050 Ti.
Fanfold Paper
Posts: 2
Registered: ‎11-20-2018
Location: CA
Views: 518
Message 2 of 2

Re: Using Lenovo Digital Download Recovery (DDRS) Fails

Well, I searched for the same type of problem and only found a few references.  What I found was happening was that there were three strange "devices" being detected that all had 0 bytes of space available/free.  They were what I would call "Phantom Drives".  The strange thing was, if you looked closely enough you'd find that they all had the exact same specs and identifiers as the NVME drive.


I went into DiskPart and performed a manual "rescan" and the disks dissapeared.  Unfortunately, the remaining disks were numbered 3 and 4, and the Lenovo restore scripts are looking for 0 and 1.  I rebooted after performing a "clean" on the two physical drives, and tried the Lenovo restore again - same results.  Apparently, there is no way to force the drives to renumber after the rescan.


At this point, I gave up - I pulled out the 256GB drive, and put the 128GB back in (the one that came with the laptop when I bought it) and everything worked immediately.  The Lenovo restore (which I didn't have to do, because the 128GB had the original image on it, but I did anyway as a test) loaded without issue, and the restore completed.


So, I guess this is a long-winded way of chalking this one up to a bad drive.  Good thing I didn't pay for it, and inherited it from someone Smiley Very Happy


Hopefully someone out there will find this helpful, if they ever run into the same problem.

Legion Y530 - i7-8750H - 16GB - 128GB NVME/1TB HDD - nVidia 1050 Ti.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!

Shop current deals

Top Kudoed Authors