English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

10 Posts

06-02-2015

CY

19 Signins

85 Page Views

  • Posts: 10
  • Registered: ‎06-02-2015
  • Location: CY
  • Views: 85
  • Message 1 of 14

Y520 Wifi keeps dropping every few seconds

2019-05-24, 10:16 AM

Hello

 

Lenovo Legion Y520. The Wi-Fi has been working fine for the past few months, but a couple of days ago started giving me problems. It frequently loses connection every 2-3 seconds (demonstrated by the ping report below). This doesn't happen on Ethernet.

 

Might be unrelated, but the problem started after installing Visual Studio 2019.

 

Tried:

- Uninstalling the card's drivers (rtl8821ae), installing the ones from realtek, installing the ones from lenovo vantage

- Checking the Event Viewer, nothing of interest

- Uninstall and re-install the card in its slot

- Disabling bluetooth (not using anyway)

 

- sfc /scannow

 

Any ideas?

 

 

 

Pinging 8.8.8.8 with 32 bytes of data:
Reply from 8.8.8.8: bytes=32 time=43ms TTL=55
Reply from 8.8.8.8: bytes=32 time=44ms TTL=55
Reply from 8.8.8.8: bytes=32 time=44ms TTL=55
Reply from 8.8.8.8: bytes=32 time=43ms TTL=55
Reply from 8.8.8.8: bytes=32 time=43ms TTL=55
Reply from 8.8.8.8: bytes=32 time=43ms TTL=55
Request timed out.
Reply from 8.8.8.8: bytes=32 time=46ms TTL=55
Reply from 8.8.8.8: bytes=32 time=44ms TTL=55
Reply from 8.8.8.8: bytes=32 time=42ms TTL=55
Reply from 8.8.8.8: bytes=32 time=42ms TTL=55
Reply from 8.8.8.8: bytes=32 time=42ms TTL=55
Reply from 8.8.8.8: bytes=32 time=42ms TTL=55
Reply from 8.8.8.8: bytes=32 time=41ms TTL=55
Reply from 8.8.8.8: bytes=32 time=42ms TTL=55
Request timed out.
Reply from 8.8.8.8: bytes=32 time=45ms TTL=55
Reply from 8.8.8.8: bytes=32 time=43ms TTL=55
Reply from 8.8.8.8: bytes=32 time=46ms TTL=55
Reply from 8.8.8.8: bytes=32 time=65ms TTL=55
Reply from 8.8.8.8: bytes=32 time=45ms TTL=55
Request timed out.
Reply from 8.8.8.8: bytes=32 time=537ms TTL=55
Reply from 8.8.8.8: bytes=32 time=44ms TTL=55
Reply from 8.8.8.8: bytes=32 time=42ms TTL=55
Reply from 8.8.8.8: bytes=32 time=43ms TTL=55
Reply from 8.8.8.8: bytes=32 time=55ms TTL=55
Reply from 8.8.8.8: bytes=32 time=47ms TTL=55
Reply from 8.8.8.8: bytes=32 time=45ms TTL=55
Request timed out.
Request timed out.
Reply from 8.8.8.8: bytes=32 time=46ms TTL=55
Reply from 8.8.8.8: bytes=32 time=41ms TTL=55
Reply from 8.8.8.8: bytes=32 time=47ms TTL=55

Ping statistics for 8.8.8.8:
    Packets: Sent = 34, Received = 29, Lost = 5 (14% loss),
Approximate round trip times in milli-seconds:
    Minimum = 41ms, Maximum = 537ms, Average = 61ms

 

 

Reply
Options

283 Posts

08-02-2018

US

221 Signins

1807 Page Views

  • Posts: 283
  • Registered: ‎08-02-2018
  • Location: US
  • Views: 1807
  • Message 2 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-25, 3:31 AM

Hi s0crates.

 

Thanks for reaching us here in our community forums.

Could you try these methods from our support website about the intermittent connection issue? Here's the link:
https://support.lenovo.com/us/en/solutions/ht502846

 

Keep us posted.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

10 Posts

06-02-2015

CY

19 Signins

85 Page Views

  • Posts: 10
  • Registered: ‎06-02-2015
  • Location: CY
  • Views: 85
  • Message 3 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-25, 5:35 AM
Hello, tried the said solutions, they didn't help unfortunately.
Reply
Options

283 Posts

08-02-2018

US

221 Signins

1807 Page Views

  • Posts: 283
  • Registered: ‎08-02-2018
  • Location: US
  • Views: 1807
  • Message 4 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-25, 8:41 AM

Thanks for trying the steps. If you're using a dual band router, could you try testing if you will have the same issue when connected to a 5GHz band and also when connected to a 2.4GHz band? Let us know how it goes.

 

Kind Regards.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

42 Posts

11-02-2018

US

46 Signins

668 Page Views

  • Posts: 42
  • Registered: ‎11-02-2018
  • Location: US
  • Views: 668
  • Message 5 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-25, 17:20 PM
To add on to Ashley-Lenovo's question does this happen on all Wifi connections or just a certain one?
Reply
Options

10 Posts

06-02-2015

CY

19 Signins

85 Page Views

  • Posts: 10
  • Registered: ‎06-02-2015
  • Location: CY
  • Views: 85
  • Message 6 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-26, 6:10 AM

I don't have access to my ISP's router settings, but the problem appears both at home and at work.

It's also important that the issue suddenly appeared on these networks which haven't changed. The laptop was working fine for more than 6 months now so I don't think the routers are to blame.

Reply
Options

42 Posts

11-02-2018

US

46 Signins

668 Page Views

  • Posts: 42
  • Registered: ‎11-02-2018
  • Location: US
  • Views: 668
  • Message 7 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-28, 1:18 AM
I wasn't sure how long or what variables were in play. Knowing that it happens on multiple networks helps narrow things down. You wouldn't have another wireless adapter to try like a usb or if you are comfortable with computers have you ever tried using a linux live cd. Since you tried to reinstall the drivers I am curious if it is wifi card related or possible windows problem. If the same thing were to happen using a linux live cd I would say faulty wireless card. I am sure there is a way to check or a program to test this out on windows but a figure a linux live cd removes any driver or windows problem.
Reply
Options

42 Posts

11-02-2018

US

46 Signins

668 Page Views

  • Posts: 42
  • Registered: ‎11-02-2018
  • Location: US
  • Views: 668
  • Message 8 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-28, 2:42 AM
Another thing to try without having to get a live cd or downloading anything would be to try to boot windows into safe mode with networking. Just throwing out ideas that might help.
Reply
Options

10 Posts

06-02-2015

CY

19 Signins

85 Page Views

  • Posts: 10
  • Registered: ‎06-02-2015
  • Location: CY
  • Views: 85
  • Message 9 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-28, 4:48 AM
Thanks for the ideas.. I'll give the live linux cd idea a go. Nothing to lose at this point.

From what I gather from other threads in this section some new driver is probably the issue, but going back didn't help in my case. I'll try to play a bit with older drivers as well and keep you posted
Reply
Options

42 Posts

11-02-2018

US

46 Signins

668 Page Views

  • Posts: 42
  • Registered: ‎11-02-2018
  • Location: US
  • Views: 668
  • Message 10 of 14

Re: Y520 Wifi keeps dropping every few seconds

2019-05-28, 7:01 AM
Please do I am very curious as to what is causing that to happen. I am curious if something simple like this would help https://www.howtogeek.com/265870/how-to-reset-your-entire-network-in-windows-10-and-start-from-scratch/ If you didn't mess with the drivers and you only installed visual studio I wouldn't think that would cause a problem with wifi. I do recommend getting a flash drive and setting up a couple of different distros to boot into like knoppix, kali, tails, ubcd, etc, in case of virus removal, boot repair, pentesting, privacy. If the computer works fine on one of those then I would try safe mode with networking to see if maybe its a program messing with your connection and start narrowing it down. Good luck and I hope you get it working.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete