Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

3 Posts

01-15-2019

United States of America

2 Signins

23 Page Views

  • Posts: 3
  • Registered: ‎01-15-2019
  • Location: United States of America
  • Views: 23
  • Message 1 of 3

Y530 Busted Bios, completely no response

2019-01-15, 3:43 AM

     So I was enjoing my evening, about to play a game when a window poped up saying “Lenovo reccomends this Bios update” So I click agree and it starts installing. For some reason I get convinced it is a virus and so I hit the power button to try to stop it. The computer cut power and now nothing, no reboot, no lights, nothing.

 

    From what I read I just destroyed my nice new laptop out of ignorance. And it is not covered by warranty.

 

    Is there anything I can do or is it just trashed? Is there a feature of booting the bios from a thumb drive, or some secret combo of buttons to push to get some sort of recovery going?

Reply
Answer
Options

3 Posts

01-15-2019

United States of America

2 Signins

23 Page Views

  • Posts: 3
  • Registered: ‎01-15-2019
  • Location: United States of America
  • Views: 23

Re: Y530 Busted Bios, completely no response

2019-01-15, 6:19 AM

Nevermind everyone, phoned an expert of sorts, he had me unplug the battery and the cmos battery, hold the power button for 30 seconds, replug the cmos battery, the battery, plug in the power supply and it booted right up in a minute or two, totaly fine now besides the time being an hour off.

Reply

Replies(2)
Answer
Options

3 Posts

01-15-2019

United States of America

2 Signins

23 Page Views

  • Posts: 3
  • Registered: ‎01-15-2019
  • Location: United States of America
  • Views: 23
  • Message 2 of 3

Re: Y530 Busted Bios, completely no response

2019-01-15, 6:19 AM

Nevermind everyone, phoned an expert of sorts, he had me unplug the battery and the cmos battery, hold the power button for 30 seconds, replug the cmos battery, the battery, plug in the power supply and it booted right up in a minute or two, totaly fine now besides the time being an hour off.

0 person found this solution to be helpful.

This helped me too

Reply
Options

17 Posts

08-31-2018

Portugal

37 Signins

709 Page Views

  • Posts: 17
  • Registered: ‎08-31-2018
  • Location: Portugal
  • Views: 709
  • Message 3 of 3

Re: Y530 Busted Bios, completely no response

2019-01-16, 20:19 PM
Good to know! You should mark your second comment as the solution to this thread :)
Legion Y53015ICH i7-8750H/16Gb RAM/GTX 1050Ti
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms