Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

39 Posts

01-10-2019

Turkey

109 Signins

865 Page Views

  • Posts: 39
  • Registered: ‎01-10-2019
  • Location: Turkey
  • Views: 865
  • Message 1 of 7

Y530 Sound Delay

2019-01-13, 18:53 PM

Hello,

 

I make a windows clean install and updated all the drivers from lenovo web page.

 

After some idle time for sound when i started music or system sound etc is delaying about 2 - 5 seconds and that causes a serious lag for system.

 

I think it's about realtek power management but i cant find the registry entries for it :(

 

Any help is appreciated.

Reply
Options

10 Posts

01-13-2019

Lithuania

13 Signins

141 Page Views

  • Posts: 10
  • Registered: ‎01-13-2019
  • Location: Lithuania
  • Views: 141
  • Message 2 of 7

Re: Y530 Sound Delay

2019-01-13, 23:15 PM

Same issue here. Searching for solutions...

Looks like Realtek audio drivers is messy

Reply
Options

10 Posts

01-13-2019

Lithuania

13 Signins

141 Page Views

  • Posts: 10
  • Registered: ‎01-13-2019
  • Location: Lithuania
  • Views: 141
  • Message 3 of 7

Re: Y530 Sound Delay

2019-01-14, 0:07 AM

After many times uninstalling realtek driver through device manager and restarting PC, I found a temporary solution.

Open Lenovo Vantage, select 'Media', scroll down to 'Dolby settings' and turn it off. Looks like audio is now working fine with no delay, but after you restart PC, same problem again...

Reply
Options

39 Posts

01-10-2019

Turkey

109 Signins

865 Page Views

  • Posts: 39
  • Registered: ‎01-10-2019
  • Location: Turkey
  • Views: 865
  • Message 4 of 7

Re: Y530 Sound Delay

2019-01-14, 9:37 AM
It's so weird. Does your system lag too? (visual lag)
Reply
Options

39 Posts

01-10-2019

Turkey

109 Signins

865 Page Views

  • Posts: 39
  • Registered: ‎01-10-2019
  • Location: Turkey
  • Views: 865
  • Message 5 of 7

Re: Y530 Sound Delay

2019-01-17, 12:17 PM
Is there any option to disable the delay from realtek regedit settings.
Reply
Options

1 Posts

07-17-2019

Dominican Republic

2 Signins

19 Page Views

  • Posts: 1
  • Registered: ‎07-17-2019
  • Location: Dominican Republic
  • Views: 19
  • Message 6 of 7

Re: Y530 Sound Delay

2019-07-17, 15:02 PM

I have the solution for this, I know is a little bit older this post but I found this setting in the bios when I was looking for another issue in the BIOS, first of all, you to need enter in the BIOS, since you are there, type:  Fn + Tab, Fn + ASDFGH, Fn + O, F10 (Yes), after that press F2 to enter the BIOS again and that will open some hidden features in the BIOS, in the advanced section look for "ACPI d3Cold settings" or just in case is different for you, look for some audio settings, then you will find "Audio Delay" and for me it was 200, I put that in 0, save the changes, restart and is done.

 

Some screenshots are attached to this reply for better understading purposes. (sorry for my english, I know it ins't that great)

screenshot 1

Screenshot 2

Screenshot 3

Reply
Options

39 Posts

01-10-2019

Turkey

109 Signins

865 Page Views

  • Posts: 39
  • Registered: ‎01-10-2019
  • Location: Turkey
  • Views: 865
  • Message 7 of 7

Re: Y530 Sound Delay

2019-07-17, 15:59 PM

Thank you so much İ'll try it later :)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All