Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

4 Posts

09-20-2019

Macedonia (the former Yugoslav Republic of)

7 Signins

78 Page Views

  • Posts: 4
  • Registered: ‎09-20-2019
  • Location: Macedonia (the former Yugoslav Republic of)
  • Views: 78
  • Message 1 of 4

Y540 "No speakers or headphones are plugged in" error

2019-09-20, 8:13 AM

Hi all!

First things first, this is a new machine, barely a week since I first turned it on. I tried several versions of Windows 10 and now I'm testing version 1703.

Long story short, these things happen every time:

1. Install Windows 10
2. Install all drivers and software
3. Wait until next day just to find out that audio is not working

4. Rinse and repeat

I seem to be having no issues with Windows 8.1 and Linux. While I don't mind staying on Windows 8.1, there seems to be a limited driver support for this version of Windows on this laptop and it's starting to get quite infuriating.

I tried setting the WiFi adapter transmit power to 4 from 5 as someone on reddit suggested but that doesn't help either.

The error code in Device Manager for Intel Display Audio and Realtek Audio is "Currently, this hardware device is not connected to the computer. (Code 45)"

As for the High Definition Audio Controller, it says: This device cannot start. (Code 10)

All of these errors occur after a while and I have no idea what's the trigger. Whenever I reformat Windows, I tried to shutdown and restart the laptop just so I can see it happen in front of my eyes but the stupid error happens after I go to sleep and wake the laptop the next day.

Thanks in advance!

Edit: Just wanted to say that headphones are working fine, it's just the internal speakers that are having this issue

Reply
Answer
Options

61 Posts

08-27-2019

Egypt

80 Signins

871 Page Views

  • Posts: 61
  • Registered: ‎08-27-2019
  • Location: Egypt
  • Views: 871

Re: Y540 "No speakers or headphones are plugged in" error

2019-09-20, 13:01 PM

From what you described, this 99% a software issue and mainly a driver issue too.

What I can think of right now is either windows updates the drivers when you're not using the laptop and somehow messes things up, or either your PC goes into sleep mode and has issues waking up.

I'd recommend you update windows first and reset your installation, even better if you could download the latest version and format the drive if possible, and also try manually putting your PC into sleep mode and see if the problem occurs due to that.

Reply

Replies(3)
Answer
Options

61 Posts

08-27-2019

Egypt

80 Signins

871 Page Views

  • Posts: 61
  • Registered: ‎08-27-2019
  • Location: Egypt
  • Views: 871
  • Message 2 of 4

Re: Y540 "No speakers or headphones are plugged in" error

2019-09-20, 13:01 PM

From what you described, this 99% a software issue and mainly a driver issue too.

What I can think of right now is either windows updates the drivers when you're not using the laptop and somehow messes things up, or either your PC goes into sleep mode and has issues waking up.

I'd recommend you update windows first and reset your installation, even better if you could download the latest version and format the drive if possible, and also try manually putting your PC into sleep mode and see if the problem occurs due to that.

0 person found this solution to be helpful.

This helped me too

Reply
Options

4 Posts

09-20-2019

Macedonia (the former Yugoslav Republic of)

7 Signins

78 Page Views

  • Posts: 4
  • Registered: ‎09-20-2019
  • Location: Macedonia (the former Yugoslav Republic of)
  • Views: 78
  • Message 3 of 4

Re: Y540 "No speakers or headphones are plugged in" error

2019-09-21, 10:24 AM

That does seem to be the issue. I've managed to turn the laptop on with the audio devices working. Sometimes they work, sometimes they don't.

 

I can try your suggestion regarding Windows. Latest version, right? 

Reply
Options

4 Posts

09-20-2019

Macedonia (the former Yugoslav Republic of)

7 Signins

78 Page Views

  • Posts: 4
  • Registered: ‎09-20-2019
  • Location: Macedonia (the former Yugoslav Republic of)
  • Views: 78
  • Message 4 of 4

Re: Y540 "No speakers or headphones are plugged in" error

2019-09-27, 20:33 PM
Reinstalled using the official media creation too from Microsoft, this seemd to fix the issue. Thanks a bunch!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms