cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
azekworlda
SCSI Port
Posts: 33
Registered: ‎07-13-2016
Location: IL
Views: 1,569
Message 1 of 4

Y700 - Lenovo.Modern.ImController 100% CPU usage

Latest Windows 10 build updates system version to 1607

Untitled.png100 % CPU usage

Y700-15ISK Touch/BIOS: CDCN37WW
i7-6700HQ/GTX 960M/(RAM) 16,0 /LITEON CV1-8B512
JDGillis
Bit Torrent
Posts: 2,600
Registered: ‎12-11-2015
Location: US
Views: 1,561
Message 2 of 4

Re: Y700 - Lenovo.Modern.ImController 100% CPU usage

The Lenovo Modern.ImController is part of Lenovo Settings, or more specifically its required "Lenovo System Interface Driver".

   

The CPU usage may go away by itself it given some time, but if not, go to  Control Panel -> Programs and Features -> uninstall the Lenovo System Interface Driver and reboot,    After Rebooting the problem will go away.    

 

Once uninstalled, you can go to Microsoft store and download Lenovo Settings again, during which you will be prompted to reinstall the Lenovo System Interface, and see if that fixes the problem.

 

Lenovo Settings is not a required program, but does provide some functionality, which is detailed more below.   

 

Lenovo Settings

http://shop.lenovo.com/us/en/accessories/software/apps/lenovo-apps/settings/

 

Good Luck,

 

azekworlda
SCSI Port
Posts: 33
Registered: ‎07-13-2016
Location: IL
Views: 1,547
Message 3 of 4

Re: Y700 - Lenovo.Modern.ImController 100% CPU usage

I use this wonderful beauty only for preserving battery 55-60%

Lenovo give me this option in my BIOS please!!!

PS: install/uninstall Lenovo Settings + "Lenovo System Interface Driver" It does not work for me.

Y700-15ISK Touch/BIOS: CDCN37WW
i7-6700HQ/GTX 960M/(RAM) 16,0 /LITEON CV1-8B512
sclexman
Bit Torrent
Posts: 4,580
Registered: ‎11-22-2011
Location: US
Views: 1,508
Message 4 of 4

Re: Y700 - Lenovo.Modern.ImController 100% CPU usage

What version of System Interface Foundation shows in programs and features?

Latest is  1.0.062.00. This version is also on your support page.

uninstall ... reboot.    install..reboot.  Otherwise settings will fail or other loops, etc.

Did you install companion from window store, if not give it a try.

Latest is 3.49.10

Did you install latest settings from window store? If so, does it launch?

Latest is 3.111.0.0

 

Companion and settings require SIF, not vice versa.

Another user(foooobar) in a other post stated:

I had the same problem too. All software up-to-date: Lenovo Settings, Lenovo Companion,  System Interface Driver. I started digging, and it turned out that the problem was occurring due to locked-down (by myself) privacy settings on Windows 10.

 

This is what I've done to fix it:

 

1. Open "Start" -> "Settings" -> "Privacy " -> "Other Devices"

 

2. Enable "Let apps use my ..."  [LAPTOP / COMPUTER etc]

 

3. Enable "Let these apps use my ..." [LAPTOP / COMPUTER etc] FOR:
•    Lenovo Settings
•    Lenovo Companion

Lenovo Settings and Lenovo Companion started working fine after this.

 

Hope it helps.

 

 This did not apply to me.

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors