Showing results for 
Search instead for 
Do you mean 
Reply
Punch Card
Posts: 57
Registered: ‎09-11-2016
Location: US
Message 1 of 6 (1,314 Views)

Y700 - Turn off Wifi from Keyboard - Windows 7

Hi, so I am running windows 7 x64 on a Y700 ideapad. I can't figure out how to turn off my wifi antenna. Looking at the keyboard I see the plane icon which normally means airplane mode. I want my wifi radio off and just use my lan line wire connection. 

 

Regardless if I press FN+airplane, in the the black window that pops up it says "first switch on the wireless device" which makes no sense. My wifi radio is on currently all drivers are upto date.

Bit Torrent
Posts: 1,909
Registered: ‎12-11-2015
Location: US
Message 2 of 6 (1,307 Views)

Re: Y700 - Turn off Wifi from Keyboard - Windows 7

I do not know why the airplane mode is saying to "first turn on the wireless device", but you can enable/disable the WiFi adapater by following the steps outlined in the link below.   Normally the Airplane mode is the on/off for the WiFi radio,m but it does not disable the card itself, while the steps linked below will.

 

How to turn wireless connectivity on or off in Windows 7

http://www.pcadvisor.co.uk/how-to/network-wifi/how-to-turn-wireless-connectivity-on-or-off-in-window...

 

 

Good Luck,

Punch Card
Posts: 57
Registered: ‎09-11-2016
Location: US
Message 3 of 6 (1,291 Views)

Re: Y700 - Turn off Wifi from Keyboard - Windows 7

Thanks for the reply. I understand how to turn off Wi-Fi via the control panel unfortunately I am looking for a way to do it from the keyboard since it's way faster and has always been available on every laptop I have ever owned.

Community Moderator
Posts: 944
Registered: ‎07-13-2010
Location: CA
Message 4 of 6 (1,287 Views)

Re: Y700 - Turn off Wifi from Keyboard - Windows 7

There must be an incompatibility with the WiFi driver used on Windows 7. On Windows 10, both the BT and WiFi devices power off immediately with the Airplane Mode key.

 

Have you tried installing the Windows 10 driver? It should install fine on Windows 7.

←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗
Tap that kudos button if I helped ^^
←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗
Bit Torrent
Posts: 497
Registered: ‎07-10-2016
Location: GB
Message 5 of 6 (1,268 Views)

Re: Y700 - Turn off Wifi from Keyboard - Windows 7


cloves wrote:

Hi, so I am running windows 7 x64 on a Y700 ideapad. I can't figure out how to turn off my wifi antenna. Looking at the keyboard I see the plane icon which normally means airplane mode. I want my wifi radio off and just use my lan line wire connection.


Have a look at this thread:

 

https://forums.lenovo.com/t5/Lenovo-IdeaPad-100-305-500-Edge/Ideapad-700-15ISK-wi-fi-not-working-in-...

 

Jorge-16 had the same problem as you, but found that installing the Lenovo "Energy Management" application enabled the F7 key to turn wi-fi and bluetooth on and off.  I am not exactly sure which laptop model he has, but with any luck the Y700 will be the same.

 

-- from CyberSimian in the UK

Punch Card
Posts: 57
Registered: ‎09-11-2016
Location: US
Message 6 of 6 (1,177 Views)

Re: Y700 - Turn off Wifi from Keyboard - Windows 7

Hi Cyber, saw that thread would, that work around does nothing for my Y700.

 

So I think I have narrowed down the problem. I am not sure what caused the wifi radio to turn off. The fn+f5 does not show any options at all when the energy manager menu shows up. I don't see the wifi or bluetooth in the Lenovo energy manager, its BLANK.

 

Anyways I rolled back with acronis to my windows 7 install from 2 weeks ago. Wifi was working. Now I checked the device manager, the bluetooth driver was missing. So I installed the intel bluetooth driver. I then rebooted and noticed I was getting a driver on/off in the device manager. It was showing the exclamation point on then off. I had to then install the other bluetooth driver set that is on the drivers page. After the reboot wifi is now working.

 

I am thinking that when I tried to turn wifi off, I did turn it off and there is NO WAY to turn it back on. This is clearly a software driver issue on Lenovo's end!

Top kudoed Authors