cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kristina92
Fanfold Paper
Posts: 6
Registered: ‎12-13-2016
Location: NO
Views: 1,405
Message 1 of 2

Y700 touchpad not working (unkown device)

I've had issues with the touchpad on and off ever since I bought this laptop. Sometimes it doesn't work after a startup (fixed with restart), just skips around after startup (fixed with restart) or the "advanced" touchpad functions like two finger scrolling etc. don't work after startup (fixed by reinstalling drivers + restart. 

 

But this time it's different. There is no mouse pointer, no function at all. I've rebooted several times. When I try to install a driver I am told there is "no appropriate driver to be installed". When I look in the device manager, there is no touchpad device but an unkown device. Its hardware ID is ACPI\VEN_FFF&DEV_FFFF which can't be right. I've tried uninstalling the unkown device and searching for hardware changes. I've tried updating the driver through windows. I've also tried installing the driver by using the "add legacy hardware" button but it did not work. And yes I have already checked that it's not disabled with the fn keys Smiley Happy

 

Please help Smiley Happy

Support Specialist
Posts: 2,948
Registered: ‎02-22-2017
Location: GB
Views: 1,360
Message 2 of 2

Re: Y700 touchpad not working (unkown device)

Hello Kristina92

Thanks for using the Lenovo forums.


Try to download the Chipset drivers for the unit from the support page.

 

Make sure to reboot after an update on the unit.


Hope this helps, let us know how you get on.


==================================================================================
Did someone help you today? Thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

 

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.



Pesszimistának lenni a legjobb, vagy igazad van, vagy kellemesen meglepődsz...

Check out current deals!


Shop current deals

Top Kudoed Authors