cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
icatalin78
SCSI Port
Posts: 65
Registered: ‎12-12-2017
Location: RO
Views: 416
Message 1 of 3

help - i messed up big time after bios update

help guys. i messed up and i cant boot anymore. after bios update (successful i think), my legion y720-151kb booted just fine up to the hdd hdd passwords prompt. then i typed the password i previously set and they were working fine before the bios update (same pass for both hdd - the 512gb samsung ssd and Seagate 2tb hdd) and surprise,the hdd pass worked but my ssd pass (main boot) didnt work anymore. how come after bios update one pass works and the other password doesnt. i need help please,i dont have password to enter bios but i cant enter bios to remove the passwords for ssd/hdd because i cant skip the hdd passes prompt. what can i do?can i do something?i guess i should have removed the passes before the bios update (started in win10 x64 and i guess it succeded since i am able to boot to ssd hdd pass prompt.

in a few words,here's the problem i have:

1. i previously set in bios passwords for both samsung 512gb ssd (os boot) and hdd seagate 2tb

2. i updated bios on my legion y720

3. after update,at boot i get the same prompt to enter hdd password (i had set only one user pass,the same for both). 2tb hdd passwd works, ssds doesnt work anymore

4. i cant enter bios and remove the hdd and ssd passwords (i didnt set a bios pass) since i cant skip the hdd hdd password prompt

what can i do?im im desperate. why is my old password not recognized anymore after bios update?system remembers the hdd pass but not the ssd 

 

PS: is it somehow possible to downgrade to my previous bios version (the one which recognized my ssd password) without booting into win10 or accessing Bios?and where can I find the previous bios version?I didn't find it on lenovo support, I bought my laptop in december 2017.

 

update: i removed the ssd and then i could boot to bios and have the hdd password removed but this didnt solve it because when i put the ssd back in,the same thing,it asks for password (the 2tb hdd is unlocked now so i could remove pass only for the hdd). that means the pass is on ssd. but again,is my old password,why it is not recognized anymore?just because i did a bios update?it should have worked,i know it and i entered the pass so many times before.what is the catch here?anyone? my ssd model is samsung mzvlw512hmjp-000l2

Social Support Agent
Social Support Agent
Posts: 296
Registered: ‎08-01-2018
Location: PH
Views: 208
Message 2 of 3

Re: help - i messed up big time after bios update

Hi icatalin78! 

 

Welcome to the community forums. 

 

Have you tried to use a different SSD if it will work if available? This is to isolate the BIOS update issue. 

 

For BIOS downgrade. See this Lenovo Forum thread: https://forums.lenovo.com/t5/Gaming-Laptops/Lenovo-Legion-Y720-Bios-Downgrade/td-p/4048058

 

Regards,

Matt_lenovo

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

icatalin78
SCSI Port
Posts: 65
Registered: ‎12-12-2017
Location: RO
Views: 199
Message 3 of 3

Re: help - i messed up big time after bios update

i dont have another ssd and my 2nd drive (2tb seagate is full,i dont have spare space to install on it win10). 

thank you for the link you provided,i have seen the option in bios but to be able to downgrade,i would need to install win10 on my 2tb seagate because i dont have another ssd. even if i do that, what is the original bios i has before the update and where can i find it? and even if i find it,would it make samsung ssd recognize my original pass?(i never change it thats the problem,only that after bios update, it was not recognized anymore - 2tb seagate recognized the pass but not the samsung).

maybe a better way would be to be able to secure erase the ssd because i had it put it inside my gf's acer laptop  and the problem is no soft can secure erase it.

The big question is this: why after bios update, at password prompt at boot:

1) 2tb seagate password is still recognized

2) 512gb samsung nvme ssd is not recognized anymore.

 

This is the real problem, because I didn't change the password and I put only one password for both drives.

Now, if I go back to previous bios (which I don't know what is and where to get it from), will it be ok?will it recognize my samsung password again or not?maybe samsung reverted to a factory password after bios change and if I downgrade to my previous bios it is useless.

What can I do?in Acer Aspire V15 it is recognized in win10 but I can't initialize it in drives management. In bios it is seen aswell. I removed secure boot in bios, I enabled legacy (it was on uefi) but still no luck to erase it using partmagic or ubuntu live nvme erase commands. PartMagic doesn't see it on uefi nor on legacy, on uefi secure boot disabled. I noticed when it loads it writes something on screen like: nvme i\o buffer error or something. On top of that, lenovo tool for secure erase (for thinkpad, hmmm) replies "it can only be run on real dos environment"....are you kidding???? I can make only a bootable freedos nowadays. brrrrr! It drives me crazy.

I actually think I give up. I'll let it rot in Acer and I'll buy a new super fast ssd , alot of money but it seems there is no way I can make 512gb work again.

Check out current deals!


Shop current deals

Top Kudoed Authors