Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

3 Posts

12-12-2018

United States of America

2 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎12-12-2018
  • Location: United States of America
  • Views: 40
  • Message 1 of 4

y520 won't use 1060 max-q

2018-12-12, 2:47 AM

Hi guys, im running out of ideas, recently i acquired a lenovo y520 and the problem is that the OS (windows 10 home) detects the gtx 1060 but refuses to use it beyond 10%...

 

the specs are these:

i5 7300hq

8gb ram ddr4 @2133mhz

Nvidia gtx 1060 max-q 3gb

 

 

Software:

Nvidia Drivers: 417.22

BIOS version: 5xcn10ww

 

 

 

how do i know this?:

i runned afterburner and the gpu maintains 40C and 600mhz running any game, and the performance is awful,

for example, i cant even get 30fps playing monster hunter on lowest settings.

 

what have i tried?:

i configured nvidia panel to use the gpu on global settings, also program settings individually.

 

thanks!

 

 

Reply
Answer
Options

1420 Posts

05-01-2012

Israel

2405 Signins

24102 Page Views

  • Posts: 1420
  • Registered: ‎05-01-2012
  • Location: Israel
  • Views: 24102

Re: y520 won't use 1060 max-q

2018-12-13, 7:37 AM

For better fps in games uninstall 417.22 and install 417.01.

Reply

Replies(3)
Options

792 Posts

07-25-2013

Australia

678 Signins

9430 Page Views

  • Posts: 792
  • Registered: ‎07-25-2013
  • Location: Australia
  • Views: 9430
  • Message 2 of 4

Re: y520 won't use 1060 max-q

2018-12-12, 23:08 PM

It looks like your laptop is not using the 1060 at all as in it's using the integrated GPU instead. The guide below is for Y530, but the steps are the same for Y520. Please give it a try and get back to us if that helped.

https://forums.lenovo.com/t5/Gaming-Laptops-Knowledge-Base/Utilizing-the-NVIDIA-GeForce-Graphics-of-your-Legion-Y530/ta-p/4189891

 

- The activity icon from Nvidia control panel will tell you whether the GPU is used or not

- Make sure the power settings are set to Hight Performance.

====================================
I'm an INsider - not a Lenovo employee.
You can find me in gaming, Ideapad and Thinkpad forums most of the time.
Reply
Answer
Options

1420 Posts

05-01-2012

Israel

2405 Signins

24102 Page Views

  • Posts: 1420
  • Registered: ‎05-01-2012
  • Location: Israel
  • Views: 24102
  • Message 3 of 4

Re: y520 won't use 1060 max-q

2018-12-13, 7:37 AM

For better fps in games uninstall 417.22 and install 417.01.

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

12-12-2018

United States of America

2 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎12-12-2018
  • Location: United States of America
  • Views: 40
  • Message 4 of 4

Re: y520 won't use 1060 max-q

2018-12-13, 16:29 PM

Thanks you sir, this solves the issue!

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms