cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 4,571

 

I wanted to run the supreme commander 2  game with the second screen enabled.  It showed me in the menu that it is disabled and I could not find a direct way to  enable it.

 

I tried to force it with altering the config, but no success while trying to alter this piece of game.perfs file:

 

 

    secondary_adapter = {
        default = 'disabled',
        custom = {
            states = {
                {
                    key = 'disabled',
                    text = '<LOC _Disabled>Disabled'
                }
            }
        }
    },

 

SOLUTION

 

You have to change it here:

 

 

            options = {
                mainmenu_bgmovie = true,
                tooltips = true,
                vsync = 1,
                joystick_vibration = true,
                keyboard_rotate_accelerate_multiplier = 2,
                FogOfWar = 'explored',
                NoRushOption = 'Off',
                master_volume = 100,
                wheel_sensitivity = 40,
                GameSpeed = 'normal',
                PrebuiltUnits = 'Off',
                antialiasing = 0,
                strategic_overlay = true,
                anisotropic_filtering = 8,
                lock_fullscreen_cursor_to_window = 0,
                subtitles = true,
                depth_of_field = 1,
                render_skydome = 1,
                joystick_zoom_speed = 16,
                show_attached_unit_lifebars = true,
                allmilitary = false,
                cinematic_subtitles = false,
                LastScenario = 'sc2_mp_204',
                joystick_invert_zoom = true,
                fidelity = 1,
                screen_edge_pans_main_view = 1,
                Victory = 'demoralization',
                allintel = false,
                vo_volume = 100,
                keyboard_pan_speed = 5400,
                keyboard_pan_accelerate_multiplier = 4,
                joystick_camera_rotation = true,
                primary_adapter = '1920,1200,60',
                secondary_adapter = 'disabled',
                CheatsEnabled = 'false',
                texture_level = 0,
                model_detail = 0,
                mp_taunt_head_enabled = 'true',
                Observers = 'Allowed',
                shadow_quality = 3,
                skin_change_on_start = 'yes',
                econ_warnings = true,
                arrow_keys_pan_main_view = 1,
                uvd_format = 'full',
                water_fidelity = 3,
                strat_icons_always_on = 0,
                fidelity_presets = 2,
                tooltip_delay = 0,
                joystick_pan_speed = 215,
                fx_volume = 100,
                quick_exit = 'false',
                TeamSpawn = 'random',
                UnitCap = '500',
                music_volume = 100,
                keyboard_rotate_speed = 10,
                display_eta = false,
                joystick_rotate_speed = 15,
                unit_health_bars = true,
                joystick_invert_rotation = false
            },

 

But after quiting game, you have to edit it again. Perhaps a bat  file could be made  to overwrite the gane.prefs before running game, or making it read-only.  

Was this information helpful?