English Community

Special Interest DiscussionsGeneral Discussion
All Forum Topics
Options

3 Posts

11-08-2011

Earth, Sector 2814

27 Signins

94 Page Views

  • Posts: 3
  • Registered: ‎11-08-2011
  • Location: Earth, Sector 2814
  • Views: 94
  • Message 1 of 7

Make the "Thinkpad Keyboard Properties" popup go away forever.

2011-11-19, 4:14 AM

I switched the Function keys back to "Legacy" in the BIOS so that I could actually work, and now when use Fn with any of the function keys to change the volume,brightness,wifi state, etc it pops up this @#$^% annoying box asking me if I want to restore the settings to default.

 

No I do not want to restore them to default. I will not want to restore them to default in 5 minutes, or 30 minutes, or a couple hours or tomorrow or next week. Stop asking me 30 times a day!

 

How do you make this popup go away FOREVER??!!!

Solved! See the solution
Reply
Options

2446 Posts

04-11-2011

Malaysia

1300 Signins

16673 Page Views

  • Posts: 2446
  • Registered: ‎04-11-2011
  • Location: Malaysia
  • Views: 16673
  • Message 2 of 7

Re: Make the "Thinkpad Keyboard Properties" popup go away forever.

2011-11-23, 5:42 AM
hey Threk,

do you have a software/driver installed call "hot key integration" ? if you do, remove that and see if the same pop-up appears.





WW Social Media
Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!



Follow @LenovoForums on Twitter!
Have you checked out the Community Knowledgebase yet?!
How to send a private message? --> Check out this article.
Reply
Options

1 Posts

11-27-2011

Prague

2 Signins

25 Page Views

  • Posts: 1
  • Registered: ‎11-27-2011
  • Location: Prague
  • Views: 25
  • Message 3 of 7

Re: Make the "Thinkpad Keyboard Properties" popup go away forever.

2011-11-27, 2:18 AM

Hello, I had the same problem so I decided to post my solution. Removing Hot Key Integration solves the issue, but also removes the other features like OSD, which is actually good.

 

I discovered a file responsible for this pop-up menu and the tab in the keyboard config is file "mkrcfg.dll" inside driver installation folder (should be: "C:\Program Files\Lenovo\HOTKEY"). If you rename/remove this file the ability to change between Legacy and Default from within an OS goes away (it can still be changed in BIOS). The pop-up "feature" will go away, but all other functions will stay.

 

I should also warn you, it's entirely possible the dll also includes some other functions related to keyboard and removing it might introduce some other problems. It seems to work fine for me, though. Proper solution would be for Lenovo to give user ability to remove this pop-up.

 

Bye. 

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

11-08-2011

Earth, Sector 2814

27 Signins

94 Page Views

  • Posts: 3
  • Registered: ‎11-08-2011
  • Location: Earth, Sector 2814
  • Views: 94
  • Message 4 of 7

Re: Make the "Thinkpad Keyboard Properties" popup go away forever.

2011-12-02, 9:27 AM

Thanks JSWM!

 

Just renaming mkrcfg.dll in C:\Program Files\HOTKEY by itself didn't make it go away, but renaming the other copies in C:\SWTOOLS\DRIVERS\HOTKEY\OSD\_amd64 and C:\SWTOOLS\DRIVERS\HOTKEY\OSD\_i386 and then rebooting did the trick.

 

Probably just the first file and a reboot would work, but since my search turned up 3 copies I renamed them all.

Reply
Options

2 Posts

12-13-2011

United Kingdom

4 Signins

37 Page Views

  • Posts: 2
  • Registered: ‎12-13-2011
  • Location: United Kingdom
  • Views: 37
  • Message 5 of 7

Re: Make the "Thinkpad Keyboard Properties" popup go away forever.

2012-08-01, 22:50 PM

I got task manager up and when I hold down the Fn key a program called MKRMSG.EXE starts up. 

 

I killed this and no more pop up.


i searched the registry for this and in "HKEY_LOCAL_MACHINE\SOFTWARE\LENOVO\MessageClient\MediaKey" it gave the defines this file as the receiver file, where MKRMSG.dll is the transmitter file.

the "ReceiverLocation" key gives the file location. I renamed the file to MKRMSG.EXE.bak

Seems to work so far ... 

Reply
Options

394 Posts

01-17-2012

NZ

682 Signins

4532 Page Views

  • Posts: 394
  • Registered: ‎01-17-2012
  • Location: NZ
  • Views: 4532
  • Message 6 of 7

Re: Make the "Thinkpad Keyboard Properties" popup go away forever.

2012-08-02, 5:03 AM
@davethejackal

Thanks!
_

ThinkPad X1 Yoga 2nd Gen, ThinkPad X230, ThinkPad S430, ThinkPad T420, ThinkPad E420s, ThinkPad E10s

Reply
Options

1 Posts

09-06-2014

graymouth

1 Signins

11 Page Views

  • Posts: 1
  • Registered: ‎09-06-2014
  • Location: graymouth
  • Views: 11
  • Message 7 of 7

Re: Make the "Thinkpad Keyboard Properties" popup go away forever.

2014-09-06, 0:13 AM

thank you ive been trying to get rid of it for ages

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete