English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

111 Posts

12-09-2018

GB

94 Signins

675 Page Views

  • Posts: 111
  • Registered: ‎12-09-2018
  • Location: GB
  • Views: 675
  • Message 1 of 10

Some of the characters on my keyboard aren't working properly.

2019-08-30, 11:12 AM

I've not checked every key but these are the main faults I've found so far:

 

(1) My 'AT' key brings up a single inverted comma '

(2) My capital double inverted commas brings up the AT key viz @

(3) With the Upper case key held down after JKL should be colon, AT and the horizontal squiggle. Instead I get these   :  "  

(4) In lower case, the last key on the ASDFGHJKL line should be the cross-hatch. I get \

 

What do I do to get back to normal please?

 

CPU Core i7 7700HQ 2.8GHz/KabyLake 14nm/8gbRAMSingle/M'board LNVNB161216 (U3E1)/Intel HD Graphics 630/4095MB NVIDIA GTX 1050 ForceWare/Win10x64/OFF365 Home
Reply
Options

111 Posts

12-09-2018

GB

94 Signins

675 Page Views

  • Posts: 111
  • Registered: ‎12-09-2018
  • Location: GB
  • Views: 675
  • Message 2 of 10

Re: Some of the characters on my keyboard aren't working properly.

2019-08-30, 22:17 PM

Has anyone any ideas please how I can stop all this nonsense with my keyboard please***? I have to submit online a lengthy freehand document to a UK Ombudsman tomorrow and with the keyboard not responding properly it's going to take me a very long time.

 

***PS I've had many laptops and desktops over the years but this is the first time that I've ever had this problem.

CPU Core i7 7700HQ 2.8GHz/KabyLake 14nm/8gbRAMSingle/M'board LNVNB161216 (U3E1)/Intel HD Graphics 630/4095MB NVIDIA GTX 1050 ForceWare/Win10x64/OFF365 Home
Reply
Options

8360 Posts

01-13-2008

US

77308 Signins

2194694 Page Views

  • Posts: 8360
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2194694
  • Message 3 of 10

Re: Some of the characters on my keyboard aren't working properly.

2019-08-31, 0:27 AM

It might help garner replies if we move your post to an appropriate forum.  What model laptop or desktop are we talking about?

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

111 Posts

12-09-2018

GB

94 Signins

675 Page Views

  • Posts: 111
  • Registered: ‎12-09-2018
  • Location: GB
  • Views: 675
  • Message 4 of 10

Re: Some of the characters on my keyboard aren't working properly.

2019-08-31, 7:46 AM

Hello. I have a Legion Y520. (I'm still setting it up, so when I've finished I'll update my signature.) But hang on a moment! I've just realised that my keyboard might be working properly. It is! I've just checked every key using notepad.

 

Just before 11pm last night (it's 8.35 am here at the moment) I was in the middle of a new Window Update when a message flashed up about a Lenovo update. I can't remember if I had to click on 'proceed' or similar but I did remember to capture this  snip.

 

 

I presume that this corrected the problem.  I hadn't realised that these updates take place. You can close this thread now - sorry that you've been troubled.

 

CPU Core i7 7700HQ 2.8GHz/KabyLake 14nm/8gbRAMSingle/M'board LNVNB161216 (U3E1)/Intel HD Graphics 630/4095MB NVIDIA GTX 1050 ForceWare/Win10x64/OFF365 Home
Reply
Options

9184 Posts

09-04-2014

SK

32614 Signins

1205950 Page Views

  • Posts: 9184
  • Registered: ‎09-04-2014
  • Location: SK
  • Views: 1205950
  • Message 5 of 10

Re: Some of the characters on my keyboard aren't working properly.

2019-08-31, 7:54 AM

On the limited information at hand I would suggest you check your selected default keyboard language setting or layout.  Some pointers on managing input and display language in Windows 10 from Microsoft;
https://support.microsoft.com/en-us/help/4496404/windows-10-manage-the-input-and-display-language

 

Andy

 

English Community Administrator
Lenovo eServices

Please remember to come back and mark the post that you feel answered your question as the solution. 
Did you find a post helpfull? You can thank the member by awarding them a Thumbs Up
 

Please don't ask me questions by Personal Message; questions belong in the forums.
Using Browser Search to find your answers in Lenovo and Moto Community

Reply
Options

111 Posts

12-09-2018

GB

94 Signins

675 Page Views

  • Posts: 111
  • Registered: ‎12-09-2018
  • Location: GB
  • Views: 675
  • Message 6 of 10

Re: Some of the characters on my keyboard aren't working properly.

2019-08-31, 8:57 AM

Hello Andy. I should have been clearer in my last post - my keyboard problem was cured by the Lenovo System Update. Thanks.

 

While you're on, would you please point me in the direction of where I can check to see what changes were made by the update? (i.e. the Lenovo equivalent of Windows Update History). Thanks

CPU Core i7 7700HQ 2.8GHz/KabyLake 14nm/8gbRAMSingle/M'board LNVNB161216 (U3E1)/Intel HD Graphics 630/4095MB NVIDIA GTX 1050 ForceWare/Win10x64/OFF365 Home
Reply
Options

111 Posts

12-09-2018

GB

94 Signins

675 Page Views

  • Posts: 111
  • Registered: ‎12-09-2018
  • Location: GB
  • Views: 675
  • Message 7 of 10

Re: Some of the characters on my keyboard aren't working properly.

2020-09-17, 9:27 AM
I was wrong when I said the problem has gone away. I'll update shortly
CPU Core i7 7700HQ 2.8GHz/KabyLake 14nm/8gbRAMSingle/M'board LNVNB161216 (U3E1)/Intel HD Graphics 630/4095MB NVIDIA GTX 1050 ForceWare/Win10x64/OFF365 Home
Reply
Options

111 Posts

12-09-2018

GB

94 Signins

675 Page Views

  • Posts: 111
  • Registered: ‎12-09-2018
  • Location: GB
  • Views: 675
  • Message 8 of 10

Re:Some of the characters on my keyboard aren't working properly.

2020-09-17, 9:35 AM

I'm still having the problem with characters not working properly. Looking at other threads here, it appears to be related to the fact that the Up arrows on this Legion Y520 don't work in the same way that they do on other make/model laptops.

 

Will someone please tell me how to resolve the problem. It's been dragging on for a very long time.

CPU Core i7 7700HQ 2.8GHz/KabyLake 14nm/8gbRAMSingle/M'board LNVNB161216 (U3E1)/Intel HD Graphics 630/4095MB NVIDIA GTX 1050 ForceWare/Win10x64/OFF365 Home
Reply
Options

111 Posts

12-09-2018

GB

94 Signins

675 Page Views

  • Posts: 111
  • Registered: ‎12-09-2018
  • Location: GB
  • Views: 675
  • Message 9 of 10

Re:Some of the characters on my keyboard aren't working properly.

2020-10-07, 17:53 PM

I posted again earlier today; I gave an example relating to my wife's problems. She couldn't take up special offers from Next, the UK's largest online clothing retailer, because of the farce with the keyboard character but I can't find my post now - it's not shown in my subscriptions. Where is it? 

The keys STILL aren't working properly. I've just had to send an urgent email to my garage about my previous MOT & service. It was ludicrous because the GBP key wasn't working. I first posted here over a year ago and you STILL haven't resolved the problem. 

If I don't get help from you in the next 24  hours I will escalate this to your CEO. The lack of help is appalling.

 

I've taken a screen print of this as proof that I posted this at 18.52 (6.52pm BST) on October 7th 2020.

CPU Core i7 7700HQ 2.8GHz/KabyLake 14nm/8gbRAMSingle/M'board LNVNB161216 (U3E1)/Intel HD Graphics 630/4095MB NVIDIA GTX 1050 ForceWare/Win10x64/OFF365 Home
Reply
Options

111 Posts

12-09-2018

GB

94 Signins

675 Page Views

  • Posts: 111
  • Registered: ‎12-09-2018
  • Location: GB
  • Views: 675
  • Message 10 of 10

Re:Some of the characters on my keyboard aren't working properly.

2020-10-22, 7:41 AM

As none of the experts here have bothered to hep me, you have now forced me to escalate this. I will now email Ms Jane Ashworth, Lenovo UK Director. If that fails to get this resolved, I'll escalate it to Mr Lanci, the Lenovo Europe President.

 

This really is the worst customer forum that I've ever been on. 

 

I now have to search the screen for the Sumit button. That's another problem that you haven't bothered to reply to

CPU Core i7 7700HQ 2.8GHz/KabyLake 14nm/8gbRAMSingle/M'board LNVNB161216 (U3E1)/Intel HD Graphics 630/4095MB NVIDIA GTX 1050 ForceWare/Win10x64/OFF365 Home
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete