English Community

Lenovo NotebooksLenovo U and S Series Notebooks Knowledge Base

Ideapad S-Series: Will Not Boot Up, No Screen, But LED Is On

Question

Scenario 1: My computer will not start. The power status LED flashes for a short time but nothing else happens - no HDD, no fan, and no display. What do I do? 

 

Scenario 2: Yesterday I shutdown to hibernate or sleep and my computer doesn't turn on. The power LED is lit but the system gives no other reaction -- no HDD, no fan, and no display. What do I do?

Answer

1: Remove the AC adapter plug.

2: Remove the battery.

3: Press the power button for about 30 seconds. This will clear the capacitors.

4: Insert the battery and plug in the AC adapter.

5: Press the power button.

 

Your computer should boot up as normal. If this does not help at first , try this process again.

Was this information helpful?

Yes No

Comments

Britt On 2010-11-22, 13:50 PM

I have just bought a Lenovo S10e from a friend, and I am experiencing the exact same problems....

(scenario 1 & 2)

It never boots, but just sort of shuts down with a 'click' sound.

 

I have tried to follow the above steps 1-5,

BUT unfortunately It does not fix the problem !

 

The computer does in fact start booting, and shows the Lenovo Quick Start menu :-)

BUT it stops and turns off in the middle of windows startup.

Or if I press F11 for recovery boot, it will stop and turn off before this has been completed.

Or if I leave it in the Quick Start Menu it will just turn off. 

 

I have tried to follow the steps like 20-some times  -  but so far it has shut down in the middle each time!

 

Any other suggestions out there?

Or must I give up and trash the computer?!

 

Thx in advance for any help you can give.

Brgds Britt 

Britt On 2010-11-22, 14:04 PM

(My) Problem seems solved...

 

I checked the Lenovo Support site for 'no power' :

 

And I tried double testing my power source:

 

quote

4) Verify the AC power source is working by attaching another device to the outlet.
unquote

 

Then  I also tried with a different power source...

Voila - computer booted sucessfully :-)

 

So in my case, it seems to be the the AC adapter which was the problem.

Mystery solved for now.

 

Rgds

Britt

 

sunshinea On 2013-11-27, 5:11 AM

sorry for making this thread back to life.. i have the same problem above.. ill just want to ask if theres any solution in my ideapad s10-3s its has no display. the first 3 icon indicator lights up but hdd indicator no light?

 

i did the above procedure but its no work for me.. its like its in sleep mode or hibernate mode or the hdd is like suspend .is there any others possible way to fix this? plz help me lenovo support team  and other smart guy here.. thnks...

tsmdevan On 2014-04-22, 16:09 PM

mine is ideapad s400u, i can see the screen after restart but screen brightness is verrrrrrry low i couldnt increase the brightness also please help me out. Also tried these 5 steps but it didnt workout for me. Cheers

 

M.Soma

Bonde On 2016-08-23, 9:13 AM

Hi,

I have the same problem.my lenovo idealpad s10-3s not working.after i push the power button the power light indicator on and the 3rd light on but the screen still black.what should i do?please need your help.

Andy_Lenovo On 2018-01-04, 1:00 AM

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop