English Community

Datacenter StorageLenovo Iomega Networking Storage
All Forum Topics
Options

9 Posts

12-13-2013

Louisiana

14 Signins

70 Page Views

  • Posts: 9
  • Registered: ‎12-13-2013
  • Location: Louisiana
  • Views: 70
  • Message 1 of 20

ix4-200d Help. Data Missing

2013-12-13, 20:22 PM

During the week while I was at work I recieved an email from the NAS that drive 1 had failed.  By the time I got home to address the issue I saw the following message:

 

4 new drives with existing data have been added to your Iomega StorCenter device.

The Iomega StorCenter device failed and some data loss may have occurred.

And on the LCD screen there is a prompt for permission to overwrite each disk which I have not done because I need to preserve my data.

 

I've powered down the drive and reseated all drives and booted back up but no luck.  I tried forcing device reconstruction from the support.html screen but the NAS does not react to this command.  I've also reset the device to factory settings to see if that would help but nothing.

 

I've tried ssh but cannot establish a connection.  I can however establish a connection via sftp.  I see lots of folders in the ftp client but nothing looks like my data.  I'm not sure if I'm supposed to be able to see my data via sftp or not so this does not immediately worry me. 

 

I am at a loss.  I've tried everything that I know how to do.  Does anyone have any receommendations?  Is it possible to pull each drive and and capture the data from each by connecting it to another pc?  Not sure if that's possible in a RAID environment but if so it may be my only hope.

 

If anyone has any input I'd greatly appreciate it.  I do not have a backup and this device houses photos of my children through the years that would be disasterous to lost.

 

Thanks so much for any help!

Reply
Options

9 Posts

12-13-2013

Louisiana

14 Signins

70 Page Views

  • Posts: 9
  • Registered: ‎12-13-2013
  • Location: Louisiana
  • Views: 70
  • Message 2 of 20

Re: ix4-200d Help. Data Missing

2013-12-13, 20:39 PM

I'm running version 2.1.42.18967.  I meant to ask if upgrading my help my situation.

 

Thanks again!

 

Reply
Options

9 Posts

12-13-2013

Louisiana

14 Signins

70 Page Views

  • Posts: 9
  • Registered: ‎12-13-2013
  • Location: Louisiana
  • Views: 70
  • Message 3 of 20

Re: ix4-200d Help. Data Missing

2013-12-13, 21:25 PM
I was able to get ssh access so if there is anything I can do via ssh or sftp I am able to connect both ways.
Reply
Options

1608 Posts

09-12-2013

Orem, UT

940 Signins

15739 Page Views

  • Posts: 1608
  • Registered: ‎09-12-2013
  • Location: Orem, UT
  • Views: 15739
  • Message 4 of 20

Re: ix4-200d Help. Data Missing

2013-12-14, 2:23 AM

Hi PDurandjr,

 

You can try shutting down the device, pulling the drives out, and then see if it will boot from any single hard drive.

 

If you want to get the data off by connecting it to a computer, it will have to be a Linux-based machine or software that will read Linux code.

Have questions and need answers?

Search the database for answers to FAQ's, software/driver downloads, tutorials, news, features and more!

LenovoEMC Support & Downloads

LenovoEMC North America Support Contact Page
Reply
Options

9 Posts

12-13-2013

Louisiana

14 Signins

70 Page Views

  • Posts: 9
  • Registered: ‎12-13-2013
  • Location: Louisiana
  • Views: 70
  • Message 5 of 20

Re: ix4-200d Help. Data Missing

2013-12-14, 3:15 AM

Hi Andrew and thanks for the reply.  What can I accomplish by trying to boot from just 1 drive?  My issue isn't that the NAS can't boot up.  I did go ahead and try this as recommended.  I booted up with only drive 1 connected.  It booted up and reported the missing drives and that 0 bytes of 0 bytes was used.  As mentioned, a drive 1 failure was the initial failure that I had. 

 

So, out of curiosity I powered down and tried booting up again with drive 4 connecetd.  This time the LCD screen displated a screen that I have not seen before.  It looks like a battery icon on the left side of the screen and a network icon on the right side of the screen.  I am not able to web admin to the NAS from here.

 

I think I like the idea of just trying to connect the drives to a PC and trying to recover the data using a tool in windows as you mentioned unless you have a better idea.  I found Linux Reader for Windows from SysInternals.  Looks simple to use.

 

I'll wait to hear from you before I do anything.

 

Thanks!

Reply
Options

1608 Posts

09-12-2013

Orem, UT

940 Signins

15739 Page Views

  • Posts: 1608
  • Registered: ‎09-12-2013
  • Location: Orem, UT
  • Views: 15739
  • Message 6 of 20

Re: ix4-200d Help. Data Missing

2013-12-14, 17:15 PM

You can try the troubleshooting suggestions here: http://forums.lenovo.com/t5/Lenovo-Network-Storage/Large-Battery-Icon-and-Network-Icon-Displayed-on-ix4-300d/m-p/1257645#M11

 

However, we cannot provide support for data recovery using a Linux reader for Windows.

Have questions and need answers?

Search the database for answers to FAQ's, software/driver downloads, tutorials, news, features and more!

LenovoEMC Support & Downloads

LenovoEMC North America Support Contact Page
Reply
Options

9 Posts

12-13-2013

Louisiana

14 Signins

70 Page Views

  • Posts: 9
  • Registered: ‎12-13-2013
  • Location: Louisiana
  • Views: 70
  • Message 7 of 20

Re: ix4-200d Help. Data Missing

2013-12-14, 18:36 PM

I understand that you cannot offer support on data recovery.  With that said, can you offer further support on getting my RAID working again within the NAS environment?

 

The link you are referring me to discusses issues with booting up the device.  Again. I have no problems booting up the device when all disks are inserted.  Is there anything else I can try?  Firmware upgrade?

Reply
Options

1608 Posts

09-12-2013

Orem, UT

940 Signins

15739 Page Views

  • Posts: 1608
  • Registered: ‎09-12-2013
  • Location: Orem, UT
  • Views: 15739
  • Message 8 of 20

Re: ix4-200d Help. Data Missing

2013-12-14, 19:00 PM

In this situation, there is nothing more I can do unfortunately. If you are willing to pay for support and call in to technical support, they may be able to ssh into your device to try to initialize the RAID reconstruction. Other options would be data recovery from Lenovo or another service.

Have questions and need answers?

Search the database for answers to FAQ's, software/driver downloads, tutorials, news, features and more!

LenovoEMC Support & Downloads

LenovoEMC North America Support Contact Page
Reply
Options

9 Posts

12-13-2013

Louisiana

14 Signins

70 Page Views

  • Posts: 9
  • Registered: ‎12-13-2013
  • Location: Louisiana
  • Views: 70
  • Message 9 of 20

Re: ix4-200d Help. Data Missing

2013-12-14, 20:20 PM

What is the success rate of attempting the RAID reconstruction via SSH?  I am able to SSH in.  Any shot you could just give me the command to kick off the process?

Reply
Options

1608 Posts

09-12-2013

Orem, UT

940 Signins

15739 Page Views

  • Posts: 1608
  • Registered: ‎09-12-2013
  • Location: Orem, UT
  • Views: 15739
  • Message 10 of 20

Re: ix4-200d Help. Data Missing

2013-12-14, 20:29 PM

I really can't say because I have not done it myself, that is left to the higher level technicians. I haven't been trained myself on the process, so I don't know the commands to do so.

Have questions and need answers?

Search the database for answers to FAQ's, software/driver downloads, tutorials, news, features and more!

LenovoEMC Support & Downloads

LenovoEMC North America Support Contact Page
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete