English Community

Lenovo DesktopsLenovo All In One (AIO) Desktops
All Forum Topics
Options

3 Posts

10-22-2015

US

7 Signins

61 Page Views

  • Posts: 3
  • Registered: ‎10-22-2015
  • Location: US
  • Views: 61
  • Message 1 of 2

B520 AIO - Possible motherboard or power supply failure?

2017-09-17, 16:24 PM

Starting in March this year, my Lenovo B520 AIO started to abruptly switch off after running for varying periods of time. During the first week, this would happen after the computer had been running for 3-8 hours, sometimes while I was actively using it and sometimes while I was not using either keyboard or mouse, but while the screen was on.

 

during the following couple of weeks, the machine would switch off after being turned on and running for only 5 to about 20 minutes at the most. I stopped using the machine at this point in April.

 

I've tried a few more times since then, using these short periods of activity to keep up to date with Windows 10 updates. All Lenovo drivers are at the current update versions.

 

Does this sound like the power supply is failing or could it be another problem. I'd like to repair the problem as simply and inexpensively as possible.

 

Thank you in advance for your advice.

 

Mod's Edit: Additional information added to Subject line for clarity of issue.

 

Reply
Options

9938 Posts

11-30-2015

PH

6778 Signins

729529 Page Views

  • Posts: 9938
  • Registered: ‎11-30-2015
  • Location: PH
  • Views: 729529
  • Message 2 of 2

Re: B520 AIO - Possible motherboard or power supply failure?

2017-09-20, 20:00 PM

Hi IvyGuy,

 

Greetings.

 

I would suggest that you try to back up your files when you got your opportunity after having the computer turned off for 1-2 hours (allowed time to cool off).

 

If you suspect a power problem, use the following procedures (page 20 of the hardware manual).

Check the following for proper installation: 
• Power adapter connector
• System Board Power adapter
connectors
• Microprocessor(s) connection

 

Check/Verify FRU/Action: Reseat connectors

 

If there is an event that it would again turn off while you're using it, check if turning it back on would immediately work or will it just turn on then off even shorter than it was when initially powered on. This event indicates probable heating issue, cleaning the fan system and reapplication of thermal paste can be done.

 

To isolate hardware issue from auto shut off due to software issue, try to run the machine and have it stay in the BIOS for several minutes to check if you would have the same symptoms. In the BIOS (tapping on F2 on start up), we have limited running resources that can delay the accumulation of heat so it may take a while. 

 

Take time to review the hardware manual for the disassembly guide for cleaning and reapplication of thermal paste else advance steps are needed and you may need to have it checked with a service center to isolate power supply/ motherboard/ RAM/ graphics/ fan/ CPU. 

 

Update us how it goes best for you.

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save