English Community

Lenovo DesktopsLenovo All In One (AIO) Desktops Knowledge Base

B310 camera does not work

Question

Had my desktop for 3  years but have never found how to switch the webcam on - sometimes it is on mostly not. When I open Lenovo Youcam it says 'No Webcam detected'.

 

How do I switch the webcam on?

Answer

For All-in-One desktops such as the B310, the camera automatically turns ON if an application triggers it, such as when a video application like Skype and YouCam is activated.

If you get the "No Camera Detected" error message, do the troubleshooting as below:

 

1) Check if the built-in camera is detected by the operating system through Device Manager

 

Go to Start > Control Panel > Device Manager > Imaging Devices

 

 

devicemanager.jpg

 

If the built-in camera is detected (see pic above), right cilck the "Integrated Camera" to uninstall it

 

Reboot for the camera's driver to be refreshed by its own.

 

 

2) Run Windows Update to get the latest patch and bug fixes for your operating system

To do so, go to Start > Control Panel > All Control Panel Items > Windows Update

 

windows update.jpg

 

After checking and installing the Windows Update(s), uninstall the camera driver from Control Panel and reinstall the drivers available here

 

Lenovo USB2.0 UVC Camera Driver

ID1CAM16WW5.exe
21.5 MB

 

 

3) If the webcam is still not detected, apply this USB binary fix and reboot

 

http://support.microsoft.com/kb/2529073

 

 

4) Device cable issue or defective

If problem persist, the camera is probably not getting detected properly or is already defective. Try to perform a factory reset using the OneKey Recovery button to isolate if the issue is OS level.

Was this information helpful?

Yes No

Comments

breezer3544 On 2015-05-07, 12:38 PM

ive done all this and it still say no webcam found 

breezer3544 On 2015-05-07, 12:41 PM

ive even done a factory reset cost me 27 pound for the disk and still no webcam or tv and my lenovo solutions centre does not work neither even tho ive run it in all compatibillity and run as admistraighter as well still not working 

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete