Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo DesktopsLenovo All In One (AIO) Desktops
All Forum Topics
Options

1 Posts

11-25-2021

Germany

3 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎11-25-2021
  • Location: Germany
  • Views: 10
  • Message 1 of 2

"A recently served boot binary is corrupt"

2021-11-25, 10:42 AM

My Windows 10 said it needs to update, so I restarted it. Instead of restarting, I got the following sequence of screens:

  • "Preparing automatic repair"
  • "Enter the BitLocker recovery key: " [I entered it]
  • "Diagnosing your PC"
  • "Your PC did not start correctly. Restart or AdvancedOptions"
  • When I click "Restart", the same sequence starts again. So I click "AdvancedOptions" and then "Troubleshoot".

In the troubleshoot screen, I tried the following:

  • Remove latest quality update: it failed.
  • Remove latest feature update: it failed.
  • Run "Startup Repair": I got a message "Startup repair could not repair your PC". It also referred me to a log file called SrtTrail.txt.
  • I opened the command line, opened the file SrtTrail.txt (using notepad), and at the bottom line, I saw the message: A recently served boot binary is corrupt.
  • I tried BootRec /FixMBR - I got the operation completed successfully.
  • I tried BootRec /FixBoot - I got access is denied.
  • I tried BootRec /RebuildBCD - I got total identified windows installations: 0.
  • I tried bcdedit /set {default} safeboot minimal to boot into safemode, but then rebooted and got to the start of the sequence.
  • I ran the lenovo Preboot System Performance check, as instructed in Lenovo Website, and after several minutes I got "success: result code 2000-0000", which means that "Pre-boot diagnostics test passed. No issues were found".
  • I ran ChkDsk /r. It told me that there are no problems with my drive. But I still get the same sequence
  • I did bcdboot c:\windows /s c:. I got a success message - "boot files created successfully" or something like that. But I still get the same sequence.
  • I tried sfc /scannow but got an error "windows resource protection could not perform the requested operation".

What more can I do to fix this error?

Technical details: I have Windows 10 on lenovo Desktop, BIOS version 1.20.0. No other OS is installed.

Web Address
Reply
Options

1605 Posts

07-22-2021

United Kingdom of Great Britain and Northern Ireland

276 Signins

7695 Page Views

  • Posts: 1605
  • Registered: ‎07-22-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 7695
  • Message 2 of 2

Re:"A recently served boot binary is corrupt"

2021-11-25, 14:38 PM

Hi

If you can include the full 10 character MTM in your next post please.

https://download.lenovo.com/pccbbs/thinkvantage_en/ldiag_4.41.0_windows_x64.exe

LENDIAGS.png

Running a Diagnostic may reduce the Time/Cost of any remedial work.

If in doubt please ask.


----------------

Forum, Agin 'em?
Uniquely Neutral

IdeaPad 3 17ITL6

MTM:- 82H9CTO1WW
OS's W10 & LINUX

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms