English Community

Lenovo DesktopsLenovo All In One (AIO) Desktops
All Forum Topics

2 Posts


Cincinnati OH, US

16 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎02-01-2011
  • Location: Cincinnati OH, US
  • Views: 25
  • Message 1 of 4

B305 IdeaCentre Wireless Connection Problem

2011-02-01, 6:32 AM

So I purchased my B305 from MicroCenter yesterday and was excited about it's wifi since I do not have the ability to run an ethernet cable to my work space. However, I have gone through some serious pain trying to get the wireless to work.


I was originally trying to connect to a Linksys WRT160N with and unsecured connection. Broadcast SSID and all, it could not even find this network, though my droid and another computer were connected with no problems. Desperate (and secretly eye-ing a new router with storage capabilities) I purchased the Linksys E3000. I used a wired connection to go through the setup process on another computer. Set to WPA-personal - I found and connected to network... connected with no internet.


I set the wireless to WPA/WPA2 Mixed Mode with security key for both 5GHZ and 2.4GHZ in router settings. I took primary and secondary DNS options and IP and default gateway from status screen and configured my IPV4 to manually connect to these. Wireless now shows conection and internet. When opening any browser page it spins and spins with no actual loading. Any web based PC options do not work either.


I also uninstalled and updated the wireless LAN driver from Lenovo site.


Any ideas or solutions?


11 Posts



569 Signins

479 Page Views

  • Posts: 11
  • Registered: ‎02-11-2011
  • Location: USA
  • Views: 479
  • Message 2 of 4

Re: B305 IdeaCentre Wireless Connection Problem

2011-02-18, 10:27 AM

Best thing to do is let trouble shooting do its job. RIght click on the wireless icon in lower right corner of the screen chose Trouble shoot problems and see if it can detect an fix the issue. Most likely with a static ip like you have it set for your not using the corrct ip . lets say your router ip is your gonna want a static ip to for your pc of somthing like I find it betst to use the option to obtain ip automagicly and make sure DHCP is enabled.There really is no need to use a static ip unless your going to port forward for a game or other application. and in most cases if you enable Upnp in the router you dont even need to port forward. Try the automatic ip if it dont connect to internet run trouble shoot connection. Let me know what that says if it still dont connect.


1 Posts



3 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎05-25-2011
  • Location: London
  • Views: 15
  • Message 3 of 4

Re: B305 IdeaCentre Wireless Connection Problem

2011-05-25, 11:28 AM

I am having a similar issue with the same model.


I have been connecting to my Sky router with no issues at all for the last two months. Suddenly last night, I started having issues. It can see the network, and sometimes even connects, but I don't get internet access. After a few seconds it will drop the connection, although usually it fails to connect at all. I should note at this point that my flatmates apple mac connects, my xbox can connect to live, and my htc sensation can connect, all via wifi. 


I ran through the troubleshooter - no joy. Ran a full virus and malware scan (just in case), rolled back my system by two weeks, started up in safe mode, reinstalled drivers, etc etc etc. Reaching the end of my tether! Am I gonna have to contact customer support? :(


1 Posts


Bedfordshire, UK

3 Signins

14 Page Views

  • Posts: 1
  • Registered: ‎09-22-2011
  • Location: Bedfordshire, UK
  • Views: 14
  • Message 4 of 4

Re: B305 IdeaCentre Wireless Connection Problem

2011-09-22, 20:23 PM

I am having exactly the same problem on by B310 - it keeps dropping wireless connections and claiming no internet when a laptop connects happily all day!


Did you find a solution James?  Many thanks in advance, Nick

Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop