Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo TabletsLenovo Android based Tablets and Phablets
All Forum Topics
Options

2 Posts

03-06-2013

North Carolina

1 Signins

6 Page Views

  • Posts: 2
  • Registered: ‎03-06-2013
  • Location: North Carolina
  • Views: 6
  • Message 1 of 3

My ideapad K1 won't download successfully

2013-03-06, 22:49 PM

My ideapad k1 won't download successfully. Also, when I try to us the internet, a notice comes on the screen saying that "there are problems with the security certificate for this site" this is while using Google chrome, and appears every time I try to switch web pages....yesterday, the problem was that the tablet wouldn't turn on.....now, it turns on but doesn't work right....also, it doesn't allow me to access the app store...

 

Moderator Note; added system type to subject

Reply
Options

6095 Posts

02-11-2012

Philippines

4461 Signins

274737 Page Views

  • Posts: 6095
  • Registered: ‎02-11-2012
  • Location: Philippines
  • Views: 274737
  • Message 2 of 3

Re: My ideapad K1 won't download successfully

2013-03-08, 22:16 PM

hi emaya_616,

 

Welcome to the Lenovo Forums.

 

Regarding your questions:

 

1. Have you tried to use the default web browser that came with the tablet and see if you can download files better there? If you still get the same problem, and you get also "Force Close" error, follow this guide but on step 6, force stop all Download Managers and the Norton Mobile Security.

 

2. For the "there are problems with the security certificate for this site" error, check if your system time is synchronized from today's date and try to use the built-in browser. You can also try Firefox or SkyFire.

 

3. Regarding the tablet not turning ON, try to do a power drain (remove AC adapter, hold power button for 30secs), then try to turn the tablet ON. If this problem is intermittent and the Lenovo logo just hangs, try to perform a factory reset by going to Settings > Privacy > Factory Data Reset.

 

4. If you get an error when opening the Google Play Store, you can re-install it by download the Google Play Store APK or you can do a factory reset.

 

 

Note:

Backup necessary files before doing a factory reset

 

 

Hope this helps.

 

Moderator Note; added system type to subject



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

266 Posts

08-27-2009

Virginia, USA

804 Signins

3933 Page Views

  • Posts: 266
  • Registered: ‎08-27-2009
  • Location: Virginia, USA
  • Views: 3933
  • Message 3 of 3

Re: My ideapad K1 won't download successfully

2013-03-10, 16:02 PM

emaya_616, you mentioned using the Chrome browser, and since Chrome won't run/install on the stock version of Android Honeycomb (3.2.1) which is formally supported on the K1, that sort of implies that you must have upgraded to one of the unofficial ICS (4.0) or JB (4.1) builds.  If so, you might want to provide more information about which build you are running, and when these problems started relative to when that upgrade was done.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms