English Community

Lenovo TabletsLenovo Android based Tablets and Phablets
All Forum Topics
Options

5 Posts

01-21-2012

united states

4 Signins

13 Page Views

  • Posts: 5
  • Registered: ‎01-21-2012
  • Location: united states
  • Views: 13
  • Message 1 of 9

wifi issues

2012-01-21, 5:20 AM
All

I have been relatively satisfied with my k1 except for one maddening issue. When the tablet goes into sleep mode, and wakes up, the internet stops working. I find that i have to either reboot he k1, or put the tablet into airplane mde, then backinto normal mode (effectvely restarting fhe wifi). Is there a fix forthis?

My wifi hotspot is fine, i have several devices hooked up to it, k1 is the only device with this problem
Reply
Options

14 Posts

12-20-2011

New Mexico

168 Signins

486 Page Views

  • Posts: 14
  • Registered: ‎12-20-2011
  • Location: New Mexico
  • Views: 486
  • Message 2 of 9

Re: wifi issues

2012-01-21, 12:28 PM

I had this same issue and when I started uninstalling recently installed apps. I found that installing  Moon Phase Pro triggers the problem.  You might look at any apps (widgets) that need location service at system start. YMMV

Reply
Options

167 Posts

11-26-2011

Bay Area

241 Signins

2309 Page Views

  • Posts: 167
  • Registered: ‎11-26-2011
  • Location: Bay Area
  • Views: 2309
  • Message 3 of 9

Re: wifi issues

2012-01-21, 16:37 PM

@rogers877

 

Does your K1 always fail to reconnect to wi-fi after going to sleep?

 

Have you tested different intervals when waking up from sleep?

 

Have you tested connecting to different AP's?

 

The behavior you are describing can sometimes be caused by DHCP lease time settings on your router.  May not be the case here, but certainly worth investigating.

Thanks,
Ricochet
The K1_Was Just A Broken Promise Lenovo
Reply
Options

5 Posts

01-21-2012

united states

4 Signins

13 Page Views

  • Posts: 5
  • Registered: ‎01-21-2012
  • Location: united states
  • Views: 13
  • Message 4 of 9

Re: wifi issues

2012-01-21, 17:55 PM

Thanks for the feedback

1) I dont have Moon Phase Pro

2) The lease time question is interesting -when i originally researched this, this seemed to be one of the 'fixes' lenovo is suggesting... but it doesn't seem to hold water for the following reasons

 

*I have 7 digital devices that connect to this router via wifi - I have never had any connectivity issue with any of these devices in terms of address lease expiration....

* my  ipod/ipads dont have this problem at all

 

 

My suspicion is that the K1 is trying to conserve battery power and as a result some fishy stuff happens in the wifi connection on sleep....this seems like an algorithm issue. perhaps they should consider automatically releasing/renewing the IP address on wake as part of the 'wake' algorithm? i am pretty sure i am not the only guy with this problem.....

 

I dont know if lenovo reads this, but i think there is some issue in the wifi connectivity algorithm. tablets should do 'nothing' really well, when i wake up my K1 it should have no problem with internet connectivity. i hope this is part of the next system update. im hopeful this can be fixed, if it is then the K1 is a great device (it is a given that android is still kind of clunky). my family doesnt like to use the K1 for this reason (connectivity) so right now i am the only user willing to put up with this bug in my household. i would like to not be the only user of the tablet at home.

 

FWIW, my K1 has had all the updates applied do it and is on android 3.2.1 (yes, i ran the new mystery update that was released this week)

 

Reply
Options

14 Posts

12-20-2011

New Mexico

168 Signins

486 Page Views

  • Posts: 14
  • Registered: ‎12-20-2011
  • Location: New Mexico
  • Views: 486
  • Message 5 of 9

Re: wifi issues

2012-01-21, 19:01 PM

You didn't mentioned what you had your WIfi disconect policy is set to or if you had experimented with the settings to see if it changes the problem?

Reply
Options

49 Posts

12-02-2011

California, U.S.

160 Signins

1321 Page Views

  • Posts: 49
  • Registered: ‎12-02-2011
  • Location: California, U.S.
  • Views: 1321
  • Message 6 of 9

Re: wifi issues

2012-01-22, 16:59 PM
What setting do you have for the WiFi disconnect policy?

It's under Settings, Wireless, Wifi Settings, WiFi Disconnect Policy. Make sure it's set to Never.

The network stack on Android has some kinks to be worked out for sure, but make sure you rule out the simple config possibilities first.
Builds:
01/18/2012 - K1_A301_14_14_120109_US
01//2012 - K1_A301_13_13_111209_US
12/2011 - K1_A301_12_12_111109_US
Reply
Options

5 Posts

01-21-2012

united states

4 Signins

13 Page Views

  • Posts: 5
  • Registered: ‎01-21-2012
  • Location: united states
  • Views: 13
  • Message 7 of 9

Re: wifi issues

2012-01-28, 15:57 PM
It is definitely set to never and i have the latest version of the kernel and android os

I reallly think this is bug in the device kernel....any lenovo guys lookin into this?
Reply
Options

167 Posts

11-26-2011

Bay Area

241 Signins

2309 Page Views

  • Posts: 167
  • Registered: ‎11-26-2011
  • Location: Bay Area
  • Views: 2309
  • Message 8 of 9

Re: wifi issues

2012-01-28, 16:28 PM
I have my wi-fi disconnection policy set to "When screen turns off". FWIW I have zero connectivy issues with my k1. Multiple routers, multiple locations. I don't use the never setting since I dont't want the device consuming power if I'm not using it. Sleep means sleep IMO :)
Thanks,
Ricochet
The K1_Was Just A Broken Promise Lenovo
Reply
Options

5 Posts

01-21-2012

united states

4 Signins

13 Page Views

  • Posts: 5
  • Registered: ‎01-21-2012
  • Location: united states
  • Views: 13
  • Message 9 of 9

Re: wifi issues

2012-01-28, 19:07 PM

I BELIEVE THIS WORKED - THANK YOU!!!

 

The 'Never' disconnect setting doesn't seem to work right - maybe Lenovo should just disable it as a feature.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete