cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LinuxRoach
Fanfold Paper
Posts: 10
Registered: ‎01-21-2019
Location: BE
Views: 685
Message 151 of 157

Re: Lenovo TAB3 Business TB3-X70F TWRP down

Mine was the S00008, I know because trying any of the "Business" ROMs suggested earlier in the thread failed to flash and, after letting the battery go flat and then recharging sent it back to the "original stock" which had been updated to the latest version previously.

 

Others got the "Business" ROMs to work BUT it looks like they had the 16GB model, mine was 32GB model so I wonder if that has some sort of influence on what works and what doesn't.

 

Fact is, using KamilMetze's advice, mine now works but says its a Tab 3 Business when connected to Windows 10 PC whereas before I'm sure it just said it was TB3-X70F according to Windows.

 

Go figure, but it looks like Lenovo made a complete fustercluck with the whole range with so much confusion between different models and even individual tablets.

Gu4n
Paper Tape
Posts: 3
Registered: ‎06-30-2018
Location: GB
Views: 667
Message 152 of 157

Re: Lenovo TAB3 Business TB3-X70F TWRP down

After several hours of reading/searching, I (a relative newbie) successfully rooted two TB3-X70F tab3 10 Plus tablets following KamilMetze's recipe.  One is a hardware version "50", the other a "51" according to the two digits in the brackets at the end of the serial number on their back.

Noob guide: 

The only things you need are Tzul's 'recovery_twrp303_TB3-X70F.img' file, a copy of the 'SuperSU v2.82-SR5 flashable zip' file and LMSA (it installs ADB, Fastboot and SP Flash Tool in its installation folders plus any USB Drivers you need).  
I followed this guide to get firmware version TB3_X70F_S000028_180108_ROW on to them both.  Instead of selecting the correct hardware version 50 or 51, choosing version '10' or '11' gets you the firmware that's compatible with Tzul's TWRP (prevents the screen from freezing).

 

Once you're on the latest firmware for model '10' or '11', follow instructions 1 to 3 here using KamilMetze's guide. 

haema
Punch Card
Posts: 32
Registered: ‎04-30-2017
Location: DE
Views: 479
Message 153 of 157

Re: Lenovo TAB3 Business TB3-X70F TWRP down

About bricked tabs

and

Netguard
I bought a second tab 3 10 wifi only 2/16 GB...since I managed to install the twrp in the first one , I didn't expect any problems. But I was wrong.
My new one is a also a Tab 3 10 plus but the serial nr is HKL....(52). The build nr was S00007....row. It gave me the notice , that an update to S0008... is available. But that didn't work.
So I used the lenovo smartassistant to flash S0028. That went well. But the flashing of the twrp ended with a not working touchscreen...probably I did not reboot after unlocking bootloader. I flashed the S0028 via spftool,which I downloaded from the smartassistant with the Windows Pc. That ended in a total brick. Thanks to the generous lenovo service, I got it back working.
Now it has the S00028_0180108 row!
For the moment my desire for rooting is satisfied.
I found netguard.app on the f-droid side which is different from the playstore app and followed the guide for the settings on:
https://www.kuketz-blog.de/netguard-firewall-android-unter-kontrolle-teil4/ .
With that I can block advertising and limit google appetite by stopping certain apps to go online.
Xprivacy is no longer developed ,that has also limited my interest in rooting. Also for example banking apps work not with rooted apps.

Hallo Quantum is your tab working again? You could send it in...

Hallo Mo I follow your story...yours is a sn.....(52) as well.

I noticed by the way, spftool would not load the scatterfile for S00025...row in my case, because the scatterfile was incomplete. After dowloading from tzuls archive it had the right size and worked!

 

Ano1
Blue Screen Again
Posts: 25
Registered: ‎06-20-2017
Location: US
Views: 469
Message 154 of 157

Re: Lenovo TAB3 Business TB3-X70F TWRP down

Xprivacy is still being developed I thought, but it's called "XivacyLua" now.

 

For rooting I nowaday use Magisk. Untill now no bank app has got problems with it.

 

Only problem I have is when Xposed is active, the Ziggo TV app refuses to work.

 

Rooting is still very convenient, main reason for me is to be able to restore backups of apps using Titanium Backup.

haema
Punch Card
Posts: 32
Registered: ‎04-30-2017
Location: DE
Views: 463
Message 155 of 157

Re: Lenovo TAB3 Business TB3-X70F TWRP down

Ano, you are right.On the rooted Tab  I use XPrivacy Version: 3.6.19 and enjoy it. The tab is still Android vers 6. Also trying things out and get back with twrp backup is undoubtedly an advantage.

The recently introduced code generator app for the DKB (Bank) doesn't install on rooted Tabs , but then mine is rooted with supersu. May be magisk would avoid that.

Ano1
Blue Screen Again
Posts: 25
Registered: ‎06-20-2017
Location: US
Views: 460
Message 156 of 157

Re: Lenovo TAB3 Business TB3-X70F TWRP down

There's a big chance that Magisk will work together with the bank app. It even has a special 'hidden mode' in case the standard settings don't work. So I would try it if I were you. Viel Glueck.

Apouro
Punch Card
Posts: 12
Registered: ‎11-08-2017
Location: SV
Views: 235
Message 157 of 157

Re: Lenovo TAB3 Business TB3-X70F TWRP down

Hello everyone, I hope you are well, you know how to use Google Translate to write to you.
if you do not remember my tablet Lenovo TB3-X70F was for consumption in China, but thanks to the data of the great @Tuzul I installed the version TB3-X70F_S000027_170619_ROW
Currently I get that there is an update TB3-X70F_S000028, but as much as I give update it does not.
I didn't really care since it worked well for me, but I could root it, today I was trying and despite the fact that with TWRP this is the last Magisk zip in the Manager, it tells me that it is not installed.
I don't know if it's related that I can't update the fact that I can't root it, can someone give me an idea?

Check out current deals!


Shop current deals

Top Kudoed Authors