cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Viper_Security
Paper Tape
Posts: 3
Registered: ‎03-03-2019
Location: US
Views: 2,572
Message 1 of 2

Need Stock Firmware/ROM for TB-X304F (Lenovo Tab 4 10)

I've posted on many different forums and no one can comeup with anything for my issue.

   https://forum.xda-developers.com/android/help/oem-unlocking-greyed-android-8-1-update-t3907510

   https://www.bleepingcomputer.com/forums/t/692651/oem-unlocking-greyed-out-after-android-81-update-le...

 

So if someone can help point me in the direction of STOCK Firmware/ROM For my Lenovo Tab4 10.1"  where the signature is VERIFIED and DOES NOT need a password, that'd be amazing, the lack of support for this tablet baffles me.

 

If more details are needed just ask.

LT410
Fanfold Paper
Posts: 1
Registered: ‎08-08-2019
Location: US
Views: 902
Message 2 of 2

Re: Need Stock Firmware/ROM for TB-X304F (Lenovo Tab 4 10)

I recently bought a LenovoTB-X304F running 7.1.1/NMF26F/TB-X304F_S000053_180927_ROW. Using Windows 8.1, I tried to root it, using the process specified for "Minimal ADB and Fastboot" to unlock it. It is unlocked now, according to recovery "DEVICE STATE - unlocked" and above it is "SECURE BOOT - enabled" but when I reboot I cannot get it past the Lenovo logo. The device no longer shows up in File Explorer nor Device Manager in Windows 8.1 although, previously, it did. When I try to connect it using Minimal ADB and Fastboot, Windows cmd.exe reports that the daemon starts at "tcp:5037"; "daemon started successfully," and; "error: no devices/emulators found".
I tried the method of downloading and saving "open_gapps-x86_64-7.1-full-20190807.zip" to a removable sandisk 16gb card that I formatted in my android phone then moved the downloaded .zip onto the card using the android phone's file explorer.
After installing the card in the tablet, and rebooting it into recovery, I wiped the cache partition and wiped data/factory reset and then I selected "Apply update from SD card" but when I reboot the "dead" Android icon briefly appears, disappears, and it goes into recovery and then I get this message:

 

"Supported API: 3
ro.boot.bootdevice is: 7824900.sdhci
--Install /sdcard/open_gapps-x86_64-7.1-full-20190807.zip ...
Finding update package ...
Opening update package ...
Verifying update package ...
E : failed to verify whole-file signature
Update package verification took 10.8 s (result 1).
E : Signature verification failed
E : error: 21
Installation aborted."

 

Prior to all of this, I saved a backup of the tablet, using TWRP, onto another sdcard but windows reports that card as "corrupted". But, I still do have that backup, assuming that Windows doesn't recognize the card and reports an error.

This tablet is about a week old.

Is there a way that I can still recover the tablet from the TWRP backup?

Thank you for your attention.

Check out current deals!


Shop current deals

Top Kudoed Authors