cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
saleemghani
What's DOS?
Posts: 1
Registered: ‎10-14-2015
Location: Maple Grove, MN
Views: 751
Message 1 of 3

B570 Stuck on lenovo logo No F2 and No F12

Hi,

 

I have 40 of these Lenovo B570's and within the last 1 month I now have 5 of these devices which get stuck on Lenovo Logo Screen

On the bottom I have F2 and F12 and the progress bar half way

 

It doesnt boot, doesnt go into BIOS and doesnt go into Boot Menu

 

Replaced, Batter, Hard-Drive, Memory, Wireless Card

sclexman
Bit Torrent
Posts: 4,580
Registered: ‎11-22-2011
Location: US
Views: 731
Message 2 of 3

Re: B570 Stuck on lenovo logo No F2 and No F12

Have you tried discharging static buildup? This may help.

 

1. Remove main battery
2. Remove power adapter
3. Press and hold down the power button for 30 seconds
4  Replace battery and power adapter

5. Reboot machine.

SeniorGuru
Posts: 2,246
Registered: ‎11-07-2014
Location: US
Views: 717
Message 3 of 3

Re: B570 Stuck on lenovo logo No F2 and No F12

Pull out the battery, disconnect the AC power then press and hold the power button for about 30 seconds. This will reset BIOS to factory settings.

Restore battery, AC power then enter bios with F keys or by booting from Lenovo Button. Set defaults then save and exit.

Check for proper operation, if works back up user files, and make recovery disks. If still not operational, try reinstalling the OS as it may have corrupt startup files.

Good luck.

CB

I do not work for Lenovo, I only provide suggestions based on my personal willingness to help others. All advice and comments are based on my experience, and do not reflect Lenovo policy, terms or conditions.

Check out current deals!


Shop current deals

Top Kudoed Authors