Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

3 Posts

08-10-2014

Los Angeles, CA

2 Signins

28 Page Views

  • Posts: 3
  • Registered: ‎08-10-2014
  • Location: Los Angeles, CA
  • Views: 28
  • Message 1 of 10

Boot with Num Lock turned on

2014-08-10, 17:11 PM

Hello all,

 

I have a G500 laptop.  When it boots up, I would like the Num Lock to automatically be turned on.  I can't see anything in the BIOS that would do that.  Any other places I should be looking?  Any other way to keep it turned on?

 

Thanks!

 

Dan Jablons

Retail Smart Guys

www.retailsmartguys.com

 

Reply
Answer
Options

3 Posts

08-10-2014

Los Angeles, CA

2 Signins

28 Page Views

  • Posts: 3
  • Registered: ‎08-10-2014
  • Location: Los Angeles, CA
  • Views: 28

Re: Boot with Num Lock turned on

2014-08-10, 19:36 PM
Actually, the fix was an edit to the registry.

Press Win + R and type in Regedit

Navigate to HKEY_USERS\Default\Control Panel\Keyboard

Right click on the "InitialKeyboardIndicators", select Modify and change
Value data to 2.

Exit Registry.

Reboot.

Reply

Replies(9)
Options

8980 Posts

01-13-2008

United States of America

77784 Signins

2227840 Page Views

  • Posts: 8980
  • Registered: ‎01-13-2008
  • Location: United States of America
  • Views: 2227840
  • Message 2 of 10

Re: Boot with Num Lock turned on

2014-08-10, 17:26 PM

Hi Dan, welcome,

 

I don't know if this will work on your specific machine or OS.  It did work (actually caused some problems) on a somewhat older machine.

 

Bring up the on-screen keyboard: in Win 7 start->search-> "on-screen keyboard".  Click the Options button and tick the "turn on numeric keyboard" check box.  That should add a NumLock key to the on-screen keyboard.  Click that.

 

On a U160 that caused NumLock to persist on reboot.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Answer
Options

3 Posts

08-10-2014

Los Angeles, CA

2 Signins

28 Page Views

  • Posts: 3
  • Registered: ‎08-10-2014
  • Location: Los Angeles, CA
  • Views: 28
  • Message 3 of 10

Re: Boot with Num Lock turned on

2014-08-10, 19:36 PM
Actually, the fix was an edit to the registry.

Press Win + R and type in Regedit

Navigate to HKEY_USERS\Default\Control Panel\Keyboard

Right click on the "InitialKeyboardIndicators", select Modify and change
Value data to 2.

Exit Registry.

Reboot.

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

04-01-2016

United States of America

1 Signins

6 Page Views

  • Posts: 1
  • Registered: ‎04-01-2016
  • Location: United States of America
  • Views: 6
  • Message 4 of 10

Re: Boot with Num Lock turned on

2016-04-01, 19:45 PM

Hi, I did this and nothing changed.  I have Windows 8.1.  Is there a different way to change the settings to boot with the Num lock turned on?

Reply
Options

3 Posts

09-13-2016

United Kingdom of Great Britain and Northern Ireland

8 Signins

67 Page Views

  • Posts: 3
  • Registered: ‎09-13-2016
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 67
  • Message 5 of 10

Re: Boot with Num Lock turned on

2016-09-13, 9:29 AM

I'm having this issue on a new C20 All-in-One, too. When turning on the PC the NmLk light is on, but after a couple of seconds, it turns itself off. Slightly annoying now that I use a pin to log in!

 

I have checked the BIOS and they are set correctly to Number Lock on.

 

I have checked the registry, and the setting there is '2'.

 

Anywhere else to look please?

 

Thanks

 

Reply
Options

4308 Posts

11-18-2012

United States of America

9980 Signins

610541 Page Views

  • Posts: 4308
  • Registered: ‎11-18-2012
  • Location: United States of America
  • Views: 610541
  • Message 6 of 10

Re: Boot with Num Lock turned on

2016-09-13, 14:27 PM

Welcome to the Lenovo Community salamat !

 

The suggestion originally offered in the beginning of this thread I believe refers a Windows 7 operating system due to the date of the posting.  Since then both Windows 8 and Windows 10 have a different Value to enter.  Please review this link.......

 

http://winaero.com/blog/enable-numlock-logon-screen-windows-10/

Reply
Options

3 Posts

09-13-2016

United Kingdom of Great Britain and Northern Ireland

8 Signins

67 Page Views

  • Posts: 3
  • Registered: ‎09-13-2016
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 67
  • Message 7 of 10

Re: Boot with Num Lock turned on (Accept as solution)

2016-09-13, 19:13 PM

Many thanks 'Majestic'! Although the initial suggestions didn't work for me, (or I wasn't following properly!), I read through the comments below and eventually came up with one that did, and am repeating below.

 

That registry setting 'initialkeyboardindicator' appears in several locations and as 'EMTammielee' pointed out, you need HKEY_USERS, not the HKEY_CURRENT_USER! Just changing this setting on it's own did not fix it, but when followed up with the power off from the log in screen, it did! 

 

<<<<< EMTammielee


I was changing the wrong registry key number. Misdirect to change the setting HKEY_CURRENT_USER which by default kept changing back to 2 on Windows 10. THIS IS NOT THE RIGHT LOCATION

This needs to be done under HKEY_USERS and changed the initialkeyboardindicator for ALL users.
HKEY_USERS => .DEFAULT=> Contorl Panel => Keyboard
edit the Initial Keyboard Indicator registry file to 2147483650 close registry, shutdown, reboot, at logon screen enable Numlock, proceed straight to the bottom right corner choose shutdown, reboot computer and BOOOOM your Numlock key should be working now. >>>>>

 

Many thanks to both!

 

Reply
Options

4308 Posts

11-18-2012

United States of America

9980 Signins

610541 Page Views

  • Posts: 4308
  • Registered: ‎11-18-2012
  • Location: United States of America
  • Views: 610541
  • Message 8 of 10

Re: Boot with Num Lock turned on (Accept as solution)

2016-09-13, 20:37 PM

You are more than welcome.

 

Glad to hear you were able to resolve the Num issue.  Thanks for posting back with an update.

Reply
Options

3 Posts

09-13-2016

United Kingdom of Great Britain and Northern Ireland

8 Signins

67 Page Views

  • Posts: 3
  • Registered: ‎09-13-2016
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 67
  • Message 9 of 10

Re: Boot with Num Lock turned on (Accept as solution) + Anniversary Update

2016-09-15, 11:16 AM

Installed the 'Anniversary Update' (14393.187) yesterday and on reboot, this turned the NmLk off, again.

 

However, applying the same fix did work.

Reply
Options

4308 Posts

11-18-2012

United States of America

9980 Signins

610541 Page Views

  • Posts: 4308
  • Registered: ‎11-18-2012
  • Location: United States of America
  • Views: 610541
  • Message 10 of 10

Re: Boot with Num Lock turned on (Accept as solution) + Anniversary Update

2016-09-15, 14:16 PM

:smileysad:

 

In revisiting that previous link to Winareo I see one person used a script to enable the Num lock which avoided any registry change.  Here is that posting copied from that thread......

 


"Bob

If for some reason Anniversary Update breaks your Numlock registry keys again, try this script: https://support.microsoft.com/en-us/kb/262625 It’s better than relying on Registry keys for numlock state. It can also be modified for CAPSLOCK or SCROLL LOCK."

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms