cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Bunty52718
Paper Tape
Posts: 3
Registered: ‎01-01-2018
Location: IN
Views: 1,567
Message 11 of 17

Re: Enable Touchpad while typing

Hi mate,
Thanks for your reply. Seems like now the right click is working but still i cant use tap function and neither the left click is working while holding a key. And i am changing the values from HKEY_CURRENT_USER instead of HKEY_LOCAL_MACHINE. Because that worked for me for enable the touchpad. Could you help me over it or send me any screenshots of your settings.
John-Jackson
What's DOS?
Posts: 1
Registered: ‎03-02-2018
Location: GB
Views: 1,456
Message 12 of 17

Re: Enable Touchpad while typing


@tylerdamiwrote:

Hi! 

 

I figured out how to fix this. It just involves a little registry tweaking:

 

Open regedit.exe as admin, navigate to:

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Elantech\SmartPad

 

Find the key named:

 

DisableWhenType_Enable

 

Double click and change the value to 0, close out and restart. Your touchpad is active while typing!

 

Good Luck!


Tyler

 -


Just signed up to add comment about new Lenovo laptops. If zeroing DisableWhenType_Enable does not works, try changing DisableWhenType_AllArea, DisableWhenType_AZone_TouchThenFree, DisableWhenType_Bottom_Range, DisableWhenType_DelayTime_Gesture, DisableWhenType_DelayTime_Move, DisableWhenType_DelayTime_Tap, DisableWhenType_Left_Range, DisableWhenType_Right_Range, DisableWhenType_Top_Range, DisableWhenType_Unit, DisableWhenTypeByApTime_Enable as well (every key that starts with DisableWhenType).

SprTchGmer
Paper Tape
Posts: 3
Registered: ‎01-14-2018
Location: AR
Views: 1,028
Message 13 of 17

Re: Enable Touchpad while typing

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Elantech\SmartPad DisableWhenType_AllArea DisableWhenType_Bottom_Range DisableWhenType_Enable DisableWhenType_Unit DisableWhenTypeByApTime_Enable All of these in 0. And DynamicPalmTap_Enable on 1. The same in Computer\HKEY_CURRENT_USER\Software\Elantech\SmartPad DisableWhenType_AllArea DisableWhenType_AZone_TouchThenFree DisableWhenType_Bottom_Range DisableWhenType_Enable DisableWhenType_Unit DisableWhenTypeByApTime_Enable All of these in 0 too. And DynamicPalmTap_Enable on 1 too. I don't know if only enabling DynamicPalm will do the trick, but at least in my notebook with those things in that way i can write and use the pad, and also use the features of 2, 3 and 4 fingers. Works for me but to be sure make a backup, i hope this helps (again sry if my english is bad)
AndrewTT
Paper Tape
Posts: 2
Registered: ‎12-09-2018
Location: AE
Views: 695
Message 14 of 17

Re: Enable Touchpad while typing

Thankyou so much for the solution but i still have a few more questions. They are:

Is there any method to press the left and right mouse button and make them both work, like for some games that have scope and shoot.

And even after the problem was solved i still see that there is a delay for the mouse to move after a button is pressed, so is it possible to remove this delay completely as sometimes buttons need to be pressed a bit fast which makes it look like it is locked like before when it is not. Holding a button shows no problem but pressing buttons continuously does show that delay.

 

Please help and thankyou for your time.

SprTchGmer
Paper Tape
Posts: 3
Registered: ‎01-14-2018
Location: AR
Views: 663
Message 15 of 17

Re: Enable Touchpad while typing

If your touchpad have buttons for left and right then u can by default, in my case it is only 1 button that detects the fingers, when pressing
on the right side makes secondary click, if it's left then primary. Some touchpads have only 1 button that recognizes where the fingers are.

about that delay it shouldn't have it, maybe an update changed some of the properties back to default, if not then idk.
if u just want to play probably the best will be buying a mouse, editing the registry can be somehow risky
I hope that helps (Again sry for bad english xd)

AndrewTT
Paper Tape
Posts: 2
Registered: ‎12-09-2018
Location: AE
Views: 636
Message 16 of 17

Re: Enable Touchpad while typing

Thankyou for replying, yes i thought that it should allow both to work together when i saw buttons but sadly it didnt turn out to be like that so i thought there might be a way to do so. (and you dont have bad english, just saying.)

CäT
What's DOS?
Posts: 1
Registered: ‎05-03-2019
Location: EE
Views: 308
Message 17 of 17

Re: Enable Touchpad while typing

Didn't work for me for some reason, tried it with restarting after doing it and tried without restarting, neither worked

Check out current deals!


Shop current deals

Top Kudoed Authors