cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mclbarri
What's DOS?
Posts: 3
Registered: ‎03-29-2011
Location: Argentina
Views: 271
Message 1 of 4

G40-30 don't turning on

My G40-30 is not turning on after a week without being used.

I've removed the battery pack but nothing happened.

With or without the battery the behaviour is the same.

After pressing the power button, nothing happens and power indicator blinks in white with a short and a long blink.

The only difference is that battery indicator is solid white when battery pack is installed.

Does anyone know what can be happening?

Thanks a lot.

 

Sr Support Specialist
Posts: 7,451
Registered: ‎11-30-2015
Location: PH
Views: 225
Message 2 of 4

Re: G40-30 don't turning on

Hi mclbarri  , 

 

Welcome to the Community Forums.

 

Best to follow the Power checkout steps from the hardware manual page 21

This would help isolate probable points of failure to check if the ac adapter / DC in port or system board itself is at fault as it should turn on even without battery . 

 

Cleaning out the fan and using one ram stick at a time testing on each slot can help further as turning on using the Novo Button isolate it from power button issue. 

 

Update us how it goes.

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

mclbarri
What's DOS?
Posts: 3
Registered: ‎03-29-2011
Location: Argentina
Views: 220
Message 3 of 4

Re: G40-30 don't turning on

I've followed the power checkout steps.

Nothing different has happened.

Voltage at the plug of the AC adapter cable is +20V.

I don't have another power supply or battery pack to test replacements.

With battery pack installed and AC adapter disconnected, when I press the power button both power and battery indicators blink and computer does not turn on.

With battery pack installed and AC adapter connected, battery indicator is solid white and when I press the power button the power indicator starts to blink (short and long) and computer does not turn on.

Without battery pack installed, behaviour is the same as above except for the battery indicator that is obviously not solid white.

Sr Support Specialist
Posts: 7,451
Registered: ‎11-30-2015
Location: PH
Views: 206
Message 4 of 4

Re: G40-30 don't turning on

Hi mclbarri , 

 

Greetings.

 

As Power checkout is done :

"4. If the voltage is acceptable, do the following: • Replace the system board."

 

Symptoms is a failed POST (power on self test) as you may need to have it further checked with local service center for confirmation specially if you had already tried cleaning fans, testing ram one at a time on each slot and reapplied thermal compound.

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Holiday Deals
HAPPENING NOW!

Get the best deals on PCs and tech now during the Holiday Sale
Shop the sale

Top Kudoed Authors