cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 25,732

Question

I just purchased a G505s laptop, and I now realize that the function keys (F1-F12) operate as Lenovo hotkeys by default, and I need to press th "Fn" key along with them in order to get them to function in their original mode.

 

This is not acceptable for my normal usage. I know with other Lenovo laptops, there is a BIOS setting that allows the user to either "disable" hotkey mode, or set them to "legacy" mode, but in the current BIOS/UEFI for the G505s there is no option to do so.

 

Are there any plans to release a new BIOS/UEFI for the G505s with this option implemented or if there is some Lenovo software I can download that will allow me to switch the Function/Hotkey behavior?

Answer

Such feedback had been conveyed to engineering for improvement. Now a new BIOS has been released to address this concern.

 

BIOS Update for Windows 8 (64-bit), 8.1 (64-bit)- Lenovo G405s, G505s - v2.03

Follow the instruction of installation and you should be able to use the function keys without FN right away. If it doesn't you have to enable it in BIOS.

 

Note: Make note of any settings you have changed in the BIOS Configuration Utility. These settings may have to be re-entered after updating the BIOS.

Attention: Do not power off or restart your computer during the BIOS flashing process, which will cause serious damage and improper functioning of your computer.

 

How to go to BIOS in Windows 8? Check out this article: How to get into BIOS in Windows 8.

 

How to enable in BIOS: 

  1. In BIOS, go to Configuration tab
  2. Arrow down to find "HotKey Mode"
  3. Press Enter to change from "Hotkey Mode" to "Legacy Mode".
  4. Press Fn+F10 to save the settings and exit BIOS

If you can't find the HotKey Mode, please try reloading BIOS Default Settings.

You can do so by going to Exit > Load Default Settings.

Was this information helpful?

Comments
LaronjohnCris

hello sir/maam i also have a problem in my lenovo ideapad100s. i am really more convinient of using Fkeys withour using Fn just like the function of a normal keyboard..i have read the manual and tells me that i should go to the bios to disable it. i have searched on my bios configuration many times but i never seen any setting that is made for disabling the hotkey..i also tried different methods suggested in the internet but doesnt make any difference. could you please help me.