English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

2 Posts

01-28-2016

Italy

3 Signins

15 Page Views

  • Posts: 2
  • Registered: ‎01-28-2016
  • Location: Italy
  • Views: 15
  • Message 1 of 4

G50-45 won't boot after bios upgrade

2016-01-28, 15:05 PM

Hi, I own a Lenovo G50-45 and, after installing Windows 10, i upgraded my bios to version 38, downloaded from here:
http://support.lenovo.com/it/it/products/laptops-and-netbooks/lenovo-g-series-laptops/g50-45-notebook-lenovo/downloads/DS100823

The upgrade process terminated at 100% and after showing "Updating ECM" or similar, the system shutted down.
Now I cannot boot anymore, I tried all procedures, keep pressing the power button, etc. but they don't work.

Reply
Options

2373 Posts

11-07-2014

US

1515 Signins

24041 Page Views

  • Posts: 2373
  • Registered: ‎11-07-2014
  • Location: US
  • Views: 24041
  • Message 2 of 4

Re: G50-45 won't boot after bios upgrade

2016-01-28, 18:51 PM

Have you tried to default the BIOS by removing AC power and Battery, then press and hold the power button for more than 10 seconds?  If not, you should try it, then when you have that completed, replace the main battery then AC power and attempt to boot the computer using the Lenovo button (has an upside down V on it) that is next to the power button.  This should allow you to enter BIOS where you can "reset to default" values, then save and exit.

 

If this does not work - you may need to contact a service center to have the system re-flashed.

 

CB


I do not work for Lenovo, I only provide suggestions based on my personal willingness to help others. All advice and comments are based on my experience, and do not reflect Lenovo policy, terms or conditions.
Reply
Options

2 Posts

01-28-2016

Italy

3 Signins

15 Page Views

  • Posts: 2
  • Registered: ‎01-28-2016
  • Location: Italy
  • Views: 15
  • Message 3 of 4

Re: G50-45 won't boot after bios upgrade

2016-01-28, 19:15 PM

Yes, I've tried everything.
I've also extracted the original firmware binary, renamed to LarneMLX64 and put to a pendriver.
Then, after pressing the power button for 10 seconds without battery, I've tried with all combinations:
Fn+Esc, Fn+r, Fn+b, and Win+b, but the motherboard never switches on, nor reads from pendrive.

Reply
Options

3 Posts

03-07-2017

HU

3 Signins

27 Page Views

  • Posts: 3
  • Registered: ‎03-07-2017
  • Location: HU
  • Views: 27
  • Message 4 of 4

Re: G50-45 won't boot after bios upgrade

2017-03-07, 22:40 PM

I had the very same issue and was spending 2 days reading comments. after I could get into bios setup by pressong the Novo button, I've enabled the BIOS back flash, change the boot mode (hdd was not visible) to Legacy support instead of UEFI. Boot priority i left uefi first, then finally before saving and exiting I've disabled the OS Optimized Defaults (on exit tab)

Not sure which of these steps solved my issue, I can only assume ut was the BOOT MODE CHANGE TO LEGACY

 

Boty

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete