Showing results for 
Search instead for 
Do you mean 
Reply
What's DOS?
Posts: 1
Registered: ‎03-08-2015
Location: USA
Message 1 of 2 (10,336 Views)

G50-70 Battery says "Plugged in, Charging" but not charging

My G50-70 of less than a year just got a dead battery.

 

The battery is constantly at 7%. It says "Plugged in, charging" but it doesn't actually charge.

 

Please help!

Retired Support Specialist
Posts: 2,277
Registered: ‎08-10-2014
Location: Bangalore
Message 2 of 2 (10,116 Views)

Re: G50-70 Battery says "Plugged in, Charging" but not charging

Hi Mistwild82,

 

Welcome to Lenovo Community!

 

As per the query we understood that you are facing issue with battery plugged in charging in your Lenovo Y50-70 laptop.

 

 Please try to perform the gauge reset, under power manager select maintenance guide and select gauge reset and check for the issue.

 

Also try to uninstall the Microsoft ACPI driver, uninstall the drivers under ACPI and restart the system and check for the issue.

 

Also shut down the system and try to charge the system for 1 or 2 hours and check if the charging percentage has increased. If the charging percentage has increased in Linux then it’s a issue with operating system please reinstall the operating system and check for the issue.

 

Hope this helps. Do post back if issue persists!

 

Best regards,       

                                     

Ashwin.S

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Top kudoed Authors