cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ZxFox
Paper Tape
Posts: 2
Registered: ‎05-20-2016
Location: SE
Views: 478
Message 1 of 3

G50-70 Wireless disconnects all the time

Hello,

 I have a probmelem with my wifi connection.

All other devices are working fine (phones, etc), but my G50-70 can suddenly disconnect from network and then not able to see it again for a few minutes.

 

I have Win10 x64 and Intel Dua-Band Wireless AC 3160.

Latest drivers (2016-01-05), v. 18.33.0.1, from Windows Update.

 

Wireless icon in windows always shows full connection.

I've tried to install Acrylic Wi-Fi Home monitor and it shows at least 2 bars and -60 RSSI.

 

Also, so far Wi-Fi is analyser is running I don't have any disconnects (so it keeps smth running?).

 

Any ideas?

Thx!

Sr Support Specialist
Posts: 8,910
Registered: ‎11-30-2015
Location: PH
Views: 469
Message 2 of 3

Re: G50-70 Wireless disconnects all the time

HI ZxFox , 

 

Welcome to the Community Forums. 

 

Initially try to maximize the power utilization of the WLAN card, 

Go to device manager and oprn network adapters as this would show the WLAN card. 

Right click for properties and from Power management tab , uncheck box for "allow device to save power" .

Go to advance tan and place any roaming aggressiveness / tendency to highest .

 

Update us how it goes.

 

Regards 

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

ZxFox
Paper Tape
Posts: 2
Registered: ‎05-20-2016
Location: SE
Views: 421
Message 3 of 3

Re: G50-70 Wireless disconnects all the time

Hi,

Okay, apparently, it happends a lot when you have a lot of networks nearby (I have like 16).

There is no workign solution for the problem. Latest drivers just make things worse (unfortunately, win10 gets the latest ones from update).

 

Setting roaming aggressiveness to lowet works best, but it still disconnects every 10 minutes.

https://communities.intel.com/thread/59439?start=45&tstart=0

 

Best solution so far is provided here :

https://www.msi.com/pic/faq/10015790@2015-0206-0239-237248@faq_0000000001178_en.pdf

they have the same problem.

 

Network strength of 2-3 bars f 5 doesn't exist for this adapter, it simply disconnects. One of the problems is that it is unable to see th network onece it drops connection without switching adapter on/off or using utilities like wifi scanner from Store.

 

The blue line in attachment is my neibourgs network... this is how it sees it.

Check out current deals!


Shop current deals

Top Kudoed Authors