Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

3 Posts

08-22-2014

UK

2 Signins

19 Page Views

  • Posts: 3
  • Registered: ‎08-22-2014
  • Location: UK
  • Views: 19
  • Message 1 of 4

G510 - conexant audio driver update won't install - no sound

2014-08-22, 19:36 PM

I have a Lenovo G510 running windows 8.1 64 bit, bought about 6 weeks ago. Installed windows updates on 18 August, including an optional driver update for the Conexant SmartAudio HD, and now there is no sound.

There is an exclamation mark next to the device in device manager and an error code for the driver that (until today) states 'Reinstall the drivers for this device. (Code 18)'. I have tried uninstalling and reinstalling many many times, including downloading the driver from the Lenovo website and using the driver from the D drive, with the same error:

Windows encountered a problem installing the driver software for your device.

Windows found driver software for your device but encountered an error while attempting to install it.

Conexant SmartAudio HD

Reinstall the drivers for this device. (Code 18)

 

I also tried doing a system restore to before the update but this failed with the message 'access denied'. After spending hours trying to find a fix I discovered that the driver update in question is still listed in windows update (now as 'important'). So I've downloaded and installed and restarted several times but still with the same error message, and the update is still listed in windows update. Update history states the audio device update was successful - every time I've downloaded and installed it - however it is not listed in 'installed updates'. I've also tried uninstalling and reinstalling all the other updates I originally installed on the 18 August.

 

Today, 22 August I tried uninstalling and reinstalling again and now the error message has changed to: 

Windows encountered a problem installing the driver software for your device.

Windows found driver software for your device but encountered an error while attempting to install it.

Conexant SmartAudio HD

This device is not configured correctly. (Code 1)

 

The events tab in device manager shows a list stating 'device installed' over and over. The information for the most recent event is as follows:

Driver Management concluded the process to install driver g13plmwa.inf_amd64_007bf12cd0f50a21\g13plmwa.inf for Device Instance ID HDAUDIO\FUNC_01&VEN_14F1&DEV_5115&SUBSYS_17AAC041&REV_1001\4&2426718C&0&0001 with the following status: 0x0.

 

I don't really know how to read all the info in the details tab but the capabilities property has a value of 00000000 which doesn't sound promising to me!

Status property reads:
01802400
DN_HAS_PROBLEM
DN_DISABLEABLE
DN_NT_ENUMERATOR
DN_NT_DRIVER

Config flags:

00000020

CONFIGFLAG_REINSTALL

 

Can post more from the details tab if that helps - I'm no techie so don't really know which bits of info are important. Would really appreciate some help here, I've searched and searched for a fix and posted the problem on a couple of other forums with no joy and I'm getting really frustrated with having no **bleep** sound!

Reply
Options

3 Posts

09-16-2014

4 Signins

34 Page Views

  • Posts: 3
  • Registered: ‎09-16-2014
  • Location:
  • Views: 34
  • Message 2 of 4

Re: G510 - conexant audio driver update won't install - no sound

2014-09-16, 12:24 PM

Hi there, I woke up today and tried to play some music, so I understood that something's wrong... I saw a x mark on the sound system that when I drive the coursor over it says ''the sound service is not performed'' what does this mean? sorry cause I really am not good with hardware nor software... I tried to install new drivers but nothing changed. Some other thing I reallised I can't access control panel... (though not sure if there is any on windows 8.1) I'll continue my tries and hope for a great answer, thank you.

Reply
Options

1 Posts

10-01-2014

Tehachapi

4 Signins

12 Page Views

  • Posts: 1
  • Registered: ‎10-01-2014
  • Location: Tehachapi
  • Views: 12
  • Message 3 of 4

Re: G510 - conexant audio driver update won't install - no sound

2014-10-01, 22:50 PM

Hi

 

I am having the same issue - I have tried all the suggestions and now I am getting a code 1 error in Device Manager.


Please help!

 

Reply
Options

3 Posts

08-22-2014

UK

2 Signins

19 Page Views

  • Posts: 3
  • Registered: ‎08-22-2014
  • Location: UK
  • Views: 19
  • Message 4 of 4

Re: G510 - conexant audio driver update won't install - no sound

2014-10-02, 17:23 PM

Well it turns out that my problem was entirely due to the firewall (ZoneAlarm) I'm running blocking the installation. All I had to do was temporarily disable it (making sure you also disconnect from the internet to avoid any nasties getting through) and reinstall the driver. 

 

Hope that solves your problem too, because I found both Lenovo and Microsoft support to be utterly useless on this. All they could suggest was what I had tried already, and then told me to do a factory reset. Glad I didn't listen and asked a friend who works in IT instead!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms