Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Fanfold Paper
Posts: 3
Registered: ‎08-04-2010
Location: Zagreb, CRO
0 Kudos

G555 Bios problem

[ Edited ]

Hi, today I bought Lenovo g555

after installing windows XP, I have installed all the drivers from lenovo site, and everything was ok, but then i realised that there is new bios for my laptop. when i flashed the bios my ati card was not recognized any more. i tried to reinstall the driver but nothing happens. My original bios was ( 2cec19ww (v1.06 ), and the new one is 2ccn21ww(v1.10).

I dont know what to do now, should i somehow clear the cmos and how? or can i find old bios firmware and where ?

Please help

Posts: 2,409
Kudos: 373
Solutions: 127
Registered: ‎06-05-2010
Location: Rosario, Santa Fe, Argentina
0 Kudos

Re: Bios problem

Try to enter BIOS and load default settings. If this doesn't solve this, maybe you need to call customer service.

IPnaSh
First Spanish Community Guru - Colaborador ad honorem

Lenovo
Fanfold Paper
Posts: 3
Registered: ‎08-04-2010
Location: Zagreb, CRO
0 Kudos

Re: Bios problem

I have already tried that.
Posts: 2,409
Kudos: 373
Solutions: 127
Registered: ‎06-05-2010
Location: Rosario, Santa Fe, Argentina
0 Kudos

Re: Bios problem

Maybe you should back to previous version. You need to contact customer suppor because Lenovo shows only the latest BIOS on download page.

IPnaSh
First Spanish Community Guru - Colaborador ad honorem

Lenovo
Fanfold Paper
Posts: 3
Registered: ‎08-04-2010
Location: Zagreb, CRO
0 Kudos

Re: Bios problem

My computer works again Smiley Very Happy

Since my bios was not bricked, I decided to install a win7x64 and to flash bios with x64 file. and guess what ? it works.  Smiley Tongue

Posts: 2,409
Kudos: 373
Solutions: 127
Registered: ‎06-05-2010
Location: Rosario, Santa Fe, Argentina
0 Kudos

Re: Bios problem

Cool! Smiley Very Happy

IPnaSh
First Spanish Community Guru - Colaborador ad honorem

Lenovo
Highlighted
Blue Screen Again
Posts: 2
Registered: ‎08-27-2010
Location: Slovakia
0 Kudos

Re: Bios problem

Congratulations. This is not a solution for XP user, though. I have the same problem. I was looking for the original BIOS on the net, but can't get it anywhere. I've also contacted the Customer support with no sucess. The only solution seems to be to ask for it here or another forum, if somebody has it backed up. Can someone help ?

Community Moderator
Posts: 13,431
Registered: ‎12-07-2009
Location: Česká Republika
0 Kudos

Re: Bios problem

updated Information:
the latest bios version supports ati m93 xt graphics card.

 

http://consumersupport.lenovo.com/us/en/DriversDownloads/drivers_show_3030.html


http://www.krasotaiskusstva.com
Posts: 1,524
Topics: 38
Kudos: 118
Solutions: 50
Registered: ‎04-20-2010
Location: Jeffersonville, Indiana
0 Kudos

Re: Bios problem

[ Edited ]

I just don't understand why people update the BIOS when they do not have an issue. I have NEVER updated any of my PC's BIOS. If it ain't broke don't fix it.

IT Specialist and Consultant
Lenovo Tablet Evangelist
Current Machines: IdeaCentre A300, ThinkPad Tablet, IdeaPad U410, and Yoga 3 Pro Touch

Deutsche Deutsche Community   Español Comunidad en Español

Lenovo - the latest in DOtabs, DOpads, DOcentre's, DOstations and DOservers!
Blue Screen Again
Posts: 2
Registered: ‎08-27-2010
Location: Slovakia
0 Kudos

Re: Bios problem

They do it to get support for new functions. Like USB booting.